mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/snd to 14.2-1
This commit is contained in:
parent
f229d609b7
commit
a958484704
2 changed files with 5 additions and 27 deletions
|
@ -7,29 +7,19 @@
|
|||
# - build with pulseaudio as sound server, not jack (x86 asm)
|
||||
|
||||
pkgname=snd
|
||||
pkgver=14.1
|
||||
pkgrel=2
|
||||
pkgver=14.2
|
||||
pkgrel=1
|
||||
pkgdesc="An advanced sound editor"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://ccrma.stanford.edu/software/snd/"
|
||||
license=('custom')
|
||||
license=('custom:free')
|
||||
depends=('pulseaudio' 'gamin' 'gsl' 'fftw' 'gtk2' 'libmpc')
|
||||
makedepends=('ladspa' 'wavpack' 'flac' 'speex' 'gmp'
|
||||
'timidity++' 'mpg123' 'vorbis-tools')
|
||||
optdepends=('wavpack' 'flac' 'speex' 'mpg123'
|
||||
'timidity++' 'vorbis-tools')
|
||||
source=("ftp://ccrma-ftp.stanford.edu/pub/Lisp/$pkgname-$pkgver.tar.gz"
|
||||
'type_error.patch')
|
||||
md5sums=('955ca19ca70ac0e4d03cd710516c0174'
|
||||
'9bfea0dccdfb5da1ba81e721672b11cc')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
# fix incomplete type error
|
||||
# see http://www.mail-archive.com/cmdist@ccrma.stanford.edu/msg04241.html
|
||||
patch -Np1 -i "$srcdir/type_error.patch"
|
||||
}
|
||||
source=("ftp://ccrma-ftp.stanford.edu/pub/Lisp/$pkgname-$pkgver.tar.gz")
|
||||
md5sums=('a442b98c75043bc8a4b9b50ba0c2b5b7')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
diff -bur snd-14.1.orig/snd-ladspa.c snd-14.1/snd-ladspa.c
|
||||
--- snd-14.1.orig/snd-ladspa.c 2013-10-28 16:07:53.260612114 +0800
|
||||
+++ snd-14.1/snd-ladspa.c 2013-10-28 16:11:18.792831983 +0800
|
||||
@@ -1191,7 +1191,7 @@
|
||||
if (descriptor->connect_port)
|
||||
descriptor->connect_port(XEN_TO_C_Ladspa_Handle(ptr),
|
||||
XEN_TO_C_ULONG(port),
|
||||
- double_to_float(samples->data, samples->length)
|
||||
+ double_to_float(mus_vct_data(samples), mus_vct_length(samples))
|
||||
);
|
||||
return(XEN_FALSE);
|
||||
}
|
Loading…
Reference in a new issue