mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
core/linux-armv7-rc to 4.15.rc8-1
This commit is contained in:
parent
ce591baadd
commit
ade04f7c89
12 changed files with 145 additions and 59 deletions
|
@ -1,7 +1,7 @@
|
|||
From 043141070b13388a29ce9f73d1378db6fee9ea00 Mon Sep 17 00:00:00 2001
|
||||
From 0b5434bba0eebdd9035b0d0184259006b4d5b8a0 Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
|
||||
Subject: [PATCH 01/10] ARM: atags: add support for Marvell's u-boot
|
||||
|
||||
Marvell uses a specific atag in its u-boot which includes among other
|
||||
information the MAC addresses for up to 4 network interfaces.
|
||||
|
@ -12,10 +12,10 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
|
|||
1 file changed, 17 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/include/uapi/asm/setup.h b/arch/arm/include/uapi/asm/setup.h
|
||||
index 979ff4016404..d1d0c1950fa4 100644
|
||||
index 6b335a9ff8c8..614150b53643 100644
|
||||
--- a/arch/arm/include/uapi/asm/setup.h
|
||||
+++ b/arch/arm/include/uapi/asm/setup.h
|
||||
@@ -143,6 +143,18 @@ struct tag_memclk {
|
||||
@@ -144,6 +144,18 @@ struct tag_memclk {
|
||||
__u32 fmemclk;
|
||||
};
|
||||
|
||||
|
@ -34,7 +34,7 @@ index 979ff4016404..d1d0c1950fa4 100644
|
|||
struct tag {
|
||||
struct tag_header hdr;
|
||||
union {
|
||||
@@ -165,6 +177,11 @@ struct tag {
|
||||
@@ -166,6 +178,11 @@ struct tag {
|
||||
* DC21285 specific
|
||||
*/
|
||||
struct tag_memclk memclk;
|
||||
|
@ -47,5 +47,5 @@ index 979ff4016404..d1d0c1950fa4 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.14.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
From 278772450de941a06782c07a43e7511b6bdbf430 Mon Sep 17 00:00:00 2001
|
||||
From 0f02774278458184fe86e3400a128a390ca57ba8 Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
loader
|
||||
Subject: [PATCH 02/10] ARM: atags/fdt: retrieve MAC addresses from Marvell
|
||||
boot loader
|
||||
|
||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||
addresses are extracted there and assigned to node aliases eth0..3
|
||||
|
@ -17,10 +17,10 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
|
|||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/compressed/atags_to_fdt.c b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
index 9448aa0c6686..ac7b6ae6c00f 100644
|
||||
index 41fa7316c52b..807ed160a4b9 100644
|
||||
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
@@ -18,7 +18,7 @@ static int node_offset(void *fdt, const char *node_path)
|
||||
@@ -19,7 +19,7 @@ static int node_offset(void *fdt, const char *node_path)
|
||||
}
|
||||
|
||||
static int setprop(void *fdt, const char *node_path, const char *property,
|
||||
|
@ -29,7 +29,7 @@ index 9448aa0c6686..ac7b6ae6c00f 100644
|
|||
{
|
||||
int offset = node_offset(fdt, node_path);
|
||||
if (offset < 0)
|
||||
@@ -179,6 +179,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
|
||||
@@ -180,6 +180,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
|
||||
initrd_start);
|
||||
setprop_cell(fdt, "/chosen", "linux,initrd-end",
|
||||
initrd_start + initrd_size);
|
||||
|
@ -43,5 +43,5 @@ index 9448aa0c6686..ac7b6ae6c00f 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.14.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From db678c33357f6349df02b0f4979fc8c9ee365697 Mon Sep 17 00:00:00 2001
|
||||
From 148f1387b852abf522bbcc6b770b663d6807012b Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||
Subject: [PATCH 3/9] SMILE Plug device tree file
|
||||
Subject: [PATCH 03/10] SMILE Plug device tree file
|
||||
|
||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||
dts with the LED definitions.
|
||||
|
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index faf46abaa4a2..aecdcfa7a67b 100644
|
||||
index d0381e9caf21..e142999e7cff 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -1010,6 +1010,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
|
||||
@@ -1046,6 +1046,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
|
||||
armada-370-db.dtb \
|
||||
armada-370-dlink-dns327l.dtb \
|
||||
armada-370-mirabox.dtb \
|
||||
|
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
|
|||
+ };
|
||||
+};
|
||||
--
|
||||
2.14.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 1b4696de4df2ebd2d2a0da05a284705e11427e06 Mon Sep 17 00:00:00 2001
|
||||
From c018608caafda694294105dcacf4c0cba5a3b14b Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||
Subject: [PATCH 4/9] fix mvsdio eMMC timing
|
||||
Subject: [PATCH 04/10] fix mvsdio eMMC timing
|
||||
|
||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||
of the Mirabox and SMILE Plug to work.
|
||||
|
@ -12,7 +12,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
||||
index 58d74b8d6c79..c9715530d676 100644
|
||||
index 210247b3d11a..1a1802dc9ef4 100644
|
||||
--- a/drivers/mmc/host/mvsdio.c
|
||||
+++ b/drivers/mmc/host/mvsdio.c
|
||||
@@ -93,7 +93,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
|
||||
|
@ -34,5 +34,5 @@ index 58d74b8d6c79..c9715530d676 100644
|
|||
host->clock = ios->clock;
|
||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||
--
|
||||
2.14.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
From ffd117b73c6a0185d3089ec9abee06122e88eecb Mon Sep 17 00:00:00 2001
|
||||
From 6c29f065fb016ebe3211b12a3251aeaef7e6c46c Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 05/10] net/smsc95xx: Allow mac address to be set as a
|
||||
parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
|
@ -91,5 +92,5 @@ index 309b88acd3d0..7bc9feb891a1 100644
|
|||
|
||||
/* maybe the boot loader passed the MAC address in devicetree */
|
||||
--
|
||||
2.14.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From e2567ba6352c663819406b73d4aa3aa31ad4ca06 Mon Sep 17 00:00:00 2001
|
||||
From 3df85aa11ccdf4a43e8869ca48d2a5e76edc46f0 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 14 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 6/9] set default cubietruck led triggers
|
||||
Subject: [PATCH 06/10] set default cubietruck led triggers
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -9,10 +9,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
||||
index 852a0aa24dce..82c963629a55 100644
|
||||
index 8c9bedc602ec..b3a765ba03fd 100644
|
||||
--- a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
||||
+++ b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
||||
@@ -69,6 +69,7 @@
|
||||
@@ -80,6 +80,7 @@
|
||||
blue {
|
||||
label = "cubietruck:blue:usr";
|
||||
gpios = <&pio 7 21 GPIO_ACTIVE_HIGH>;
|
||||
|
@ -20,7 +20,7 @@ index 852a0aa24dce..82c963629a55 100644
|
|||
};
|
||||
|
||||
orange {
|
||||
@@ -84,6 +85,7 @@
|
||||
@@ -95,6 +96,7 @@
|
||||
green {
|
||||
label = "cubietruck:green:usr";
|
||||
gpios = <&pio 7 7 GPIO_ACTIVE_HIGH>;
|
||||
|
@ -29,5 +29,5 @@ index 852a0aa24dce..82c963629a55 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.14.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From dc9e6fcc9675737091fb99550b361aea81a94b90 Mon Sep 17 00:00:00 2001
|
||||
From 0ce1c4867c66f0ee470904e9090a6c3d207b0b25 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 11 Aug 2016 00:42:37 -0600
|
||||
Subject: [PATCH 7/9] exynos4412-odroid: set higher minimum buck2 regulator
|
||||
Subject: [PATCH 07/10] exynos4412-odroid: set higher minimum buck2 regulator
|
||||
voltage
|
||||
|
||||
Set a higher minimum voltage to help reboot issue.
|
||||
|
@ -13,10 +13,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
|
||||
index 102acd78be15..5b65992e5667 100644
|
||||
index a21be71000c1..65cdf0d9c512 100644
|
||||
--- a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
|
||||
+++ b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
|
||||
@@ -423,7 +423,7 @@
|
||||
@@ -421,7 +421,7 @@
|
||||
|
||||
buck2_reg: BUCK2 {
|
||||
regulator-name = "vdd_arm";
|
||||
|
@ -26,5 +26,5 @@ index 102acd78be15..5b65992e5667 100644
|
|||
regulator-always-on;
|
||||
regulator-boot-on;
|
||||
--
|
||||
2.14.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From c5b29f6344d0e5da1d5ef64e4e7e5ed4937541be Mon Sep 17 00:00:00 2001
|
||||
From 7de44316a3c5f6c6121101fdbc3d28f8f90224ea Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 25 Feb 2017 19:39:51 -0700
|
||||
Subject: [PATCH 8/9] disable USB3 port on ODROID-XU
|
||||
Subject: [PATCH 08/10] disable USB3 port on ODROID-XU
|
||||
|
||||
Ports report over-current condition and are non-operable.
|
||||
|
||||
|
@ -11,7 +11,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/exynos5410-odroidxu.dts b/arch/arm/boot/dts/exynos5410-odroidxu.dts
|
||||
index c4de1353e5df..f80fa58995c5 100644
|
||||
index a45eaae33f8f..7f7de094724e 100644
|
||||
--- a/arch/arm/boot/dts/exynos5410-odroidxu.dts
|
||||
+++ b/arch/arm/boot/dts/exynos5410-odroidxu.dts
|
||||
@@ -630,6 +630,7 @@
|
||||
|
@ -23,5 +23,5 @@ index c4de1353e5df..f80fa58995c5 100644
|
|||
|
||||
&usbdrd_dwc3_1 {
|
||||
--
|
||||
2.14.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 43fc6d48884feb1d121bef1dd64ab444b5c46169 Mon Sep 17 00:00:00 2001
|
||||
From d1950bd64d45bb3e2dbca710b5aa68dbd3225ca3 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 7 May 2017 13:32:25 -0600
|
||||
Subject: [PATCH 9/9] ARM: dove: enable ethernet on D3Plug
|
||||
Subject: [PATCH 09/10] ARM: dove: enable ethernet on D3Plug
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -9,10 +9,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/dove-d3plug.dts b/arch/arm/boot/dts/dove-d3plug.dts
|
||||
index e88ff83f1dec..5004f09d76b7 100644
|
||||
index 826026c28f90..a4c9963e1261 100644
|
||||
--- a/arch/arm/boot/dts/dove-d3plug.dts
|
||||
+++ b/arch/arm/boot/dts/dove-d3plug.dts
|
||||
@@ -60,6 +60,13 @@
|
||||
@@ -61,6 +61,13 @@
|
||||
&uart0 { status = "okay"; };
|
||||
&sata0 { status = "okay"; };
|
||||
&i2c0 { status = "okay"; };
|
||||
|
@ -27,5 +27,5 @@ index e88ff83f1dec..5004f09d76b7 100644
|
|||
/* Samsung M8G2F eMMC */
|
||||
&sdio0 {
|
||||
--
|
||||
2.14.2
|
||||
2.15.0
|
||||
|
||||
|
|
|
@ -0,0 +1,81 @@
|
|||
From a8a2aa5970ad5d692db580f616ce4a3a1e7a7d18 Mon Sep 17 00:00:00 2001
|
||||
From: Arnd Bergmann <arnd@arndb.de>
|
||||
Date: Fri, 12 Jan 2018 11:12:05 +0100
|
||||
Subject: [PATCH 10/10] phy: work around 'phys' references to usb-nop-xceiv
|
||||
devices
|
||||
|
||||
Stefan Wahren reports a problem with a warning fix that was merged
|
||||
for v4.15: we had lots of device nodes with a 'phys' property pointing
|
||||
to a device node that is not compliant with the binding documented in
|
||||
Documentation/devicetree/bindings/phy/phy-bindings.txt
|
||||
|
||||
This generally works because USB HCD drivers that support both the generic
|
||||
phy subsystem and the older usb-phy subsystem ignore most errors from
|
||||
phy_get() and related calls and then use the usb-phy driver instead.
|
||||
|
||||
However, it turns out that making the usb-nop-xceiv device compatible with
|
||||
the generic-phy binding changes the phy_get() return code from -EINVAL to
|
||||
-EPROBE_DEFER, and the dwc2 usb controller driver for bcm2835 now returns
|
||||
-EPROBE_DEFER from its probe function rather than ignoring the failure,
|
||||
breaking all USB support on raspberry-pi when CONFIG_GENERIC_PHY is
|
||||
enabled. The same code is used in the dwc3 driver and the usb_add_hcd()
|
||||
function, so a reasonable assumption would be that many other platforms
|
||||
are affected as well.
|
||||
|
||||
I have reviewed all the related patches and concluded that "usb-nop-xceiv"
|
||||
is the only USB phy that is affected by the change, and since it is by far
|
||||
the most commonly referenced phy, all the other USB phy drivers appear
|
||||
to be used in ways that are are either safe in DT (they don't use the
|
||||
'phys' property), or in the driver (they already ignore -EPROBE_DEFER
|
||||
from generic-phy when usb-phy is available).
|
||||
|
||||
To work around the problem, this adds a special case to _of_phy_get()
|
||||
so we ignore any PHY node that is compatible with "usb-nop-xceiv",
|
||||
as we know that this can never load no matter how much we defer. In the
|
||||
future, we might implement a generic-phy driver for "usb-nop-xceiv"
|
||||
and then remove this workaround.
|
||||
|
||||
Since we generally want older kernels to also want to work with the
|
||||
fixed devicetree files, it would be good to backport the patch into
|
||||
stable kernels as well (3.13+ are possibly affected), even though they
|
||||
don't contain any of the patches that may have caused regressions.
|
||||
|
||||
Fixes: 014d6da6cb25 ARM: dts: bcm283x: Fix DTC warnings about missing phy-cells
|
||||
Fixes: c5bbf358b790 arm: dts: nspire: Add missing #phy-cells to usb-nop-xceiv
|
||||
Fixes: 44e5dced2ef6 arm: dts: marvell: Add missing #phy-cells to usb-nop-xceiv
|
||||
Fixes: f568f6f554b8 ARM: dts: omap: Add missing #phy-cells to usb-nop-xceiv
|
||||
Fixes: d745d5f277bf ARM: dts: imx51-zii-rdu1: Add missing #phy-cells to usb-nop-xceiv
|
||||
Fixes: 915fbe59cbf2 ARM: dts: imx: Add missing #phy-cells to usb-nop-xceiv
|
||||
Link: https://marc.info/?l=linux-usb&m=151518314314753&w=2
|
||||
Link: https://patchwork.kernel.org/patch/10158145/
|
||||
Cc: stable@vger.kernel.org
|
||||
Cc: Stefan Wahren <stefan.wahren@i2se.com>
|
||||
Cc: Felipe Balbi <balbi@kernel.org>
|
||||
Cc: Eric Anholt <eric@anholt.net>
|
||||
Tested-by: Hans Verkuil <hans.verkuil@cisco.com>
|
||||
Acked-by: Kishon Vijay Abraham I <kishon@ti.com>
|
||||
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
|
||||
Tested-by: Stefan Wahren <stefan.wahren@i2se.com>
|
||||
Acked-by: Rob Herring <robh@kernel.org>
|
||||
---
|
||||
drivers/phy/phy-core.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/drivers/phy/phy-core.c b/drivers/phy/phy-core.c
|
||||
index b4964b067aec..8f6e8e28996d 100644
|
||||
--- a/drivers/phy/phy-core.c
|
||||
+++ b/drivers/phy/phy-core.c
|
||||
@@ -410,6 +410,10 @@ static struct phy *_of_phy_get(struct device_node *np, int index)
|
||||
if (ret)
|
||||
return ERR_PTR(-ENODEV);
|
||||
|
||||
+ /* This phy type handled by the usb-phy subsystem for now */
|
||||
+ if (of_device_is_compatible(args.np, "usb-nop-xceiv"))
|
||||
+ return ERR_PTR(-ENODEV);
|
||||
+
|
||||
mutex_lock(&phy_provider_mutex);
|
||||
phy_provider = of_phy_provider_lookup(args.np);
|
||||
if (IS_ERR(phy_provider) || !try_module_get(phy_provider->owner)) {
|
||||
--
|
||||
2.15.0
|
||||
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=4
|
||||
|
||||
_rcver=4.15
|
||||
_rcrel=7
|
||||
_rcrel=8
|
||||
_rcnrel=armv7-x0
|
||||
|
||||
pkgbase=linux-armv7-rc
|
||||
|
@ -29,24 +29,26 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
|
|||
'0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
|
||||
'0008-disable-USB3-port-on-ODROID-XU.patch'
|
||||
'0009-ARM-dove-enable-ethernet-on-D3Plug.patch'
|
||||
'0010-phy-work-around-phys-references-to-usb-nop-xceiv-dev.patch'
|
||||
'config'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
'kernel_data_key.vbprivk'
|
||||
'linux.preset'
|
||||
'99-linux.hook')
|
||||
md5sums=('c94fe83caa8956ca6e751511d56513ba'
|
||||
'b683135f0c921993a93352f2c0cbafaf'
|
||||
'a9a96c56f83a0190a55511bf340774e1'
|
||||
'0783eff6ee3c3e69d860468ea350a091'
|
||||
'98c229baab4561144eb37210a20283a1'
|
||||
'a5a7083d247fd3827fe22b06b78f909c'
|
||||
'33067cc37863c18b4bc1820020c83859'
|
||||
'2dbc0a7f497085917711f3a0cc6aa66e'
|
||||
'1073c8192dc512674ccbf923334c5b79'
|
||||
'c1712dcecd00d08884cf2e078159b023'
|
||||
'90d0639b90925ad2e79cc26a7ec51e58'
|
||||
'acf068dc66ef7ac1fb625a2d5337336d'
|
||||
md5sums=('ad8277e87079747f0e352f1fba151d38'
|
||||
'51d94dedeccf5cd50b730f7a74095508'
|
||||
'13e49c73b6f8ada432b295ee3942cfbc'
|
||||
'd7c27c5fb5af85b5f964cc4e62b498b2'
|
||||
'3f3c1b782f6f39bed4b56b63e84436bd'
|
||||
'db48b4221f89e01c745b8a556bec4a4d'
|
||||
'35f0c38a1a6705aec91907422fea125b'
|
||||
'fbcc64d159c6d385cc9bea9d8517c816'
|
||||
'd8ef99d2fbab82b3f611ac168f2ee079'
|
||||
'61fa5c2852492dc079e20da535e59811'
|
||||
'04a7206ed51c3359154f5acaff0b95f4'
|
||||
'732d220643981cbcd77b8f499667a517'
|
||||
'6dba81bd6483c3d06e2a594b60fe4589'
|
||||
'4f2379ed84258050edb858ee8d281678'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
'584777ae88bce2c5659960151b64c7d8'
|
||||
|
@ -70,6 +72,7 @@ prepare() {
|
|||
git apply ../0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
|
||||
git apply ../0008-disable-USB3-port-on-ODROID-XU.patch
|
||||
git apply ../0009-ARM-dove-enable-ethernet-on-D3Plug.patch
|
||||
git apply ../0010-phy-work-around-phys-references-to-usb-nop-xceiv-dev.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 4.15.0-rc5-1 Kernel Configuration
|
||||
# Linux/arm 4.15.0-rc8-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -199,6 +199,7 @@ CONFIG_KALLSYMS_ALL=y
|
|||
# CONFIG_KALLSYMS_ABSOLUTE_PERCPU is not set
|
||||
CONFIG_KALLSYMS_BASE_RELATIVE=y
|
||||
CONFIG_BPF_SYSCALL=y
|
||||
# CONFIG_BPF_JIT_ALWAYS_ON is not set
|
||||
CONFIG_USERFAULTFD=y
|
||||
CONFIG_EMBEDDED=y
|
||||
CONFIG_HAVE_PERF_EVENTS=y
|
||||
|
|
Loading…
Reference in a new issue