mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/ruby2.7
This commit is contained in:
parent
9af6ed5dd6
commit
ae1d38996c
2 changed files with 101 additions and 0 deletions
|
@ -0,0 +1,39 @@
|
|||
From bc148b24448c68bc2720a10db4424d8a6d5772b3 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 14 Jan 2019 21:34:02 -0700
|
||||
Subject: [PATCH] Use only unsigned long for rb_serial_t
|
||||
|
||||
---
|
||||
internal.h | 12 ------------
|
||||
1 file changed, 12 deletions(-)
|
||||
|
||||
diff --git a/internal.h b/internal.h
|
||||
index baefb36c02..f57dc911ef 100644
|
||||
--- a/internal.h
|
||||
+++ b/internal.h
|
||||
@@ -1000,22 +1000,10 @@ struct rb_subclass_entry {
|
||||
rb_subclass_entry_t *next;
|
||||
};
|
||||
|
||||
-#if defined(HAVE_LONG_LONG)
|
||||
-typedef unsigned LONG_LONG rb_serial_t;
|
||||
-#define SERIALT2NUM ULL2NUM
|
||||
-#define PRI_SERIALT_PREFIX PRI_LL_PREFIX
|
||||
-#define SIZEOF_SERIAL_T SIZEOF_LONG_LONG
|
||||
-#elif defined(HAVE_UINT64_T)
|
||||
-typedef uint64_t rb_serial_t;
|
||||
-#define SERIALT2NUM SIZET2NUM
|
||||
-#define PRI_SERIALT_PREFIX PRI_64_PREFIX
|
||||
-#define SIZEOF_SERIAL_T SIZEOF_UINT64_T
|
||||
-#else
|
||||
typedef unsigned long rb_serial_t;
|
||||
#define SERIALT2NUM ULONG2NUM
|
||||
#define PRI_SERIALT_PREFIX PRI_LONG_PREFIX
|
||||
#define SIZEOF_SERIAL_T SIZEOF_LONG
|
||||
-#endif
|
||||
|
||||
struct rb_classext_struct {
|
||||
struct st_table *iv_index_tbl;
|
||||
--
|
||||
2.24.1
|
||||
|
62
community/ruby2.7/PKGBUILD
Normal file
62
community/ruby2.7/PKGBUILD
Normal file
|
@ -0,0 +1,62 @@
|
|||
# Contributor: Thomas Dziedzic <gostrc@gmail.com>
|
||||
# Contributor: Allan McRae <allan@archlinux.org>
|
||||
# Contributor: John Proctor <jproctor@prium.net>
|
||||
# Contributor: Jeramy Rutley <jrutley@gmail.com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to fix running ruby on 32-bit ARM
|
||||
|
||||
pkgname=ruby2.7
|
||||
pkgver=2.7.3
|
||||
pkgrel=1
|
||||
arch=(x86_64)
|
||||
pkgdesc='An object-oriented language for quick and easy programming, version 2.7'
|
||||
url='https://www.ruby-lang.org/en/'
|
||||
license=(BSD custom)
|
||||
depends=(libxcrypt gdbm openssl libffi libyaml gmp zlib)
|
||||
optdepends=(
|
||||
'tk: for Ruby/TK'
|
||||
)
|
||||
makedepends=(tk)
|
||||
options=(!emptydirs)
|
||||
source=(https://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.xz
|
||||
0001-Use-only-unsigned-long-for-rb_serial_t.patch)
|
||||
sha512sums=('b755d418b3bab2f9f6a8893afd13869269f17065643dde78b9e85ae3538a6d0617893db6e9c3908e00a40c7577a5c912a7c822d8f245cdcfb857be76dfb66c1e'
|
||||
'ae1a9e00ab3bfb1bf29cda872ddf6d64dd6ec5745bd25f00e3692a1d769dd81bbce8921ed63e0f5776ec3e610655087b739fde26ede9649c6c2e095b27381926')
|
||||
|
||||
prepare() {
|
||||
cd ruby-${pkgver}
|
||||
# fixes https://bugs.ruby-lang.org/issues/9507
|
||||
[[ $CARCH == 'arm' ]] && patch -Np1 -i ../0001-Use-only-unsigned-long-for-rb_serial_t.patch || true
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ruby-${pkgver}
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--program-suffix=-2.7 \
|
||||
--with-soname=ruby-2.7 \
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--sharedstatedir=/var/lib \
|
||||
--libexecdir=/usr/lib/ruby \
|
||||
--enable-shared \
|
||||
--disable-rpath \
|
||||
--with-dbm-type=gdbm_compat \
|
||||
--disable-install-doc
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ruby-${pkgver}
|
||||
|
||||
make DESTDIR="${pkgdir}" install-nodoc
|
||||
|
||||
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/ruby2.7/LICENSE"
|
||||
install -D -m644 BSDL "${pkgdir}/usr/share/licenses/ruby2.7/BSDL"
|
||||
|
||||
# remove files conflicting with 'ruby' package
|
||||
rm -r "$pkgdir"/usr/share/man/
|
||||
}
|
Loading…
Reference in a new issue