mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed extra/pyqt4
This commit is contained in:
parent
bc8c896f25
commit
afbe624120
2 changed files with 0 additions and 344 deletions
|
@ -1,113 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Andrea Scarpino <andrea@archlinux.org>
|
||||
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
|
||||
# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - Fix for QReal on ARM, for both python versions
|
||||
|
||||
pkgbase=pyqt4
|
||||
pkgname=('pyqt4-common' 'python-pyqt4' 'python2-pyqt4')
|
||||
pkgver=4.12.1
|
||||
pkgrel=2
|
||||
arch=('x86_64')
|
||||
url='http://www.riverbankcomputing.com/software/pyqt/intro'
|
||||
license=('GPL')
|
||||
makedepends=('python-sip' 'python-dbus' 'python2-sip' 'phonon-qt4' 'mesa'
|
||||
'python2-opengl' 'qt-assistant-compat' 'python2-dbus')
|
||||
source=("http://downloads.sourceforge.net/pyqt/PyQt4_gpl_x11-${pkgver}.tar.gz"
|
||||
"PyQt4-4.7.3-qreal_float_support.patch")
|
||||
md5sums=('0112e15858cd7d318a09e7366922f874'
|
||||
'7958e9e630963f1be44ea77c2329bb94')
|
||||
|
||||
build() {
|
||||
cd PyQt4_gpl_x11-${pkgver}
|
||||
patch -p1 -i "${srcdir}"/PyQt4-4.7.3-qreal_float_support.patch
|
||||
|
||||
cd "${srcdir}"
|
||||
cp -a PyQt4_gpl_x11-${pkgver}{,-py2}
|
||||
|
||||
cd PyQt4_gpl_x11-${pkgver}
|
||||
python configure-ng.py \
|
||||
--confirm-license \
|
||||
--no-sip-files \
|
||||
--qsci-api \
|
||||
-q /usr/bin/qmake-qt4
|
||||
|
||||
# Thanks Gerardo for the rpath fix
|
||||
find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
|
||||
|
||||
make
|
||||
|
||||
### Python2 version ###
|
||||
cd ../PyQt4_gpl_x11-${pkgver}-py2
|
||||
python2 configure-ng.py \
|
||||
--confirm-license \
|
||||
--no-sip-files \
|
||||
--qsci-api \
|
||||
-q /usr/bin/qmake-qt4
|
||||
|
||||
# Thanks Gerardo for the rpath fix
|
||||
find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package_pyqt4-common(){
|
||||
pkgdesc="Common PyQt files shared between python-pyqt4 and python2-pyqt4"
|
||||
depends=('qt4')
|
||||
replaces=('pyqt-common')
|
||||
conflicts=('pyqt-common')
|
||||
provides=("pyqt-common=${pkgver}")
|
||||
|
||||
cd PyQt4_gpl_x11-${pkgver}
|
||||
make -C pyrcc INSTALL_ROOT="${pkgdir}" install
|
||||
make -C pylupdate INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
install -Dm644 PyQt4.api "${pkgdir}"/usr/share/qt4/qsci/api/python/PyQt4.api
|
||||
|
||||
install -d "${pkgdir}"/usr/share/sip/PyQt4
|
||||
cp -r sip/* "${pkgdir}"/usr/share/sip/PyQt4
|
||||
}
|
||||
|
||||
package_python-pyqt4(){
|
||||
pkgdesc="A set of Python 3.x bindings for the Qt toolkit"
|
||||
depends=('python-sip' 'python-dbus' 'pyqt4-common')
|
||||
optdepends=('phonon-qt4: enable audio and video in PyQt applications'
|
||||
'qt-assistant-compat: add PyQt online help in Qt Assistant')
|
||||
replaces=('pyqt')
|
||||
conflicts=('pyqt')
|
||||
provides=("pyqt=${pkgver}")
|
||||
|
||||
cd PyQt4_gpl_x11-${pkgver}
|
||||
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
|
||||
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Provided by pyqt-common
|
||||
rm "${pkgdir}"/usr/bin/{pylupdate4,pyrcc4}
|
||||
rm "${pkgdir}"/usr/share/qt4/qsci/api/python/PyQt4.api
|
||||
}
|
||||
|
||||
package_python2-pyqt4(){
|
||||
pkgdesc="A set of Python 2.x bindings for the Qt toolkit"
|
||||
depends=('python2-sip' 'python2-dbus' 'pyqt4-common')
|
||||
optdepends=('phonon-qt4: enable audio and video in PyQt applications'
|
||||
'python2-opengl: enable OpenGL 3D graphics in PyQt applications'
|
||||
'qt-assistant-compat: add PyQt online help in Qt Assistant')
|
||||
replaces=('python2-pyqt')
|
||||
conflicts=('python2-pyqt')
|
||||
provides=("python2-pyqt=${pkgver}")
|
||||
|
||||
cd PyQt4_gpl_x11-${pkgver}-py2
|
||||
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
|
||||
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
|
||||
|
||||
# Fix conflicts with python-pyqt4
|
||||
mv "${pkgdir}"/usr/bin/{,python2-}pyuic4
|
||||
|
||||
# Provided by python-pyqt4
|
||||
rm "${pkgdir}"/usr/bin/{pylupdate4,pyrcc4}
|
||||
rm "${pkgdir}"/usr/lib/qt4/plugins/designer/libpyqt4.so
|
||||
rm "${pkgdir}"/usr/share/qt4/qsci/api/python/PyQt4.api
|
||||
}
|
|
@ -1,231 +0,0 @@
|
|||
diff -urN a/sip/QtCore/qlist.sip b/sip/QtCore/qlist.sip
|
||||
--- a/sip/QtCore/qlist.sip 2013-08-20 23:51:08.000000000 -0600
|
||||
+++ b/sip/QtCore/qlist.sip 2013-08-22 11:04:16.951816724 -0600
|
||||
@@ -819,3 +819,227 @@
|
||||
return sipGetState(sipTransferObj);
|
||||
%End
|
||||
};
|
||||
+
|
||||
+// If we're on an architecture where qreal != double, then we need to also
|
||||
+// explicately handle doubles. On architectures where qreal == double, they
|
||||
+// will automaticially be cast upwards
|
||||
+
|
||||
+%If (!PyQt_qreal_double)
|
||||
+
|
||||
+%If (Qt_4_3_0 -)
|
||||
+// QList<QPair<double, double> > is implemented as a Python list of 2-element tuples.
|
||||
+%MappedType QList<QPair<double, double> >
|
||||
+{
|
||||
+%TypeHeaderCode
|
||||
+#include <qlist.h>
|
||||
+#include <qpair.h>
|
||||
+%End
|
||||
+
|
||||
+%ConvertFromTypeCode
|
||||
+ // Create the list.
|
||||
+ PyObject *l;
|
||||
+
|
||||
+ if ((l = PyList_New(sipCpp->size())) == NULL)
|
||||
+ return NULL;
|
||||
+
|
||||
+ // Set the list elements.
|
||||
+ for (int i = 0; i < sipCpp->size(); ++i)
|
||||
+ {
|
||||
+ const QPair<double, double> &p = sipCpp->at(i);
|
||||
+ PyObject *pobj;
|
||||
+
|
||||
+ if ((pobj = Py_BuildValue((char *)"dd", p.first, p.second)) == NULL)
|
||||
+ {
|
||||
+ Py_DECREF(l);
|
||||
+
|
||||
+ return NULL;
|
||||
+ }
|
||||
+
|
||||
+ PyList_SET_ITEM(l, i, pobj);
|
||||
+ }
|
||||
+
|
||||
+ return l;
|
||||
+%End
|
||||
+
|
||||
+%ConvertToTypeCode
|
||||
+ SIP_SSIZE_T len;
|
||||
+
|
||||
+ // Check the type if that is all that is required.
|
||||
+ if (sipIsErr == NULL)
|
||||
+ {
|
||||
+ if (!PySequence_Check(sipPy) || (len = PySequence_Size(sipPy)) < 0)
|
||||
+ return 0;
|
||||
+
|
||||
+ for (SIP_SSIZE_T i = 0; i < len; ++i)
|
||||
+ {
|
||||
+ PyObject *tup = PySequence_ITEM(sipPy, i);
|
||||
+
|
||||
+ if (!PySequence_Check(tup) || PySequence_Size(tup) != 2)
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
+ return 1;
|
||||
+ }
|
||||
+
|
||||
+ QList<QPair<double, double> > *ql = new QList<QPair<double, double> >;
|
||||
+ len = PySequence_Size(sipPy);
|
||||
+
|
||||
+ for (SIP_SSIZE_T i = 0; i < len; ++i)
|
||||
+ {
|
||||
+ PyObject *tup = PySequence_ITEM(sipPy, i);
|
||||
+
|
||||
+ double first = PyFloat_AsDouble(PySequence_ITEM(tup, 0));
|
||||
+ double second = PyFloat_AsDouble(PySequence_ITEM(tup, 1));
|
||||
+
|
||||
+ ql->append(QPair<double, double>(first, second));
|
||||
+ }
|
||||
+
|
||||
+ *sipCppPtr = ql;
|
||||
+
|
||||
+ return sipGetState(sipTransferObj);
|
||||
+%End
|
||||
+};
|
||||
+%End
|
||||
+%If (Qt_4_3_0 -)
|
||||
+// QList<QPair<double, TYPE> > is implemented as a Python list of 2-element tuples.
|
||||
+template<double, TYPE>
|
||||
+%MappedType QList<QPair<double, TYPE> >
|
||||
+{
|
||||
+%TypeHeaderCode
|
||||
+#include <qlist.h>
|
||||
+#include <qpair.h>
|
||||
+%End
|
||||
+
|
||||
+%ConvertFromTypeCode
|
||||
+ // Create the list.
|
||||
+ PyObject *l;
|
||||
+
|
||||
+ if ((l = PyList_New(sipCpp->size())) == NULL)
|
||||
+ return NULL;
|
||||
+
|
||||
+ // Set the list elements.
|
||||
+ for (int i = 0; i < sipCpp->size(); ++i)
|
||||
+ {
|
||||
+ const QPair<double, TYPE> &p = sipCpp->at(i);
|
||||
+ TYPE *t = new TYPE(p.second);
|
||||
+ PyObject *pobj;
|
||||
+
|
||||
+ if ((pobj = sipBuildResult(NULL, "(dB)", p.first, t, sipClass_TYPE, sipTransferObj)) == NULL)
|
||||
+ {
|
||||
+ Py_DECREF(l);
|
||||
+ delete t;
|
||||
+
|
||||
+ return NULL;
|
||||
+ }
|
||||
+
|
||||
+ PyList_SET_ITEM(l, i, pobj);
|
||||
+ }
|
||||
+
|
||||
+ return l;
|
||||
+%End
|
||||
+
|
||||
+%ConvertToTypeCode
|
||||
+ SIP_SSIZE_T len;
|
||||
+
|
||||
+ // Check the type if that is all that is required.
|
||||
+ if (sipIsErr == NULL)
|
||||
+ {
|
||||
+ if (!PySequence_Check(sipPy) || (len = PySequence_Size(sipPy)) < 0)
|
||||
+ return 0;
|
||||
+
|
||||
+ for (SIP_SSIZE_T i = 0; i < len; ++i)
|
||||
+ {
|
||||
+ PyObject *tup = PySequence_ITEM(sipPy, i);
|
||||
+
|
||||
+ if (!PySequence_Check(tup) || PySequence_Size(tup) != 2)
|
||||
+ return 0;
|
||||
+
|
||||
+ if (!sipCanConvertToInstance(PySequence_ITEM(tup, 1), sipClass_TYPE, SIP_NOT_NONE))
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
+ return 1;
|
||||
+ }
|
||||
+
|
||||
+ QList<QPair<double, TYPE> > *ql = new QList<QPair<double, TYPE> >;
|
||||
+ len = PySequence_Size(sipPy);
|
||||
+
|
||||
+ for (SIP_SSIZE_T i = 0; i < len; ++i)
|
||||
+ {
|
||||
+ PyObject *tup = PySequence_ITEM(sipPy, i);
|
||||
+ double d;
|
||||
+ int state;
|
||||
+
|
||||
+ d = PyFloat_AsDouble(PySequence_ITEM(tup, 0));
|
||||
+ TYPE *t = reinterpret_cast<TYPE *>(sipConvertToInstance(PySequence_ITEM(tup, 1), sipClass_TYPE, sipTransferObj, SIP_NOT_NONE, &state, sipIsErr));
|
||||
+
|
||||
+ if (*sipIsErr)
|
||||
+ {
|
||||
+ sipReleaseInstance(t, sipClass_TYPE, state);
|
||||
+
|
||||
+ delete ql;
|
||||
+ return 0;
|
||||
+ }
|
||||
+
|
||||
+ ql->append(QPair<double, TYPE>(d, *t));
|
||||
+
|
||||
+ sipReleaseInstance(t, sipClass_TYPE, state);
|
||||
+ }
|
||||
+
|
||||
+ *sipCppPtr = ql;
|
||||
+
|
||||
+ return sipGetState(sipTransferObj);
|
||||
+%End
|
||||
+};
|
||||
+%End
|
||||
+
|
||||
+// QList<double> is implemented as a Python list of doubles.
|
||||
+%MappedType QList<double>
|
||||
+{
|
||||
+%TypeHeaderCode
|
||||
+#include <qlist.h>
|
||||
+%End
|
||||
+
|
||||
+%ConvertFromTypeCode
|
||||
+ // Create the list.
|
||||
+ PyObject *l;
|
||||
+
|
||||
+ if ((l = PyList_New(sipCpp->size())) == NULL)
|
||||
+ return NULL;
|
||||
+
|
||||
+ // Set the list elements.
|
||||
+ for (int i = 0; i < sipCpp->size(); ++i)
|
||||
+ {
|
||||
+ PyObject *pobj;
|
||||
+
|
||||
+ if ((pobj = PyFloat_FromDouble(sipCpp->value(i))) == NULL)
|
||||
+ {
|
||||
+ Py_DECREF(l);
|
||||
+
|
||||
+ return NULL;
|
||||
+ }
|
||||
+
|
||||
+ PyList_SET_ITEM(l, i, pobj);
|
||||
+ }
|
||||
+
|
||||
+ return l;
|
||||
+%End
|
||||
+
|
||||
+%ConvertToTypeCode
|
||||
+ // Check the type if that is all that is required.
|
||||
+ if (sipIsErr == NULL)
|
||||
+ return (PySequence_Check(sipPy) && PySequence_Size(sipPy) >= 0);
|
||||
+
|
||||
+ QList<double> *ql = new QList<double>;
|
||||
+ SIP_SSIZE_T len = PySequence_Size(sipPy);
|
||||
+
|
||||
+ for (SIP_SSIZE_T i = 0; i < len; ++i)
|
||||
+ ql->append(PyFloat_AsDouble(PySequence_ITEM(sipPy, i)));
|
||||
+
|
||||
+ *sipCppPtr = ql;
|
||||
+
|
||||
+ return sipGetState(sipTransferObj);
|
||||
+%End
|
||||
+};
|
||||
+
|
||||
+%End
|
Loading…
Reference in a new issue