extra/rust to 1.79.0-1

This commit is contained in:
Kevin Mihelich 2024-06-16 16:08:52 +00:00
parent bcc56b3b5f
commit b42f7fbd7f
6 changed files with 26 additions and 26 deletions

View file

@ -1,6 +1,6 @@
pkgbase = rust pkgbase = rust
pkgdesc = Systems programming language focused on safety, speed and concurrency pkgdesc = Systems programming language focused on safety, speed and concurrency
pkgver = 1.78.0 pkgver = 1.79.0
pkgrel = 1 pkgrel = 1
epoch = 1 epoch = 1
url = https://www.rust-lang.org/ url = https://www.rust-lang.org/
@ -32,19 +32,19 @@ pkgbase = rust
depends = zlib depends = zlib
options = !emptydirs options = !emptydirs
options = !lto options = !lto
source = https://static.rust-lang.org/dist/rustc-1.78.0-src.tar.gz source = https://static.rust-lang.org/dist/rustc-1.79.0-src.tar.gz
source = https://static.rust-lang.org/dist/rustc-1.78.0-src.tar.gz.asc source = https://static.rust-lang.org/dist/rustc-1.79.0-src.tar.gz.asc
source = 0001-bootstrap-Change-libexec-dir.patch source = 0001-bootstrap-Change-libexec-dir.patch
source = 0002-bootstrap-Change-bash-completion-dir.patch source = 0002-bootstrap-Change-bash-completion-dir.patch
source = 0003-compiler-Change-LLVM-targets.patch source = 0003-compiler-Change-LLVM-targets.patch
source = 0004-compiler-Use-wasm-ld-for-wasm-targets.patch source = 0004-compiler-Use-wasm-ld-for-wasm-targets.patch
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
b2sums = 3f43a1c50e268afbe76755ae24bccb3db9ff4dd8bbb8130c75d486c4c0e40f0253c4d4cad1de1040600c090d03d93b08adee5b16fa8abcf36d47a3c14024719f b2sums = 07fbb29007921cffa6fc11a928d64a43c93c14cd421aee77cf44b7ee71a67c67d9f7454f5d1b85f2d79f50dcc7048a356f4f3971ba87ebad21f53321c51808ca
b2sums = SKIP b2sums = SKIP
b2sums = ef56a70741bae70a95695b4d05d1a6395f545e671c9d016c7180732f69a09b828ff5e16964ef16f9ebec55dd778a1b50927275cd4c21a7b78ae4959946a0657c b2sums = c1cf64e26d240fbacbe2170ad4a114e09deb8230c8c7934415c7b9cb32eb30f708694265b34f281f466c8d8ec7841bfa4895da877d2ca87a3a953a7faa40de80
b2sums = d20861a8a8e16d4bb0143f00d4beb42e2c52eeb2c1894e9f9c04e3d74ecd750d9bdacf15bb39fd0ade4487b9d3d14da24cf5f25ceab112f096fddcd329320a15 b2sums = 093cf81b7c5be5ef8421b4a31a56b5b28d3ecfcb2e952bfea379683f31a237142afdd1c2e45a67e29a11e8e915e80671249fdc2b5760e58702234e5b339abf4e
b2sums = 64391cf17e7d801fb263e9d637928c3a2f6aa11aca6afbf115be4e38e9afce42371ed4884929cf11d6c74c2aa497fb26abbba1812d4f31f44dcda38e4978a33f b2sums = c81eb7e5f4dd8225701aa379381bd377be2348f42f778e67b77118f68e92ac1fe60aab692fbcd61a02af900f9e017ea05adc7bb508ef6297dd096585e0571e5e
b2sums = 23f399d5ea776df5dba1ec42a96020a7ae3b18f5a83121d90ca0256a90027529135bac751373a31480860c0dbad30598833a7da43d1e7f25ce5b6d5d945ce550 b2sums = 963aa64d27763f063b9fac483a870563f5a71a49ec02d17b7ca0c14dbf67064ba56028bbc45f2ee50b16eada725cb55c2aa2ab17ceadff65ba9e40cb220f7a0c
pkgname = rust pkgname = rust
optdepends = gdb: rust-gdb script optdepends = gdb: rust-gdb script

View file

@ -9,7 +9,7 @@ Subject: [PATCH] bootstrap: Change libexec dir
2 files changed, 2 insertions(+), 2 deletions(-) 2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/bootstrap/src/core/build_steps/dist.rs b/src/bootstrap/src/core/build_steps/dist.rs diff --git a/src/bootstrap/src/core/build_steps/dist.rs b/src/bootstrap/src/core/build_steps/dist.rs
index 012d64e53443..a077e67e49dc 100644 index 770a5cdb232d..d115a615774c 100644
--- a/src/bootstrap/src/core/build_steps/dist.rs --- a/src/bootstrap/src/core/build_steps/dist.rs
+++ b/src/bootstrap/src/core/build_steps/dist.rs +++ b/src/bootstrap/src/core/build_steps/dist.rs
@@ -424,7 +424,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) { @@ -424,7 +424,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
@ -22,10 +22,10 @@ index 012d64e53443..a077e67e49dc 100644
let libdir_relative = builder.libdir_relative(compiler); let libdir_relative = builder.libdir_relative(compiler);
diff --git a/src/bootstrap/src/core/build_steps/tool.rs b/src/bootstrap/src/core/build_steps/tool.rs diff --git a/src/bootstrap/src/core/build_steps/tool.rs b/src/bootstrap/src/core/build_steps/tool.rs
index 3c2001121037..17c816c6230a 100644 index 994f0bef0dc7..075f3e9e4166 100644
--- a/src/bootstrap/src/core/build_steps/tool.rs --- a/src/bootstrap/src/core/build_steps/tool.rs
+++ b/src/bootstrap/src/core/build_steps/tool.rs +++ b/src/bootstrap/src/core/build_steps/tool.rs
@@ -684,7 +684,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> { @@ -681,7 +681,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
// Copy `rust-analyzer-proc-macro-srv` to `<sysroot>/libexec/` // Copy `rust-analyzer-proc-macro-srv` to `<sysroot>/libexec/`
// so that r-a can use it. // so that r-a can use it.

View file

@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change bash-completion dir
1 file changed, 5 insertions(+), 1 deletion(-) 1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/src/bootstrap/src/core/build_steps/dist.rs b/src/bootstrap/src/core/build_steps/dist.rs diff --git a/src/bootstrap/src/core/build_steps/dist.rs b/src/bootstrap/src/core/build_steps/dist.rs
index a077e67e49dc..eac689560808 100644 index d115a615774c..444369829413 100644
--- a/src/bootstrap/src/core/build_steps/dist.rs --- a/src/bootstrap/src/core/build_steps/dist.rs
+++ b/src/bootstrap/src/core/build_steps/dist.rs +++ b/src/bootstrap/src/core/build_steps/dist.rs
@@ -1072,7 +1072,11 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> { @@ -1095,7 +1095,11 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
tarball.add_file(cargo, "bin", 0o755); tarball.add_file(cargo, "bin", 0o755);
tarball.add_file(etc.join("_cargo"), "share/zsh/site-functions", 0o644); tarball.add_file(etc.join("_cargo"), "share/zsh/site-functions", 0o644);

View file

@ -23,10 +23,10 @@ targets, as things break when this is done:
3 files changed, 6 insertions(+), 2 deletions(-) 3 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
index b7ee2c980254..3be7b748718d 100644 index 4f259960ac3a..fbd643f93bbc 100644
--- a/compiler/rustc_session/src/config.rs --- a/compiler/rustc_session/src/config.rs
+++ b/compiler/rustc_session/src/config.rs +++ b/compiler/rustc_session/src/config.rs
@@ -2222,6 +2222,10 @@ pub fn parse_target_triple(early_dcx: &EarlyDiagCtxt, matches: &getopts::Matches @@ -1921,6 +1921,10 @@ pub fn parse_target_triple(early_dcx: &EarlyDiagCtxt, matches: &getopts::Matches
early_dcx.early_fatal(format!("target file {path:?} does not exist")) early_dcx.early_fatal(format!("target file {path:?} does not exist"))
}) })
} }
@ -51,10 +51,10 @@ index 1d4916cabfdf..4caab818efdb 100644
description: None, description: None,
tier: None, tier: None,
diff --git a/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs diff --git a/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs
index 98374023dc57..0e08b8c32229 100644 index 11fb28a9aed7..3be190b535ae 100644
--- a/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs --- a/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs
+++ b/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs +++ b/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs
@@ -18,7 +18,7 @@ pub fn target() -> Target { @@ -19,7 +19,7 @@ pub fn target() -> Target {
base.supports_xray = true; base.supports_xray = true;
Target { Target {

View file

@ -9,10 +9,10 @@ We don't ship rust-lld.
1 file changed, 1 insertion(+), 2 deletions(-) 1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/compiler/rustc_target/src/spec/base/wasm.rs b/compiler/rustc_target/src/spec/base/wasm.rs diff --git a/compiler/rustc_target/src/spec/base/wasm.rs b/compiler/rustc_target/src/spec/base/wasm.rs
index 4b4d2aca26e4..b4918c8fdda2 100644 index f237391016e7..a333bb529627 100644
--- a/compiler/rustc_target/src/spec/base/wasm.rs --- a/compiler/rustc_target/src/spec/base/wasm.rs
+++ b/compiler/rustc_target/src/spec/base/wasm.rs +++ b/compiler/rustc_target/src/spec/base/wasm.rs
@@ -88,8 +88,7 @@ macro_rules! args { @@ -85,8 +85,7 @@ macro_rules! args {
// arguments just yet // arguments just yet
limit_rdylib_exports: false, limit_rdylib_exports: false,

View file

@ -20,7 +20,7 @@ pkgname=(
rust-src rust-src
) )
epoch=1 epoch=1
pkgver=1.78.0 pkgver=1.79.0
pkgrel=1 pkgrel=1
pkgdesc="Systems programming language focused on safety, speed and concurrency" pkgdesc="Systems programming language focused on safety, speed and concurrency"
url=https://www.rust-lang.org/ url=https://www.rust-lang.org/
@ -64,12 +64,12 @@ source=(
0003-compiler-Change-LLVM-targets.patch 0003-compiler-Change-LLVM-targets.patch
0004-compiler-Use-wasm-ld-for-wasm-targets.patch 0004-compiler-Use-wasm-ld-for-wasm-targets.patch
) )
b2sums=('3f43a1c50e268afbe76755ae24bccb3db9ff4dd8bbb8130c75d486c4c0e40f0253c4d4cad1de1040600c090d03d93b08adee5b16fa8abcf36d47a3c14024719f' b2sums=('07fbb29007921cffa6fc11a928d64a43c93c14cd421aee77cf44b7ee71a67c67d9f7454f5d1b85f2d79f50dcc7048a356f4f3971ba87ebad21f53321c51808ca'
'SKIP' 'SKIP'
'ef56a70741bae70a95695b4d05d1a6395f545e671c9d016c7180732f69a09b828ff5e16964ef16f9ebec55dd778a1b50927275cd4c21a7b78ae4959946a0657c' 'c1cf64e26d240fbacbe2170ad4a114e09deb8230c8c7934415c7b9cb32eb30f708694265b34f281f466c8d8ec7841bfa4895da877d2ca87a3a953a7faa40de80'
'd20861a8a8e16d4bb0143f00d4beb42e2c52eeb2c1894e9f9c04e3d74ecd750d9bdacf15bb39fd0ade4487b9d3d14da24cf5f25ceab112f096fddcd329320a15' '093cf81b7c5be5ef8421b4a31a56b5b28d3ecfcb2e952bfea379683f31a237142afdd1c2e45a67e29a11e8e915e80671249fdc2b5760e58702234e5b339abf4e'
'64391cf17e7d801fb263e9d637928c3a2f6aa11aca6afbf115be4e38e9afce42371ed4884929cf11d6c74c2aa497fb26abbba1812d4f31f44dcda38e4978a33f' 'c81eb7e5f4dd8225701aa379381bd377be2348f42f778e67b77118f68e92ac1fe60aab692fbcd61a02af900f9e017ea05adc7bb508ef6297dd096585e0571e5e'
'23f399d5ea776df5dba1ec42a96020a7ae3b18f5a83121d90ca0256a90027529135bac751373a31480860c0dbad30598833a7da43d1e7f25ce5b6d5d945ce550') '963aa64d27763f063b9fac483a870563f5a71a49ec02d17b7ca0c14dbf67064ba56028bbc45f2ee50b16eada725cb55c2aa2ab17ceadff65ba9e40cb220f7a0c')
validpgpkeys=( validpgpkeys=(
108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org> 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
) )
@ -92,7 +92,7 @@ prepare() {
cat >config.toml <<END cat >config.toml <<END
profile = "user" profile = "user"
change-id = 121754 change-id = 123711
[llvm] [llvm]
link-shared = true link-shared = true