mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-olinuxino to 2016.07-1
This commit is contained in:
parent
3ec21863af
commit
b46710d829
2 changed files with 12 additions and 21 deletions
|
@ -1,27 +1,26 @@
|
|||
From 2db7b7cd826260180268077b7f22e7380d9b3390 Mon Sep 17 00:00:00 2001
|
||||
From ff573490833587ad9b78d56bb17ac596584e7d39 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 31 Oct 2015 10:05:29 -0600
|
||||
Subject: [PATCH] arch linux arm modifications
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
include/configs/mx23_olinuxino.h | 134 ++++++++++++++++++---------------------
|
||||
1 file changed, 60 insertions(+), 74 deletions(-)
|
||||
include/configs/mx23_olinuxino.h | 131 +++++++++++++++++----------------------
|
||||
1 file changed, 58 insertions(+), 73 deletions(-)
|
||||
|
||||
diff --git a/include/configs/mx23_olinuxino.h b/include/configs/mx23_olinuxino.h
|
||||
index 529f73b..3b57a8a 100644
|
||||
index 7747258..7bfbd24 100644
|
||||
--- a/include/configs/mx23_olinuxino.h
|
||||
+++ b/include/configs/mx23_olinuxino.h
|
||||
@@ -24,6 +24,17 @@
|
||||
#define CONFIG_CMD_MMC
|
||||
#define CONFIG_CMD_USB
|
||||
@@ -17,6 +17,16 @@
|
||||
|
||||
#define CONFIG_CMD_LED
|
||||
|
||||
+/* Arch Linux ARM extras */
|
||||
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
||||
+#define CONFIG_CMD_SETEXPR
|
||||
+#define CONFIG_CMD_PART
|
||||
+#define CONFIG_PARTITION_UUIDS
|
||||
+#define CONFIG_CMD_FAT
|
||||
+#define CONFIG_CMD_EXT4
|
||||
+#define CONFIG_CMD_FS_GENERIC
|
||||
+#define CONFIG_CMD_BOOTZ
|
||||
|
@ -30,15 +29,7 @@ index 529f73b..3b57a8a 100644
|
|||
/* Memory configuration */
|
||||
#define CONFIG_NR_DRAM_BANKS 1 /* 1 bank of DRAM */
|
||||
#define PHYS_SDRAM_1 0x40000000 /* Base address */
|
||||
@@ -64,92 +75,67 @@
|
||||
#endif
|
||||
|
||||
/* Booting Linux */
|
||||
-#define CONFIG_BOOTDELAY 3
|
||||
+#define CONFIG_BOOTDELAY 1
|
||||
#define CONFIG_BOOTFILE "uImage"
|
||||
#define CONFIG_LOADADDR 0x42000000
|
||||
#define CONFIG_SYS_LOAD_ADDR CONFIG_LOADADDR
|
||||
@@ -63,85 +73,60 @@
|
||||
|
||||
/* Extra Environment */
|
||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||
|
@ -173,5 +164,5 @@ index 529f73b..3b57a8a 100644
|
|||
/* The rest of the configuration is shared */
|
||||
#include <configs/mxs.h>
|
||||
--
|
||||
2.6.1
|
||||
2.9.3
|
||||
|
||||
|
|
|
@ -6,7 +6,7 @@ buildarch=2
|
|||
|
||||
pkgname=uboot-olinuxino
|
||||
pkgdesc="U-Boot for i.MX233-OLinuXino"
|
||||
pkgver=2016.03
|
||||
pkgver=2016.07
|
||||
pkgrel=1
|
||||
arch=('arm')
|
||||
license=('GPL')
|
||||
|
@ -17,8 +17,8 @@ backup=('boot/uEnv.txt')
|
|||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||
'0001-arch-linux-arm-modifications.patch'
|
||||
'uEnv.txt')
|
||||
md5sums=('973c1d896be751321cc3aafa564f64b2'
|
||||
'6b5f319d0b043e223629d001579c3a2e'
|
||||
md5sums=('425a3fa610a7d972e5092a0e92276c70'
|
||||
'8a8fa0c90fc6898ac4de7d8fad52723f'
|
||||
'd41d8cd98f00b204e9800998ecf8427e')
|
||||
|
||||
prepare() {
|
||||
|
|
Loading…
Reference in a new issue