mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added community/libfbclient
This commit is contained in:
parent
c0c6a953e2
commit
b6de61ac00
3 changed files with 125 additions and 0 deletions
44
community/libfbclient/LICENSE
Normal file
44
community/libfbclient/LICENSE
Normal file
|
@ -0,0 +1,44 @@
|
|||
|
||||
LICENSES
|
||||
--------
|
||||
|
||||
The applicable and approved licenses for the source files
|
||||
of the Firebird RDBMS project are:
|
||||
|
||||
1) InterBase Public License (IPL), version 1.0
|
||||
http://bdn.borland.com/article/0,1410,30198,00.html
|
||||
|
||||
2) Initial Developer's Public License (IDPL), version 1.0
|
||||
http://www.ibphoenix.com/main.nfs?a=ibphoenix&page=ibp_idpl
|
||||
|
||||
The IPL is copyright of Borland Corp., the other licenses are copyright
|
||||
by the source code authors and contributors.
|
||||
|
||||
|
||||
USAGE RULES
|
||||
-----------
|
||||
|
||||
1) The source code which was released under the IPL must keep this license.
|
||||
All modifications / adaptations of this code are still subjects of the IPL.
|
||||
|
||||
2) The files that are derived from the IPL covered code, must also keep
|
||||
this license. It means that if any new file contains some code covered by
|
||||
the IPL, then this file should be released under the IPL too.
|
||||
|
||||
3) The new files developed by the members of the Firebird project should
|
||||
be released under the IDPL.
|
||||
|
||||
4) The new files contributed by people who are not members of the Firebird
|
||||
project should follow the rule #3. If an author (initial developer) doesn't
|
||||
specify the license to be used, the person who applies the contributed code
|
||||
to the CVS tree (a committer) becomes responsible for the license assigned
|
||||
to the contributed code.
|
||||
|
||||
5) Every non-binary file that exists in the CVS tree, should have a header
|
||||
section which describes the license this code is released under. If a file
|
||||
contains no header, it means that this code is freeware and nobody owns the
|
||||
appropriate copyrights.
|
||||
|
||||
|
||||
You may find the exhibits for the approved licenses in /doc/license directory
|
||||
of the CVS tree.
|
54
community/libfbclient/PKGBUILD
Normal file
54
community/libfbclient/PKGBUILD
Normal file
|
@ -0,0 +1,54 @@
|
|||
# $Id$
|
||||
# Maintainer: Carlier Laurent <lordheavym@gmail.com>
|
||||
# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to link with atomic_ops
|
||||
|
||||
pkgname=libfbclient
|
||||
pkgver=2.5.2.26540
|
||||
pkgrel=2
|
||||
pkgdesc="Client library for Firebird."
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.firebirdsql.org/"
|
||||
license=('custom')
|
||||
depends=('gcc-libs' 'icu')
|
||||
options=('!makeflags')
|
||||
source=(http://downloads.sourceforge.net/firebird/Firebird-$pkgver-0.tar.bz2
|
||||
link_atomic_ops.patch
|
||||
LICENSE)
|
||||
md5sums=('21154d2004e025c8a3666625b0357bb5'
|
||||
'ca8e2c7a1fe0d3398f72d63a6c85422a'
|
||||
'0d61798861e159c85dbdf0f30fe2f2ce')
|
||||
|
||||
build() {
|
||||
cd $srcdir/Firebird-$pkgver-0
|
||||
|
||||
patch -p1 -i ../link_atomic_ops.patch
|
||||
|
||||
./configure --prefix=/usr --with-system-icu --without-fbudf \
|
||||
--without-fbsbin --without-fbconf --without-fbdoc --without-fbsample \
|
||||
--without-fbsample-db --without-fbintl --without-fbmisc --without-fbhelp \
|
||||
--without-fbsecure-db --with-fbmsg=/usr/share/firebird --without-fblog \
|
||||
--without-fbglock --without-fbplugins
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $srcdir/Firebird-$pkgver-0
|
||||
|
||||
mkdir -p $pkgdir/usr/{bin,share/{firebird,licenses/$pkgname}}
|
||||
|
||||
cp -R gen/firebird/{lib,include} $pkgdir/usr
|
||||
rm -f $pkgdir/usr/lib/libedit.a
|
||||
|
||||
install -m644 gen/firebird/*.msg $pkgdir/usr/share/firebird
|
||||
install -m755 gen/firebird/bin/fb_config $pkgdir/usr/bin
|
||||
install -m644 ${srcdir}/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
|
||||
|
||||
# Add libgds support FS#30062 FS#30282
|
||||
cd $pkgdir/usr/lib
|
||||
ln -s libfbclient.so libgds.so.0
|
||||
ln -s libfbclient.so libgds.so
|
||||
}
|
27
community/libfbclient/link_atomic_ops.patch
Normal file
27
community/libfbclient/link_atomic_ops.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
diff -urN a/builds/posix/make.defaults b/builds/posix/make.defaults
|
||||
--- a/builds/posix/make.defaults 2013-03-19 02:37:30.000000000 -0600
|
||||
+++ b/builds/posix/make.defaults 2014-02-19 15:55:29.151554390 -0700
|
||||
@@ -151,7 +151,8 @@
|
||||
EXE_LINK:= @CXX@ $(GLOB_OPTIONS) $(CXXFLAGS)
|
||||
STATICEXE_LINK:= @CXX@ $(GLOB_OPTIONS) $(CXXFLAGS)
|
||||
|
||||
-LINK_LIBS = @LIBS@
|
||||
+ATOMIC_LIBS = -latomic_ops
|
||||
+LINK_LIBS = @LIBS@ $(ATOMIC_LIBS)
|
||||
ICU_LIBS = -licuuc -licudata -licui18n
|
||||
STATICLINK_LIBS = @LIBS@
|
||||
SO_LINK_LIBS = @LIBS@
|
||||
@@ -294,11 +295,11 @@
|
||||
|
||||
LINK_CLIENT = $(CLIENTLIB_LINK) $(LINK_FIREBIRD_CLIENT_SYMBOLS) $(LIB_LINK_OPTIONS)\
|
||||
$(LIB_LINK_IMPLIB) $(call LIB_LINK_SONAME,$(ClientLibrarySoName)) $(call LIB_LINK_RPATH,lib)
|
||||
-LINK_CLIENT_LIBS = $(SO_LINK_LIBS) $(STATIC_CXXSUPPORT_LIB)
|
||||
+LINK_CLIENT_LIBS = $(SO_LINK_LIBS) $(STATIC_CXXSUPPORT_LIB) $(ATOMIC_LIBS)
|
||||
|
||||
LINK_EMBED = $(LIB_LINK) $(LINK_FIREBIRD_EMBED_SYMBOLS) $(LIB_LINK_OPTIONS) $(LIB_EMBED_LINK_OPTIONS)\
|
||||
$(call LIB_LINK_SONAME,$(SharedLibrarySoName)) $(call LIB_LINK_RPATH,lib)
|
||||
-LINK_EMBED_LIBS = -L$(LIB) $(LIB_GUI) $(SO_LINK_LIBS) $(ICU_LIBS)
|
||||
+LINK_EMBED_LIBS = -L$(LIB) $(LIB_GUI) $(SO_LINK_LIBS) $(ICU_LIBS) $(ATOMIC_LIBS)
|
||||
|
||||
# From utilities
|
||||
CREATE_DB = $(BIN)/create_db$(EXEC_EXT)
|
Loading…
Reference in a new issue