alarm/uboot-sunxi: fix patch

This commit is contained in:
Kevin Mihelich 2014-06-12 02:29:05 +00:00
parent b94abc0dd2
commit c2f04af5d6
2 changed files with 7 additions and 6 deletions

View file

@ -23,7 +23,7 @@ source=("https://github.com/linux-sunxi/u-boot-sunxi/archive/${_commit}.tar.gz"
'hackberry.fex' 'hackberry.env'
'a20-olinuxino_micro.fex' 'a20-olinuxino_micro.env')
md5sums=('8e4f2a2c1384f31eca5d3864b86e8351'
'294c1c3546eb0bf3f9a51daa7dc2c653'
'234ac383320992dea6734cc442075558'
'36c04988cecd53151f3f5ff5c48d76a9'
'd41d8cd98f00b204e9800998ecf8427e'
'c898ab1b57f474d620f5704b2a53d87c'

View file

@ -1,6 +1,6 @@
diff -urN a/include/config_distro_defaults.h b/include/config_distro_defaults.h
--- a/include/config_distro_defaults.h 2014-06-03 11:30:04.000000000 -0600
+++ b/include/config_distro_defaults.h 2014-06-11 19:52:40.580010171 -0600
+++ b/include/config_distro_defaults.h 2014-06-11 20:20:44.881069479 -0600
@@ -45,7 +45,7 @@
#define CONFIG_CMDLINE_EDITING
@ -12,7 +12,7 @@ diff -urN a/include/config_distro_defaults.h b/include/config_distro_defaults.h
#define CONFIG_DOS_PARTITION
diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
--- a/include/configs/sunxi-common.h 2014-06-03 11:30:04.000000000 -0600
+++ b/include/configs/sunxi-common.h 2014-06-11 20:05:04.219182801 -0600
+++ b/include/configs/sunxi-common.h 2014-06-11 20:21:15.295967969 -0600
@@ -126,7 +126,7 @@
#define CONFIG_SYS_NO_FLASH
@ -22,7 +22,7 @@ diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
#define CONFIG_ENV_OFFSET (544 << 10) /* (8 + 24 + 512) KiB */
#define CONFIG_ENV_SIZE (128 << 10) /* 128 KiB */
@@ -137,99 +137,54 @@
@@ -137,99 +137,55 @@
#define RUN_BOOT_RAM ""
#endif
@ -57,8 +57,9 @@ diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
+ #define CONFIG_DEFAULT_FDT_FILE "sun7i-a20-olinuxino-micro.dts"
+#elif defined(CONFIG_HACKBERRY)
+ #define CONFIG_DEFAULT_FDT_FILE "sun4i-a10-hackberry.dts"
+#else
+ #define CONFIG_DEFAULT_FDT_FILE ""
+#endif
+
+
#define CONFIG_EXTRA_ENV_SETTINGS \
"bootm_size=0x10000000\0" \
@ -162,7 +163,7 @@ diff -urN a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
"boot_ram=" \
"saved_stdout=$stdout;setenv stdout nc;"\
"if iminfo 0x41000000; then" \
@@ -238,9 +193,33 @@
@@ -238,9 +194,33 @@
" source 0x41000000;" \
"else" \
" setenv stdout $saved_stdout;" \