mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added community/simutrans
This commit is contained in:
parent
8d5a548182
commit
c3bd1a0db0
5 changed files with 152 additions and 0 deletions
61
community/simutrans/PKGBUILD
Normal file
61
community/simutrans/PKGBUILD
Normal file
|
@ -0,0 +1,61 @@
|
|||
# $Id: PKGBUILD 91302 2013-05-20 23:13:17Z bgyorgy $
|
||||
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
|
||||
# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
|
||||
# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
|
||||
# Contributor: Gilles Gagniard <gilles@gagniard.org>
|
||||
# Contributor: JD Steffen <jd at steffennet dot org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - get rid of a bad gcc flag in Makefile
|
||||
|
||||
pkgname=simutrans
|
||||
pkgver=112.3
|
||||
_pkgver=112-3
|
||||
pkgrel=1
|
||||
pkgdesc="An open source transportation simulation game"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://simutrans.com/"
|
||||
license=('PerlArtistic')
|
||||
depends=('gcc-libs' 'zlib' 'sdl_mixer' 'bzip2' 'simutrans-pak64')
|
||||
makedepends=('imagemagick')
|
||||
optdepends=('timidity++: play MIDI music')
|
||||
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-src-$_pkgver.zip
|
||||
http://downloads.sourceforge.net/$pkgname/simulinux-$_pkgver.zip
|
||||
settings-folder.patch
|
||||
path-for-game-data.patch
|
||||
config.patch
|
||||
simutrans.desktop)
|
||||
md5sums=('4963f0ad0da5f622f67b7c1fb888a264'
|
||||
'8e09f450173110fec097497c7198e50c'
|
||||
'c87d9a9910bc371df5d50f7f1ec298bb'
|
||||
'4648680290b44775b9c47d3758d3bd6c'
|
||||
'd11bc8ee33a34e33341f6ccd90a44dba'
|
||||
'f41f7a08ad517ef2b60412859eb49963')
|
||||
|
||||
build() {
|
||||
cd "$srcdir"
|
||||
|
||||
cp config.template config.default
|
||||
patch -Np0 -i "$srcdir/settings-folder.patch"
|
||||
patch -Np1 -i "$srcdir/path-for-game-data.patch"
|
||||
patch -Np0 -i "$srcdir/config.patch"
|
||||
convert simutrans.ico -alpha on simutrans.png
|
||||
sed -i 's/-minline-all-stringops/-O3/' Makefile
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir"
|
||||
|
||||
#binary
|
||||
install -Dm755 build/default/sim "$pkgdir/usr/bin/simutrans"
|
||||
|
||||
#data
|
||||
mkdir -p "$pkgdir/usr/share/games/$pkgname"
|
||||
cp -r "$pkgname"/{config,font,music,script,skin,text} "$pkgdir/usr/share/games/$pkgname"
|
||||
|
||||
#desktop file and icon
|
||||
install -Dm644 simutrans.png "$pkgdir/usr/share/pixmaps/simutrans.png"
|
||||
install -Dm644 simutrans.desktop "$pkgdir/usr/share/applications/simutrans.desktop"
|
||||
}
|
52
community/simutrans/config.patch
Normal file
52
community/simutrans/config.patch
Normal file
|
@ -0,0 +1,52 @@
|
|||
--- config.default.orig 2011-11-10 21:48:01.000000000 +0100
|
||||
+++ config.default 2011-11-10 21:51:58.383221979 +0100
|
||||
@@ -6,23 +6,23 @@
|
||||
#BACKEND = allegro
|
||||
#BACKEND = gdi
|
||||
#BACKEND = sdl
|
||||
-#BACKEND = mixer_sdl
|
||||
+BACKEND = mixer_sdl
|
||||
#BACKEND = posix
|
||||
|
||||
#COLOUR_DEPTH = 0
|
||||
-#COLOUR_DEPTH = 16
|
||||
+COLOUR_DEPTH = 16
|
||||
|
||||
#OSTYPE = amiga
|
||||
#OSTYPE = beos
|
||||
#OSTYPE = cygwin
|
||||
#OSTYPE = freebsd
|
||||
#OSTYPE = haiku
|
||||
-#OSTYPE = linux
|
||||
+OSTYPE = linux
|
||||
#OSTYPE = mingw
|
||||
#OSTYPE = mac
|
||||
|
||||
#DEBUG = 3 # Level 1-3, higher number means more debug-friendly, see Makefile
|
||||
-#OPTIMISE = 1 # Add umpteen optimisation flags
|
||||
+OPTIMISE = 1 # Add umpteen optimisation flags
|
||||
#PROFILE = 1 # Enable profiling
|
||||
#PROFILE = 2 # Enable profiling with optimisation flags, can be used with `OPTIMISE = 1'
|
||||
|
||||
@@ -34,9 +34,9 @@
|
||||
# Define these as empty strings, if you don't have the respective config program
|
||||
#ALLEGRO_CONFIG = allegro-config
|
||||
#PNG_CONFIG = pkg-config libpng
|
||||
-#SDL_CONFIG = sdl-config
|
||||
+SDL_CONFIG = sdl-config
|
||||
|
||||
-#VERBOSE = 1
|
||||
+VERBOSE = 1
|
||||
|
||||
# The following useful conditional compilation flags exist
|
||||
#
|
||||
@@ -65,6 +65,9 @@
|
||||
#
|
||||
# In order to use the flags, add a line like this: (-Dxxx)
|
||||
# FLAGS = -DUSE_C
|
||||
+ifeq ($(shell uname -m),x86_64)
|
||||
+ FLAGS += -DUSE_C
|
||||
+endif
|
||||
|
||||
# Output directories:
|
||||
#
|
18
community/simutrans/path-for-game-data.patch
Normal file
18
community/simutrans/path-for-game-data.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
look in /usr/share/games/simutrans for game data
|
||||
|
||||
@DPATCH@
|
||||
|
||||
--- simutrans.orig/simmain.cc
|
||||
+++ simutrans/simmain.cc
|
||||
@@ -437,8 +437,9 @@
|
||||
strcat( umgebung_t::program_dir, path_sep );
|
||||
}
|
||||
else {
|
||||
- strcpy( umgebung_t::program_dir, argv[0] );
|
||||
- *(strrchr( umgebung_t::program_dir, path_sep[0] )+1) = 0;
|
||||
+ // strcpy( umgebung_t::program_dir, argv[0] );
|
||||
+ // *(strrchr( umgebung_t::program_dir, path_sep[0] )+1) = 0;
|
||||
+ strcpy(umgebung_t::program_dir, "/usr/share/games/simutrans/");
|
||||
|
||||
chdir( umgebung_t::program_dir );
|
||||
}
|
12
community/simutrans/settings-folder.patch
Normal file
12
community/simutrans/settings-folder.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- simsys.cc.orig 2011-10-28 20:32:25.000000000 +0200
|
||||
+++ simsys.cc 2011-11-10 23:09:10.380031846 +0100
|
||||
@@ -47,7 +47,7 @@
|
||||
#elif defined __APPLE__
|
||||
sprintf(buffer, "%s/Library/Simutrans", getenv("HOME"));
|
||||
#else
|
||||
- sprintf(buffer, "%s/simutrans", getenv("HOME"));
|
||||
+ sprintf(buffer, "%s/.simutrans", getenv("HOME"));
|
||||
#endif
|
||||
|
||||
dr_mkdir(buffer);
|
||||
|
9
community/simutrans/simutrans.desktop
Normal file
9
community/simutrans/simutrans.desktop
Normal file
|
@ -0,0 +1,9 @@
|
|||
[Desktop Entry]
|
||||
Name=Simutrans
|
||||
Comment=Transportation simulator
|
||||
Exec=simutrans
|
||||
Icon=simutrans
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Game;Simulation;
|
||||
|
Loading…
Reference in a new issue