mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
removed extra/imagemagick
This commit is contained in:
parent
c272f45051
commit
c7891bb1a3
2 changed files with 0 additions and 115 deletions
|
@ -1,104 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Eric Bélanger <eric@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove libcl, opencl-headers makedepends (x86 blob package)
|
||||
# - remove --enable-libcl from configure
|
||||
# - remove libcl from package depends
|
||||
|
||||
pkgbase=imagemagick
|
||||
pkgname=('imagemagick' 'imagemagick-doc')
|
||||
pkgver=6.9.9.25
|
||||
pkgrel=1
|
||||
arch=('x86_64')
|
||||
url="http://www.imagemagick.org/"
|
||||
license=('custom')
|
||||
makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript'
|
||||
'openexr' 'libwmf' 'librsvg' 'libxml2' 'liblqr' 'openjpeg2' 'libraw' 'libraqm'
|
||||
'libwebp' 'subversion' 'glu')
|
||||
source=(http://www.imagemagick.org/download/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
|
||||
perlmagick.rpath.patch)
|
||||
sha256sums=('5d78b1b50c6d71aee9d5aba8d2c2d1f26b739d432a0cfef5afb8316a45e58771'
|
||||
'SKIP'
|
||||
'17218bbecc17f3c7a86935a09d5a47e46113a1fc28f7d91c2fe495019cc36088')
|
||||
validpgpkeys=('D8272EF51DA223E4D05B466989AB63D48277377A')
|
||||
|
||||
prepare() {
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
sed '/AC_PATH_XTRA/d' -i configure.ac
|
||||
patch -p0 -i "${srcdir}/perlmagick.rpath.patch"
|
||||
autoreconf --force --install
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
[[ $CARCH = "i686" ]] && EXTRAOPTS="--with-gcc-arch=i686"
|
||||
[[ $CARCH = "x86_64" ]] && EXTRAOPTS="--with-gcc-arch=x86-64"
|
||||
|
||||
./configure --prefix=/usr --sysconfdir=/etc --with-modules \
|
||||
--enable-hdri --with-wmf --with-openexr --with-xml \
|
||||
--with-webp --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
|
||||
--with-perl --with-perl-options="INSTALLDIRS=vendor" --with-lqr --with-rsvg \
|
||||
--with-openjp2 --without-gvc --without-djvu --without-autotrace \
|
||||
--without-jbig --without-fpx --without-dps --without-fftw $EXTRAOPTS
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
# make check
|
||||
}
|
||||
|
||||
package_imagemagick() {
|
||||
pkgdesc="An image viewing/manipulation program"
|
||||
depends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'liblqr' 'libraqm')
|
||||
optdepends=('imagemagick-doc: for additional information'
|
||||
'ghostscript: for Ghostscript support'
|
||||
'openexr: for OpenEXR support'
|
||||
'openjpeg2: for JP2 support'
|
||||
'libwmf: for WMF support'
|
||||
'librsvg: for SVG support'
|
||||
'libxml2: for XML support'
|
||||
'libpng: for PNG support'
|
||||
'libwebp: for WEBP support'
|
||||
'libraw: for DNG support')
|
||||
backup=("etc/ImageMagick-${pkgver%%.*}/coder.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/colors.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/delegates.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/log.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/magic.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/mime.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/policy.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/quantization-table.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/thresholds.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/type.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/type-dejavu.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/type-ghostscript.xml"
|
||||
"etc/ImageMagick-${pkgver%%.*}/type-windows.xml")
|
||||
options=('!docs' 'libtool' '!emptydirs')
|
||||
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
make -j1 DESTDIR="${pkgdir}" install
|
||||
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick/LICENSE"
|
||||
install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick/NOTICE"
|
||||
|
||||
#Cleaning
|
||||
rm -f "${pkgdir}"/usr/lib/*.la
|
||||
|
||||
# template start; name=perl-binary-module-dependency; version=1;
|
||||
if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
|
||||
_perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
|
||||
_perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
|
||||
depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
|
||||
fi
|
||||
# template end;
|
||||
}
|
||||
|
||||
package_imagemagick-doc() {
|
||||
pkgdesc="The ImageMagick documentation (utilities manuals and libraries API)"
|
||||
|
||||
cd ImageMagick-${pkgver%.*}-${pkgver##*.}
|
||||
make DESTDIR="${pkgdir}" install-data-html
|
||||
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick-doc/LICENSE"
|
||||
install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick-doc/NOTICE"
|
||||
}
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.in.orig 2013-02-21 03:26:56.785156600 -0500
|
||||
+++ Makefile.in 2013-02-21 03:39:03.102411457 -0500
|
||||
@@ -10469,6 +10469,8 @@
|
||||
|
||||
@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@$(PERLMAKEFILE): perl-sources $(MAGICKCORE_LIBS) $(MAGICKWAND_LIBS) $(PERLMAKEMAKER)
|
||||
@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @PERL@ Makefile.PL $(PERL_MAKE_OPTIONS)
|
||||
+@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @SED@ -i 's|LD_RUN_PATH|DIE_LD_RUN_PATH_DIE|g' Makefile
|
||||
+@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @SED@ -i 's|LD_RUN_PATH|DIE_LD_RUN_PATH_DIE|g' quantum/Makefile
|
||||
|
||||
@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@install-exec-perl: $(PERLMAKEFILE)
|
||||
@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ ( cd $(PERLMAGICK) && $(MAKE) CC='@CC@' && \
|
Loading…
Reference in a new issue