extra/python2 to 2.7.15-1

This commit is contained in:
Kevin Mihelich 2018-05-04 18:51:44 +00:00
parent 6c93aa7380
commit d0fba0575c
2 changed files with 7 additions and 23 deletions

View file

@ -8,8 +8,8 @@
# - configure with --without-lto
pkgname=python2
pkgver=2.7.14
pkgrel=3
pkgver=2.7.15
pkgrel=1
_pybasever=2.7
pkgdesc="A high-level scripting language"
arch=('x86_64')
@ -23,11 +23,10 @@ optdepends=('tk: for IDLE'
'python2-pip')
conflicts=('python<3')
source=("https://www.python.org/ftp/python/${pkgver%rc?}/Python-${pkgver}.tar.xz"{,.asc}
descr_ref.patch fix-profile-task.patch)
sha512sums=('78310b0be6388ffa15f29a80afb9ab3c03a572cb094e9da00cfe391afadb51696e41f592eb658d6a31a2f422fdac8a55214a382cbb8cfb43d4a127d5b35ea7f9'
descr_ref.patch)
sha512sums=('27ea43eb45fc68f3d2469d5f07636e10801dee11635a430ec8ec922ed790bb426b072da94df885e4dfa1ea8b7a24f2f56dd92f9b0f51e162330f161216bd6de6'
'SKIP'
'2e16eb23eb402dbe921c09bce99b400c10939114b4a1ded0e94a744d8cb66427947bc8d07c4fb054f9fe0906d10d1da509fc2273fd136225c0f019cc43dd045d'
'5d7b47bfa9f13cf5fb827546189d823033278f96866366fca5257aaf819c92ffb26e2116426c84ab78d9ae3178eebb591fa4b2f22cfc2725e3e3e795fdb5c2b6')
'2e16eb23eb402dbe921c09bce99b400c10939114b4a1ded0e94a744d8cb66427947bc8d07c4fb054f9fe0906d10d1da509fc2273fd136225c0f019cc43dd045d')
validpgpkeys=('C01E1CAD5EA2C4F0B8E3571504C367C218ADD4FF') # Benjamin Peterson
prepare() {
@ -62,9 +61,6 @@ prepare() {
# FS#48761
# http://bugs.python.org/issue25750
patch -Np1 -i ../descr_ref.patch
# Backport from Python 3.x
patch -Np2 -i ../fix-profile-task.patch
}
build() {
@ -89,10 +85,11 @@ build() {
check() {
# Since 2.7.14 with latest xvfb
# test_idle, test_tk, test_ttk_guionly: segfaults
# Since 2.7.15: test_ctypes
cd Python-${pkgver}
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
xvfb-run "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_idle test_tk test_ttk_guionly
xvfb-run "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_idle test_tk test_ttk_guionly test_ctypes
}
package() {

View file

@ -1,13 +0,0 @@
diff --git a/Python-2.7.13/Makefile.pre.in b/Python-2.7.13/Makefile.pre.in
index e288964..22edc27 100644
--- a/Python-2.7.13/Makefile.pre.in
+++ b/Python-2.7.13/Makefile.pre.in
@@ -456,7 +456,7 @@ build_all_generate_profile:
run_profile_task:
: # FIXME: can't run for a cross build
- $(LLVM_PROF_FILE) ./$(BUILDPYTHON) $(PROFILE_TASK) || true
+ $(LLVM_PROF_FILE) $(RUNSHARED) ./$(BUILDPYTHON) $(PROFILE_TASK) || true
build_all_merge_profile:
$(LLVM_PROF_MERGER)