mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/pacman to 5.1.3-1.1
This commit is contained in:
parent
0c3b62453c
commit
d7783e2a01
5 changed files with 44 additions and 13 deletions
|
@ -1,7 +1,7 @@
|
|||
From 8569d3c4b63f15ea588b9bde050072bfa2769eb0 Mon Sep 17 00:00:00 2001
|
||||
From f0131b44f6fb8bd54e78ca97a4aefb4538211e75 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 13 Sep 2014 18:58:16 -0600
|
||||
Subject: [PATCH 1/3] Sychronize filesystem
|
||||
Subject: [PATCH 1/4] Sychronize filesystem
|
||||
|
||||
Since many problems arise from improper flushing of the filesystem,
|
||||
particularly package installations followed by a reboot very shorly after,
|
||||
|
@ -28,5 +28,5 @@ index 4d97921f..531dbbe4 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.20.1
|
||||
2.21.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 0d026763a6bb067072628d559855072bc034ac7c Mon Sep 17 00:00:00 2001
|
||||
From c0836b1f802f54c793618823f5d1bb649a13e85d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 30 Jan 2016 17:19:03 -0700
|
||||
Subject: [PATCH 2/3] Revert "close stdin before running install scripts"
|
||||
Subject: [PATCH 2/4] Revert "close stdin before running install scripts"
|
||||
|
||||
This reverts commit e374e6829cea3512f0b4a4069c5a6168f0f8d8a0.
|
||||
|
||||
|
@ -28,5 +28,5 @@ index d33eef2a..e08cb923 100644
|
|||
close(2);
|
||||
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
|
||||
--
|
||||
2.20.1
|
||||
2.21.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 0dccdcf0113f1a8ec6df1ec30e73a43ee9beec4b Mon Sep 17 00:00:00 2001
|
||||
From c3daaf594599a1a6942cafc907dbb7e9755fe6d4 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 11 Mar 2016 20:11:24 -0700
|
||||
Subject: [PATCH 3/3] Revert "alpm_run_chroot: always connect parent2child
|
||||
Subject: [PATCH 3/4] Revert "alpm_run_chroot: always connect parent2child
|
||||
pipe"
|
||||
|
||||
This reverts commit 1d6583a58da0904fb7feafd4a666391087955a7b.
|
||||
|
@ -56,5 +56,5 @@ index e08cb923..7e788a7e 100644
|
|||
|
||||
#define STOP_POLLING(p) do { close(p->fd); p->fd = -1; } while(0)
|
||||
--
|
||||
2.20.1
|
||||
2.21.0
|
||||
|
||||
|
|
|
@ -0,0 +1,27 @@
|
|||
From 2c7bbd7ce02be70a2af21e45a17c2cdca187526f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 20 May 2019 18:55:18 -0600
|
||||
Subject: [PATCH 4/4] Support application/gzip MIME type in extraction
|
||||
|
||||
file 5.37 changed the gzip MIME type from application/x-gzip to
|
||||
application/gzip, so support this when checking to extract source files.
|
||||
---
|
||||
scripts/libmakepkg/source/file.sh.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/scripts/libmakepkg/source/file.sh.in b/scripts/libmakepkg/source/file.sh.in
|
||||
index 08b8bef8..8492ba11 100644
|
||||
--- a/scripts/libmakepkg/source/file.sh.in
|
||||
+++ b/scripts/libmakepkg/source/file.sh.in
|
||||
@@ -102,7 +102,7 @@ extract_file() {
|
||||
case "$file_type" in
|
||||
*application/x-tar*|*application/zip*|*application/x-zip*|*application/x-cpio*)
|
||||
cmd="bsdtar" ;;
|
||||
- *application/x-gzip*)
|
||||
+ *application/x-gzip*|*application/gzip*)
|
||||
case "$ext" in
|
||||
gz|z|Z) cmd="gzip" ;;
|
||||
*) return;;
|
||||
--
|
||||
2.21.0
|
||||
|
|
@ -8,10 +8,11 @@
|
|||
# - makepkg.conf: adjusted C/CXX/LDFLAGS, drop -z,now for armv5
|
||||
# - patch to sync filesystem after install/remove
|
||||
# - reverts to allow scriplet input on stdin
|
||||
# - patch to fix application/gzip change in file 5.37
|
||||
|
||||
pkgname=pacman
|
||||
pkgver=5.1.3
|
||||
pkgrel=1
|
||||
pkgrel=1.1
|
||||
pkgdesc="A library-based package manager with dependency support"
|
||||
arch=('x86_64')
|
||||
url="https://www.archlinux.org/pacman/"
|
||||
|
@ -32,13 +33,15 @@ source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig
|
|||
0001-Sychronize-filesystem.patch
|
||||
0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
|
||||
0004-Support-application-gzip-MIME-type-in-extraction.patch
|
||||
pacman.conf
|
||||
makepkg.conf)
|
||||
sha256sums=('10db61a0928d619871340c3f93a677d1541d6c52353c516aec4f8d96e830d4eb'
|
||||
'SKIP'
|
||||
'ce1be3021e5cd693b602ddfe96aca65117dce59ca11d4127aff58decd634fd04'
|
||||
'9dc4d4b30e9c561868e89272e1867d5a009fbe6461b885c569f93069a32bdada'
|
||||
'1b7286b86499a02e63362f501209effafcd1676111d91e88253e07737ba44b89'
|
||||
'9ac4ded74073b9cba6e977ce44ae51110e4084b49945c999aa4d1e4954517b8d'
|
||||
'8da873b8ce3b8c4878d29b9ec891aeccbbf8d8d4bf1a239560a006700949296f'
|
||||
'b9461112d857a897cde4e64a2eee6b5a1dfca29422d14c41a3b248e0d9215561'
|
||||
'610cea75cc3a0a89fbce3d72a54866d7ebd9d4d692c9c3b6d1d1a15b9ec76a1c'
|
||||
'd55cd09eda56a0f19dfba8a042056fdf8d8d441d2c218fddaa30c1546a703532'
|
||||
'edc48d8a6c051d50241fa727e948a06ece8890d9d9da80573f8894a3bf455d36')
|
||||
|
||||
|
@ -48,6 +51,7 @@ prepare() {
|
|||
patch -p1 -i ../0001-Sychronize-filesystem.patch
|
||||
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch
|
||||
patch -p1 -i ../0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
|
||||
patch -p1 -i ../0004-Support-application-gzip-MIME-type-in-extraction.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue