mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
added extra/calligra
This commit is contained in:
parent
c3bd1a0db0
commit
dc4fb607c4
2 changed files with 45 additions and 2 deletions
|
@ -4,6 +4,7 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - removed makedepend on vc - not for ARM
|
||||
# - patch to fix qreal ARMisms
|
||||
|
||||
pkgbase=calligra
|
||||
pkgname=('calligra-filters'
|
||||
|
@ -30,10 +31,16 @@ makedepends=('cmake' 'automoc4' 'boost' 'kdepimlibs' 'eigen2' 'kdeedu-marble'
|
|||
'libwps' 'gsl' 'glew' 'fftw' 'opengtl' 'poppler-qt' 'libkdcraw'
|
||||
'openjpeg' 'kdegraphics-okular' 'pstoedit')
|
||||
groups=('calligra')
|
||||
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.bz2")
|
||||
md5sums=('90d6bb619191abbcc94094379d47e225')
|
||||
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.bz2"
|
||||
"arm.patch")
|
||||
md5sums=('90d6bb619191abbcc94094379d47e225'
|
||||
'51f443435a0cf022bec3db041b4047bb')
|
||||
|
||||
build() {
|
||||
cd $pkgbase-$pkgver
|
||||
patch -p1 -i "$srcdir"/arm.patch
|
||||
cd ..
|
||||
|
||||
mkdir build
|
||||
cd build
|
||||
cmake ../${pkgbase}-${pkgver} \
|
||||
|
|
36
extra/calligra/arm.patch
Normal file
36
extra/calligra/arm.patch
Normal file
|
@ -0,0 +1,36 @@
|
|||
diff -urN a/krita/ui/kis_image_view_converter.cpp b/krita/ui/kis_image_view_converter.cpp
|
||||
--- a/krita/ui/kis_image_view_converter.cpp 2013-04-08 03:23:17.000000000 -0500
|
||||
+++ b/krita/ui/kis_image_view_converter.cpp 2013-05-21 17:20:34.227367776 -0500
|
||||
@@ -40,7 +40,7 @@
|
||||
|
||||
// remember here; document is postscript points; view is krita pixels.
|
||||
|
||||
-void KisImageViewConverter::zoom(qreal *zoomX, qreal *zoomY) const
|
||||
+void KisImageViewConverter::zoom(double *zoomX, double *zoomY) const
|
||||
{
|
||||
Q_ASSERT(zoomX);
|
||||
Q_ASSERT(zoomY);
|
||||
diff -urN a/krita/ui/kis_image_view_converter.h b/krita/ui/kis_image_view_converter.h
|
||||
--- a/krita/ui/kis_image_view_converter.h 2013-04-08 03:23:17.000000000 -0500
|
||||
+++ b/krita/ui/kis_image_view_converter.h 2013-05-21 17:19:52.171064761 -0500
|
||||
@@ -52,7 +52,7 @@
|
||||
using KoViewConverter::viewToDocument;
|
||||
|
||||
/// reimplemented from superclass
|
||||
- void zoom(qreal *zoomX, qreal *zoomY) const;
|
||||
+ void zoom(double *zoomX, double *zoomY) const;
|
||||
|
||||
qreal documentToViewX(qreal documentX) const;
|
||||
qreal documentToViewY(qreal documentY) const;
|
||||
diff -urN a/krita/ui/tests/kis_zoom_and_pan_test.cpp b/krita/ui/tests/kis_zoom_and_pan_test.cpp
|
||||
--- a/krita/ui/tests/kis_zoom_and_pan_test.cpp 2013-04-08 03:24:15.000000000 -0500
|
||||
+++ b/krita/ui/tests/kis_zoom_and_pan_test.cpp 2013-05-21 19:09:55.408078960 -0500
|
||||
@@ -220,7 +220,7 @@
|
||||
qreal oldPreferredCenterFractionY = 1.0 * oldPreferredCenter.y() / oldDocumentSize.height();
|
||||
|
||||
qreal roundingTolerance =
|
||||
- qMax(1.0, qMax(oldPreferredCenterFractionX, oldPreferredCenterFractionY) / k);
|
||||
+ qMax((float)1.0, qMax(oldPreferredCenterFractionX, oldPreferredCenterFractionY) / k);
|
||||
|
||||
/**
|
||||
* In the computation of the offset two roundings happen:
|
Loading…
Reference in a new issue