mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-armv7 to 4.0.4-2
This commit is contained in:
parent
514143875b
commit
df62b94f95
2 changed files with 54 additions and 1 deletions
|
@ -0,0 +1,50 @@
|
||||||
|
From bbfb0c2a33848ed6aa2eeedef96ae3a5a153456c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Eric Work <work.eric@gmail.com>
|
||||||
|
Date: Mon, 18 May 2015 23:26:23 -0700
|
||||||
|
Subject: [PATCH] md/raid0: fix restore to sector variable in
|
||||||
|
raid0_make_request
|
||||||
|
|
||||||
|
The variable "sector" in "raid0_make_request()" was improperly updated
|
||||||
|
by a call to "sector_div()" which modifies its first argument in place.
|
||||||
|
Commit 47d68979cc968535cb87f3e5f2e6a3533ea48fbd restored this variable
|
||||||
|
after the call for later re-use. Unfortunetly the restore was done after
|
||||||
|
the referenced variable "bio" was advanced. This lead to the original
|
||||||
|
value and the restored value being different. Here we move this line to
|
||||||
|
the proper place.
|
||||||
|
|
||||||
|
One observed side effect of this bug was discarding a file though
|
||||||
|
unlinking would cause an unrelated file's contents to be discarded.
|
||||||
|
|
||||||
|
Signed-off-by: NeilBrown <neilb@suse.de>
|
||||||
|
Fixes: 47d68979cc96 ("md/raid0: fix bug with chunksize not a power of 2.")
|
||||||
|
Cc: stable@vger.kernel.org (any that received above backport)
|
||||||
|
URL: https://bugzilla.kernel.org/show_bug.cgi?id=98501
|
||||||
|
---
|
||||||
|
drivers/md/raid0.c | 4 +++-
|
||||||
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/md/raid0.c b/drivers/md/raid0.c
|
||||||
|
index 3b5d7f7..903391c 100644
|
||||||
|
--- a/drivers/md/raid0.c
|
||||||
|
+++ b/drivers/md/raid0.c
|
||||||
|
@@ -517,6 +517,9 @@ static void raid0_make_request(struct mddev *mddev, struct bio *bio)
|
||||||
|
? (sector & (chunk_sects-1))
|
||||||
|
: sector_div(sector, chunk_sects));
|
||||||
|
|
||||||
|
+ /* Restore due to sector_div */
|
||||||
|
+ sector = bio->bi_iter.bi_sector;
|
||||||
|
+
|
||||||
|
if (sectors < bio_sectors(bio)) {
|
||||||
|
split = bio_split(bio, sectors, GFP_NOIO, fs_bio_set);
|
||||||
|
bio_chain(split, bio);
|
||||||
|
@@ -524,7 +527,6 @@ static void raid0_make_request(struct mddev *mddev, struct bio *bio)
|
||||||
|
split = bio;
|
||||||
|
}
|
||||||
|
|
||||||
|
- sector = bio->bi_iter.bi_sector;
|
||||||
|
zone = find_zone(mddev->private, §or);
|
||||||
|
tmp_dev = map_sector(mddev, zone, sector, §or);
|
||||||
|
split->bi_bdev = tmp_dev->bdev;
|
||||||
|
--
|
||||||
|
2.4.1
|
||||||
|
|
|
@ -8,7 +8,7 @@ _srcname=linux-4.0
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="ARMv7 multi-platform"
|
_desc="ARMv7 multi-platform"
|
||||||
pkgver=4.0.4
|
pkgver=4.0.4
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
rcnrel=armv7-x2
|
rcnrel=armv7-x2
|
||||||
arch=('armv7h')
|
arch=('armv7h')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
|
@ -26,6 +26,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||||
'0004-fix-mvsdio-eMMC-timing.patch'
|
'0004-fix-mvsdio-eMMC-timing.patch'
|
||||||
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||||
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
|
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
|
||||||
|
'0001-md-raid0-fix-restore-to-sector-variable-in-raid0_mak.patch'
|
||||||
'config')
|
'config')
|
||||||
md5sums=('a86916bd12798220da9eb4a1eec3616d'
|
md5sums=('a86916bd12798220da9eb4a1eec3616d'
|
||||||
'30de8c55237264deee4d4fc60eee78fd'
|
'30de8c55237264deee4d4fc60eee78fd'
|
||||||
|
@ -37,6 +38,7 @@ md5sums=('a86916bd12798220da9eb4a1eec3616d'
|
||||||
'90911aad404f80fcf81488da57bf2906'
|
'90911aad404f80fcf81488da57bf2906'
|
||||||
'1a9033f9bd00f5397ba5ce5bdc842220'
|
'1a9033f9bd00f5397ba5ce5bdc842220'
|
||||||
'648459624ebad128af1faa55a29d0e7d'
|
'648459624ebad128af1faa55a29d0e7d'
|
||||||
|
'23a42a1c1a6b9af044edc7ac6297e5c5'
|
||||||
'ea6b4be069cdb8dc8fdae82113666de8')
|
'ea6b4be069cdb8dc8fdae82113666de8')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
|
@ -55,6 +57,7 @@ prepare() {
|
||||||
git apply ../0004-fix-mvsdio-eMMC-timing.patch
|
git apply ../0004-fix-mvsdio-eMMC-timing.patch
|
||||||
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||||
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
|
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
|
||||||
|
git apply ../0001-md-raid0-fix-restore-to-sector-variable-in-raid0_mak.patch
|
||||||
|
|
||||||
# AUFS patches
|
# AUFS patches
|
||||||
cp -ru "${srcdir}/aufs4-standalone/Documentation" .
|
cp -ru "${srcdir}/aufs4-standalone/Documentation" .
|
||||||
|
|
Loading…
Reference in a new issue