extra/js52 to 52.9.0-3

This commit is contained in:
Kevin Mihelich 2019-06-20 23:10:02 +00:00
parent 0cb029faf9
commit dfbdf20624
3 changed files with 33 additions and 81 deletions

View file

@ -1,41 +1,40 @@
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - use tarball source
# - remove -flto from CFLAGS
# - remove --enable-gold
pkgname=js52
pkgver=52.9.0
pkgrel=2
_ffver=${pkgver%%.*}
pkgdesc="JavaScript interpreter and libraries - Version $_ffver"
pkgrel=3
pkgdesc="JavaScript interpreter and libraries - Version 52"
arch=(x86_64)
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
license=(MPL)
depends=(gcc-libs readline zlib sh)
makedepends=(python2 zip autoconf2.13 mercurial)
_repo=https://hg.mozilla.org/mozilla-unified
source=("https://hg.mozilla.org/mozilla-unified/archive/FIREFOX_${pkgver//./_}esr_RELEASE.tar.gz"
makedepends=(python2 zip autoconf2.13)
_relver=${pkgver}esr
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz
mozjs52-copy-headers.patch
mozjs52-disable-mozglue.patch
mozjs52-fix-soname.patch
mozjs52-include-configure-script.patch)
sha256sums=('9603829c4ca04ec1c6eae74071b92f7ff61be842e5b554246a725d8a2ac1db32'
no-error.diff)
sha256sums=('c01d09658c53c1b3a496e353a24dad03b26b81d3b1d099abc26a06f81c199dd6'
'c5b3a88e4d10ef149aba6fc48d431db54ff266323fa22a5d549028fd794423cc'
'5a84f02521f37de873991dd360a4c4bfdbdd2fb4a218e11be73f9cbbf02050e8'
'728456fd9e66b69d6e0688c75e50091dc56735004ecf5f649212a83fe3087df1'
'd91a89acd88bfc747a255050757a0c17139bf5c3508c2e1c3c6bb2056786a344')
'4c5a1662e36c6a5a11db0263bb264d104ff801789d5b6bc6a6104439457afb90')
prepare() {
cd mozilla-unified-FIREFOX_${pkgver//./_}esr_RELEASE
cd firefox-$_relver
mkdir obj
# https://salsa.debian.org/gnome-team/mozjs52/tree/debian/master/debian/patches
patch -Np1 -i ../mozjs52-fix-soname.patch
patch -Np1 -i ../mozjs52-copy-headers.patch
patch -Np1 -i ../mozjs52-disable-mozglue.patch
patch -Np1 -i ../mozjs52-include-configure-script.patch
# New errors in test code as of GCC 9
patch -Np1 -i ../no-error.diff
}
build() {
@ -54,13 +53,17 @@ build() {
--with-intl-api
--with-system-zlib
--without-system-icu
) flags=(
-fno-delete-null-pointer-checks
-fno-strict-aliasing
-fno-tree-vrp
)
cd mozilla-unified-FIREFOX_${pkgver//./_}esr_RELEASE/obj
cd firefox-$_relver/obj
unset CPPFLAGS
CFLAGS+=' -fno-delete-null-pointer-checks -fno-strict-aliasing -fno-tree-vrp'
CXXFLAGS+=' -fno-delete-null-pointer-checks -fno-strict-aliasing -fno-tree-vrp'
CFLAGS+=" ${flags[*]}"
CXXFLAGS+=" ${flags[*]}"
export CC=gcc CXX=g++ PYTHON=/usr/bin/python2
sh ../js/src/configure "${configure_args[@]}"
@ -78,7 +81,7 @@ check() {
basic
)
cd mozilla-unified/obj
cd firefox-$_relver/obj
make -C js/src check-jstests check-jit-test \
JSTESTS_EXTRA_ARGS="${jstests_extra_args[*]}" \
JITTEST_EXTRA_ARGS="${jittest_extra_args[*]}" \
@ -86,7 +89,7 @@ check() {
}
package() {
cd mozilla-unified-FIREFOX_${pkgver//./_}esr_RELEASE/obj
cd firefox-$_relver/obj
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/lib/*.ajs
find "$pkgdir"/usr/{lib/pkgconfig,include} -type f -exec chmod -c a-x {} +

View file

@ -1,63 +0,0 @@
From 4a06a1a6a71293decb83aee7adb74bc709493106 Mon Sep 17 00:00:00 2001
From: Philip Chimento <philip.chimento@gmail.com>
Date: Wed, 5 Jul 2017 22:57:09 -0700
Subject: [PATCH] build: Include configure script, be nicer about options
A configure script is not included in the SpiderMonkey tarball by
default. Also, we have to account for JHbuild passing extra unknown
options like --disable-Werror.
https://bugzilla.mozilla.org/show_bug.cgi?id=1379540
---
js/src/configure | 9 +++++++++
python/mozbuild/mozbuild/configure/__init__.py | 2 +-
python/mozbuild/mozbuild/configure/options.py | 6 +++++-
3 files changed, 15 insertions(+), 2 deletions(-)
create mode 100755 js/src/configure
diff --git a/js/src/configure b/js/src/configure
new file mode 100755
index 00000000..f1ef8c49
--- /dev/null
+++ b/js/src/configure
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+SRCDIR=$(dirname $0)
+TOPSRCDIR="$SRCDIR"/../..
+export OLD_CONFIGURE="$SRCDIR"/old-configure
+
+set -- "$@" --enable-project=js
+
+which python2.7 > /dev/null && exec python2.7 "$TOPSRCDIR/configure.py" "$@" || exec python "$TOPSRCDIR/configure.py" "$@"
diff --git a/python/mozbuild/mozbuild/configure/__init__.py b/python/mozbuild/mozbuild/configure/__init__.py
index 0fe640ca..09b460d3 100644
--- a/python/mozbuild/mozbuild/configure/__init__.py
+++ b/python/mozbuild/mozbuild/configure/__init__.py
@@ -356,7 +356,7 @@ def run(self, path=None):
# All options should have been removed (handled) by now.
for arg in self._helper:
without_value = arg.split('=', 1)[0]
- raise InvalidOptionError('Unknown option: %s' % without_value)
+ print('Ignoring', without_value, ': Unknown option')
# Run the execution queue
for func, args in self._execution_queue:
diff --git a/python/mozbuild/mozbuild/configure/options.py b/python/mozbuild/mozbuild/configure/options.py
index 4310c862..15bfe425 100644
--- a/python/mozbuild/mozbuild/configure/options.py
+++ b/python/mozbuild/mozbuild/configure/options.py
@@ -402,7 +402,11 @@ def __init__(self, environ=os.environ, argv=sys.argv):
def add(self, arg, origin='command-line', args=None):
assert origin != 'default'
- prefix, name, values = Option.split_option(arg)
+ try:
+ prefix, name, values = Option.split_option(arg)
+ except InvalidOptionError as e:
+ print('Ignoring', arg, ':', e)
+ return
if args is None:
args = self._extra_args
if args is self._extra_args and name in self._extra_args:

12
extra/js52/no-error.diff Normal file
View file

@ -0,0 +1,12 @@
diff -u -r firefox-52.9.0esr/js/src/jsapi-tests/moz.build firefox-52.9.0esr-noerror/js/src/jsapi-tests/moz.build
--- firefox-52.9.0esr/js/src/jsapi-tests/moz.build 2017-04-11 02:13:16.000000000 +0000
+++ firefox-52.9.0esr-noerror/js/src/jsapi-tests/moz.build 2019-06-20 20:10:31.092230735 +0000
@@ -147,7 +147,7 @@
OS_LIBS += CONFIG['MOZ_ZLIB_LIBS']
if CONFIG['GNU_CXX']:
- CXXFLAGS += ['-Wno-shadow', '-Werror=format']
+ CXXFLAGS += ['-Wno-shadow']
# This is intended as a temporary workaround to enable VS2015.
if CONFIG['_MSC_VER']: