core/linux-armv7-rc to 5.0.rc2-2

This commit is contained in:
Kevin Mihelich 2019-01-18 03:28:14 +00:00
parent 4896008b0f
commit e1714de5d6
10 changed files with 66 additions and 25 deletions

View file

@ -1,7 +1,7 @@
From 31ec94ea2ed75e7ff3b473b7a4208fa126e0e357 Mon Sep 17 00:00:00 2001
From aec38a2b1453395a62290dda38a5a33706d4d13d Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/8] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.

View file

@ -1,7 +1,7 @@
From d44d25bae2baf5b0df6d88950b479f127fb94e0f Mon Sep 17 00:00:00 2001
From 500fa72f9dd68904807d9effd7011586e153ba6c Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/8] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC

View file

@ -1,7 +1,7 @@
From 9f10dfc2e7ac81a5c57dda349a9a6f0228d087af Mon Sep 17 00:00:00 2001
From 25481e75ce7ac18b05d357c95e29f8f959cbe333 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/8] SMILE Plug device tree file
Subject: [PATCH 3/9] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.

View file

@ -1,7 +1,7 @@
From 5b7fa644a61475bf9e2d5e2e696a5750d322e21e Mon Sep 17 00:00:00 2001
From faed79b3f326e7111770a260dc9790f36e36a152 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/8] fix mvsdio eMMC timing
Subject: [PATCH 4/9] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.

View file

@ -1,7 +1,7 @@
From c1d2aa1b449ee5febf9fd033d7ad24fb37463b16 Mon Sep 17 00:00:00 2001
From fe27576a0c9c3e49af29b32695dbf820c5664cb3 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/8] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++

View file

@ -1,7 +1,7 @@
From eeed3f8ebf38c00696c76d1b6afd56af39c4871a Mon Sep 17 00:00:00 2001
From a6e2f2d8098639d0ba04591a392617bcdbd03ab6 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/8] set default cubietruck led triggers
Subject: [PATCH 6/9] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---

View file

@ -1,7 +1,7 @@
From 9f6932651c7fe19267afbd4070f567fe3b766a9f Mon Sep 17 00:00:00 2001
From 3cb9a065486a4e9fc5fa0e83cd91fb86c65078c8 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 7/8] exynos4412-odroid: set higher minimum buck2 regulator
Subject: [PATCH 7/9] exynos4412-odroid: set higher minimum buck2 regulator
voltage
Set a higher minimum voltage to help reboot issue.

View file

@ -1,7 +1,7 @@
From 7808def16b309a450e15e29e60c9ebed695005e1 Mon Sep 17 00:00:00 2001
From 67be64e425bf44f5fa496833cfb32b60bc74f917 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 8/8] ARM: dove: enable ethernet on D3Plug
Subject: [PATCH 8/9] ARM: dove: enable ethernet on D3Plug
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---

View file

@ -0,0 +1,38 @@
From 5d3a19c0fd89f6721a01c882d37a6f114337edb7 Mon Sep 17 00:00:00 2001
From: Marek Szyprowski <m.szyprowski@samsung.com>
Date: Mon, 7 Jan 2019 13:04:14 +0100
Subject: [PATCH 9/9] media: s5p-mfc: fix incorrect bus assignment in virtual
child device
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Virtual MFC codec's child devices must not be assigned to platform bus,
because they are allocated as raw 'struct device' and don't have the
corresponding 'platform' part. This fixes NULL pointer access revealed
recently by commit a66d972465d1 ("devres: Align data[] to
ARCH_KMALLOC_MINALIGN").
Reported-by: Paweł Chmiel <pawel.mikolaj.chmiel@gmail.com>
Fixes: c79667dd93b0 ("media: s5p-mfc: replace custom reserved memory handling code with generic one")
Signed-off-by: Marek Szyprowski <m.szyprowski@samsung.com>
Tested-by: Paweł Chmiel <pawel.mikolaj.chmiel@gmail.com>
---
drivers/media/platform/s5p-mfc/s5p_mfc.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/media/platform/s5p-mfc/s5p_mfc.c b/drivers/media/platform/s5p-mfc/s5p_mfc.c
index 8a5ba3bec3af..0a9f59d89185 100644
--- a/drivers/media/platform/s5p-mfc/s5p_mfc.c
+++ b/drivers/media/platform/s5p-mfc/s5p_mfc.c
@@ -1089,7 +1089,6 @@ static struct device *s5p_mfc_alloc_memdev(struct device *dev,
device_initialize(child);
dev_set_name(child, "%s:%s", dev_name(dev), name);
child->parent = dev;
- child->bus = dev->bus;
child->coherent_dma_mask = dev->coherent_dma_mask;
child->dma_mask = dev->dma_mask;
child->release = s5p_mfc_memdev_release;
--
2.19.2

View file

@ -12,7 +12,7 @@ _srcname=linux-${_rcver}-rc${_rcrel}
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform (release candidate)"
pkgver=${_rcver}.rc${_rcrel}
pkgrel=1
pkgrel=2
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
@ -28,6 +28,7 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'0006-set-default-cubietruck-led-triggers.patch'
'0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
'0008-ARM-dove-enable-ethernet-on-D3Plug.patch'
'0009-media-s5p-mfc-fix-incorrect-bus-assignment-in-virtua.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -36,14 +37,15 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'99-linux.hook')
md5sums=('60b9f05b0f9bf8c31ed6b42bbd094749'
'2d6dcb489cecec6e341bd9d99ed61e46'
'37db6ec9801a3f1ee42429555256cc18'
'beedfd6612ee158e4572254a08806f1e'
'72573dfcc846e2122f817370070a8926'
'c57879b44c7894db1946b8943b231123'
'bb3e691e44e19ea4970a90720db66932'
'8b2d85a3f174ad5ab1f8f0e9bcde81ef'
'caf855734e6576759e9f4517c019c177'
'6dfc43c9e248e21453c763759cb227d8'
'186d831eddea59ab5cc7c62cc4696897'
'd9a7a634715fa7219159573bd61d3ff7'
'495ec4bfb1e4a12cca55a3c9bde58bdc'
'f6d51f34eabdfd602ddff70bc3e7d143'
'4987fdc657955965451e44202eb4e5ac'
'9940571a36c300290c158267430c541e'
'5a4a3385293b0d6b156f393a2c685475'
'e4a4d30642990394812eb996de6705d5'
'21170922884a1ab0aa7d0711e1012b5f'
'a8085cdaf57eaf9e1580f7b28535e9e9'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -67,6 +69,7 @@ prepare() {
git apply ../0006-set-default-cubietruck-led-triggers.patch
git apply ../0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
git apply ../0008-ARM-dove-enable-ethernet-on-D3Plug.patch
git apply ../0009-media-s5p-mfc-fix-incorrect-bus-assignment-in-virtua.patch
cat "${srcdir}/config" > ./.config