mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
community/openimageio: fix
This commit is contained in:
parent
593551e853
commit
e300d87f78
2 changed files with 37 additions and 2 deletions
25
community/openimageio/0001-disable-neon.patch
Normal file
25
community/openimageio/0001-disable-neon.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From aff1753c7632464312843617b1b0d98112aff04d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 2 Oct 2020 11:10:28 -0600
|
||||
Subject: [PATCH] disable neon
|
||||
|
||||
---
|
||||
src/include/OpenImageIO/simd.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/include/OpenImageIO/simd.h b/src/include/OpenImageIO/simd.h
|
||||
index 0b2c1193..5498af00 100644
|
||||
--- a/src/include/OpenImageIO/simd.h
|
||||
+++ b/src/include/OpenImageIO/simd.h
|
||||
@@ -193,7 +193,7 @@
|
||||
|
||||
// FIXME Future: support ARM Neon
|
||||
// Uncomment this when somebody with Neon can verify it works
|
||||
-#if defined(__ARM_NEON__) && !defined(OIIO_NO_NEON)
|
||||
+#if 0 && defined(__ARM_NEON__) && !defined(OIIO_NO_NEON)
|
||||
# define OIIO_SIMD 4
|
||||
# define OIIO_SIMD_NEON 1
|
||||
# define OIIO_SIMD_MAX_SIZE_BYTES 16
|
||||
--
|
||||
2.28.0
|
||||
|
|
@ -2,6 +2,7 @@
|
|||
# Contributor: SpepS <dreamspepser at yahoo dot it>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch out neon on v7, only works on v8
|
||||
# - disable lto via -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=OFF
|
||||
|
||||
pkgname=openimageio
|
||||
|
@ -17,8 +18,17 @@ depends=('openexr' 'boost-libs' 'openjpeg2' 'glew' 'libtiff' 'opencolorio' 'libp
|
|||
makedepends=('cmake' 'qt5-base' 'python' 'boost' 'mesa' 'fontconfig' 'libxrender' 'ninja' 'robin-map')
|
||||
optdepends=('qt5-base: iv image viewer'
|
||||
'python: bindings support')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenImageIO/oiio/archive/refs/tags/v$pkgver.tar.gz")
|
||||
sha512sums=('fbefa341a11fd502ec9313ca48a0fe433c5822699e4934f6a14089f670314cbe1c9c0b9a491b1d1927bda0223e38a62192c6ddeec6c4c5e6215a8b3fb6900dd8')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/OpenImageIO/oiio/archive/refs/tags/v$pkgver.tar.gz"
|
||||
'0001-disable-neon.patch')
|
||||
sha512sums=('fbefa341a11fd502ec9313ca48a0fe433c5822699e4934f6a14089f670314cbe1c9c0b9a491b1d1927bda0223e38a62192c6ddeec6c4c5e6215a8b3fb6900dd8'
|
||||
'ea88d253d9f9a9302ffe113c6d8f86ff990ada1c304c890d6aecdb4ad3370c9fd12887bb421aaaeff658af4840caefa9f243d3f552cbfc533403b81c2a56d156')
|
||||
|
||||
prepare() {
|
||||
cd oiio-$pkgver
|
||||
if [[ $CARCH == "armv7h" ]]; then
|
||||
patch -p1 -i ../0001-disable-neon.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd oiio-$pkgver
|
||||
|
|
Loading…
Reference in a new issue