community/ceph: fix

This commit is contained in:
Kevin Mihelich 2018-06-08 06:05:03 +00:00
parent 3ca4d51b8f
commit e3a320bb3c
3 changed files with 8 additions and 38 deletions

View file

@ -1,14 +1,14 @@
From abed0c91771f3349120505a28e3fe32de951f459 Mon Sep 17 00:00:00 2001
From 38f696ece361beffcc3f843c786f8b165d7ad81f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 9 Dec 2017 10:20:06 -0700
Subject: [PATCH 1/2] no neon
Subject: [PATCH] no neon
---
cmake/modules/SIMDExt.cmake | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/cmake/modules/SIMDExt.cmake b/cmake/modules/SIMDExt.cmake
index 5330835aa1..0708867de5 100644
index 021524e11e..2c4adc7307 100644
--- a/cmake/modules/SIMDExt.cmake
+++ b/cmake/modules/SIMDExt.cmake
@@ -68,10 +68,7 @@ if(CMAKE_SYSTEM_PROCESSOR MATCHES "aarch64|AARCH64")
@ -24,5 +24,5 @@ index 5330835aa1..0708867de5 100644
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "i386|i686|amd64|x86_64|AMD64")
set(HAVE_INTEL 1)
--
2.15.1
2.17.1

View file

@ -1,31 +0,0 @@
From 3c34c1168e200d9924cdc35c2d06321192838a8b Mon Sep 17 00:00:00 2001
From: Boris Ranto <branto@redhat.com>
Date: Fri, 8 Dec 2017 00:21:38 +0100
Subject: [PATCH 2/2] librbd: Conditionally import TrimRequest.cc
We include TrimRequest.cc in librbd tests at two places:
- operation/test_mock_TrimRequest.cc
- operation/test_mock_ResizeRequest.cc
That causes linking errors when doing the builds because some of the
structures are defined twice.
Signed-off-by: Boris Ranto <branto@redhat.com>
---
src/librbd/operation/TrimRequest.cc | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/librbd/operation/TrimRequest.cc b/src/librbd/operation/TrimRequest.cc
index 28f2deb1af..929ca51459 100644
--- a/src/librbd/operation/TrimRequest.cc
+++ b/src/librbd/operation/TrimRequest.cc
@@ -362,4 +362,6 @@ void TrimRequest<I>::send_finish(int r) {
} // namespace operation
} // namespace librbd
+#ifndef TEST_F
template class librbd::operation::TrimRequest<librbd::ImageCtx>;
+#endif
--
2.15.1

View file

@ -4,6 +4,7 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to remove neon detection in cmake
# - make -j3, RAM constraints
# - upstream commit to fix building on ARM
highmem=1
@ -29,7 +30,7 @@ options=('emptydirs')
source=("https://download.ceph.com/tarballs/${pkgbase}-${pkgver}.tar.gz"
'ceph.sysusers'
'0001-no-neon.patch'
'0002-librbd-Conditionally-import-TrimRequest.cc.patch'
'https://github.com/ceph/ceph/commit/61516bcfac4dff53d0e24f6c4623127465c46d9d.patch'
'boost-1.67.patch'
'fix-ceph_disk-python-interpreter.patch'
'fix-or-disable-broken-tests.patch'
@ -37,8 +38,8 @@ source=("https://download.ceph.com/tarballs/${pkgbase}-${pkgver}.tar.gz"
'remove-distro-version-detection.patch')
sha512sums=('2524ad5a868024463e1a1edc5bd9c3f7bc1f58e47bf8d331902ed53206120abc6a427dd9c1d657131e67efd955d6ed8052b6c3fed8658aa905d58ac58ee62973'
'4354001c1abd9a0c385ba7bd529e3638fb6660b6a88d4e49706d4ac21c81b8e829303a20fb5445730bdac18c4865efb10bc809c1cd56d743c12aa9a52e160049'
'e389a0034d1310d9a2d15c9f8b1d489fa65d2222668566747f1da2e83564f7b78507f3ad2d71887a2b6d56751eebd8d7b3ce43e435e404afb765e4b3ded6821e'
'6c410d26a7e510d126dd361e389b470dd6448fcbbb255b1b31b2a1c9a437397e46cd18ba0e17405c47b91cc9c55dcc8d1fc1029527b6d90e6ac990a1b0ac2bc9'
'5b813e2532d5e497d44a41c57493fb4eacecd46cac56ad49815b9f5db798ddcb4fdeb6574e86b1b45fef526feef156d9262a98bb73cdf89c9960222f66ca6d55'
'ba552ca7937cc1279360225072af5e5fe1eb459037382f544aaedacbe022b6984d9ca913fc34f4a16c4832b172d3e8f27201914cfb56b13b01044752725445dd'
'1e29028783bb50ab0fda0ef915a795cd77b09a9b605e8ffaaab9ac6464b207f9b1c8772779ca2e8b90eec4990d516d8400619819c9f3ec21b578aea084da8fa5'
'7abd94a333fb0d6c9f7156d69ed6d4bf123f0f3030407f4347209d677b282e5023664d43e74a21a27b7856d3493ae469a17ea8a810331c7266018cc34eee4841'
'915bb02b91a2e7c6e21243e5d4d80847aedaf6f899e3bac55f4ccae4bb8386c434aad7f052dd449fd510c103f7796bd0a25c0cfac72ee8d1e94d230cf2f0550a'