extra/blender to 3.6.2-6

This commit is contained in:
Kevin Mihelich 2023-09-15 13:58:31 +00:00
parent 46962bf730
commit e446b77ee7
2 changed files with 40 additions and 6 deletions

View file

@ -17,7 +17,7 @@ buildarch=8
pkgname=blender
pkgver=3.6.2
pkgrel=4
pkgrel=6
epoch=17
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('x86_64')
@ -26,10 +26,10 @@ url="https://www.blender.org"
depends=('libpng' 'libtiff' 'openexr' 'python' 'desktop-file-utils' 'python-requests' 'potrace'
'shared-mime-info' 'hicolor-icon-theme' 'xdg-utils' 'glew' 'openjpeg2' 'python-numpy'
'freetype2' 'openal' 'ffmpeg' 'fftw' 'boost-libs' 'opencollada' 'alembic' 'openxr'
'openimageio' 'libsndfile' 'jack' 'opencolorio' 'openshadinglanguage'
'openimageio' 'libsndfile' 'jack' 'opencolorio'
'jemalloc' 'libspnav' 'ptex' 'opensubdiv' 'openvdb' 'sdl2' 'libharu'
'draco' 'libxkbcommon' 'libepoxy')
makedepends=('cmake' 'boost' 'mesa' 'git' 'svn' 'llvm15' 'ninja' 'wayland-protocols'
makedepends=('cmake' 'boost' 'mesa' 'git' 'svn' 'llvm' 'ninja' 'wayland-protocols'
'libxkbcommon' 'libdecor')
optdepends=('libdecor: wayland support')
# We're using !buildflags here as otherwise we get stuff such as FS#77557
@ -40,18 +40,22 @@ source=("git+https://projects.blender.org/blender/blender.git#commit=$_commit"
https://developer.download.nvidia.com/redist/optix/v7.6/OptiX-7.6-Include.zip
force-draco1.patch
force-draco2.patch
blender-new-sycl.patch)
blender-new-sycl.patch
openxr.patch)
sha512sums=('SKIP'
'dfe86de395dd298fb9feae73bff06a26742efa06a25bb5a4f78ffb1ba4c78f555d1af927efea98af281715cce01db219aa2adfd6bd323bf0d766c1c70ce03532'
'e239da4f3906f1b54265435181cf770bae3d269c8d915df9a73861e6ee71ec70bf2339426e7c81a91e5a567273b3b3742d7a99feefd3398d821b26e1ff3a56d0'
'c162646eba42ea7112cfb615466c2cbaddac8d254d4a9e91cf887c5bffef1325a983701163223a1fdee091310ac5574a400347aab7f52321825b5fa3d5a9036f'
'b1eb2379b673514da2599c5fc3be7fc597d4d3d23550ff392b364ae53f67e332bbed7612a0d06cbf9cd255ad6833bdb29f7e3fe668471d57e91407092419f4dd')
'b1eb2379b673514da2599c5fc3be7fc597d4d3d23550ff392b364ae53f67e332bbed7612a0d06cbf9cd255ad6833bdb29f7e3fe668471d57e91407092419f4dd'
'b5f1ebee05f7099568d6dc1c5b8d4518ca0bba08a167ad979d72f6a382378019fd6c8493ccb1e7424c94866068522f5b1faaace69044639e401db0c3d958bb59')
prepare() {
cd "$pkgname"
make update
patch -p1 -i "$srcdir"/openxr.patch
# fix draco
patch -p1 -i "$srcdir"/force-draco1.patch
patch -p1 -d scripts/addons -i "$srcdir"/force-draco2.patch
@ -76,9 +80,10 @@ build() {
-GNinja \
-Cbuild_files/cmake/config/blender_release.cmake \
-C precache \
-DLLVM_VERSION=15 \
-DLLVM_VERSION=16 \
-DPYTHON_VERSION=$PYTHON_VER \
-DOPTIX_ROOT_DIR="$srcdir" \
-DWITH_CYCLES_OSL=NO \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DWITH_INSTALL_PORTABLE=OFF \

View file

@ -0,0 +1,29 @@
From 76dcf5b15d4789fb00b73a5b817f4768cee4c3ef Mon Sep 17 00:00:00 2001
From: ChengduLittleA <xp8110@outlook.com>
Date: Tue, 5 Sep 2023 10:11:08 +0800
Subject: [PATCH 2/2] Use XR_CURRENT_API_VERSION for different type casting
---
intern/ghost/intern/GHOST_XrGraphicsBinding.cc | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/intern/ghost/intern/GHOST_XrGraphicsBinding.cc b/intern/ghost/intern/GHOST_XrGraphicsBinding.cc
index dad9fab9337..4bd47ee4953 100644
--- a/intern/ghost/intern/GHOST_XrGraphicsBinding.cc
+++ b/intern/ghost/intern/GHOST_XrGraphicsBinding.cc
@@ -153,7 +153,12 @@ class GHOST_XrGraphicsBindingOpenGL : public GHOST_IXrGraphicsBinding {
# if defined(WITH_GHOST_X11)
/* #GHOST_SystemX11. */
oxr_binding.egl.type = XR_TYPE_GRAPHICS_BINDING_EGL_MNDX;
+# if XR_CURRENT_API_VERSION >= XR_MAKE_VERSION(1, 0, 29)
+ oxr_binding.egl.getProcAddress = reinterpret_cast<PFN_xrEglGetProcAddressMNDX>(
+ eglGetProcAddress);
+# else
oxr_binding.egl.getProcAddress = eglGetProcAddress;
+# endif
oxr_binding.egl.display = ctx_egl.getDisplay();
oxr_binding.egl.config = ctx_egl.getConfig();
oxr_binding.egl.context = ctx_egl.getContext();
--
2.30.2