extra/qt5-webengine: fix

This commit is contained in:
Kevin Mihelich 2021-10-17 20:49:50 +00:00
parent baf8f11f07
commit e48e6a2d19
4 changed files with 9 additions and 9 deletions

View file

@ -1,4 +1,4 @@
From 005a59a7b37f64c9f130adcdfffff3b7b99ae257 Mon Sep 17 00:00:00 2001
From 30959e74702e266b93e7a1322b34e33c6c94a2eb Mon Sep 17 00:00:00 2001
From: Yuki Shiino <yukishiino@chromium.org>
Date: Mon, 5 Oct 2020 11:01:57 +0000
Subject: [PATCH 3/5] bind-gen: Support --single_process flag in
@ -20,7 +20,7 @@ Cr-Commit-Position: refs/heads/master@{#813675}
2 files changed, 49 insertions(+), 33 deletions(-)
diff --git a/chromium/third_party/blink/renderer/bindings/scripts/bind_gen/task_queue.py b/chromium/third_party/blink/renderer/bindings/scripts/bind_gen/task_queue.py
index e666a9b668e..16bb8cc575e 100644
index e666a9b668e..42b96d41688 100644
--- a/chromium/third_party/blink/renderer/bindings/scripts/bind_gen/task_queue.py
+++ b/chromium/third_party/blink/renderer/bindings/scripts/bind_gen/task_queue.py
@@ -14,10 +14,23 @@ class TaskQueue(object):
@ -79,7 +79,7 @@ index e666a9b668e..16bb8cc575e 100644
+ for index, task in enumerate(self._requested_tasks):
+ func, args, kwargs = task
+ report_progress(len(self._requested_tasks), index)
+ apply(func, args, kwargs)
+ func(*args, **kwargs)
+ report_progress(len(self._requested_tasks), len(self._requested_tasks))
+
+ def _run_in_parallel(self, report_progress):
@ -93,7 +93,7 @@ index e666a9b668e..16bb8cc575e 100644
+ def report_worker_task_progress():
+ if not report_progress:
+ return
+ done_count = reduce(
+ done_count = functools.reduce(
+ lambda count, worker_task: count + bool(worker_task.ready()),
+ self._worker_tasks, 0)
+ report_progress(len(self._worker_tasks), done_count)

View file

@ -1,4 +1,4 @@
From 9eb798765b417f2c419926ba78315c0b2bcf136a Mon Sep 17 00:00:00 2001
From 61c2c92e3d37c7c7c8a812424766342dbeace848 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 2 Feb 2021 13:58:59 -0700
Subject: [PATCH 4/5] Run blink bindings generation single threaded

View file

@ -1,4 +1,4 @@
From a1a7a22464fbd48fc31a752590fc791fba5bcb84 Mon Sep 17 00:00:00 2001
From 27bfb004e8f3e38fd4220b94852a57d3f7d61e04 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 2 Feb 2021 13:58:21 -0700
Subject: [PATCH 5/5] Fix sandbox 'Aw snap' for sycalls 403 and 407

View file

@ -46,9 +46,9 @@ sha256sums=('SKIP'
'c15954ab938ec6235c5d9756753773896691a77ff6a5bf7ef183122f5d04f022'
'412c675fd60e78785e7dfedafa4982d999ea5797c65580d6465e53288ad3000e'
'64f50a097a69c37ea07ad5ddf01f8342a97a786174382907922d7d22c1d88fc6'
'252ad4cb3ab11ef48583a404ba867da2de92bc2d2e678f5a80ea3b32150db5a1'
'6d1546d00babc2c3f3d80340d1ef98ef90261d8885810a217bed34e4a1dc906e'
'd666a228c476ae6f61ffcc9672d2a79cc0c7d293c24e392ab64ddf2f85cb84b0')
'56034f14437842e3182252cebbd824f7845affb4af9c2af41de2528ea8cfa02d'
'9ed3b4d24047061f68b6e94cb616304bb857eec1e2bafe1df686526c35da44e4'
'5b2024eaf70a6e0fc6227dd63c76b419f74cf815741d6e063847a442590755ce')
prepare() {
mkdir -p build