mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/nodejs to 6.8.0-1
This commit is contained in:
parent
65bc7cba98
commit
e4ca60192e
2 changed files with 37 additions and 2 deletions
30
community/nodejs/6.8.0-build-fix.patch
Normal file
30
community/nodejs/6.8.0-build-fix.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
From fc164acbbb700fd50ab9c04b47fc1b2687e9c0f4 Mon Sep 17 00:00:00 2001
|
||||
From: "Bradley T. Hughes" <bradleythughes@fastmail.fm>
|
||||
Date: Thu, 13 Oct 2016 07:38:38 +0000
|
||||
Subject: [PATCH] build: add -DZLIB_CONST when building with --shared-zlib
|
||||
|
||||
Commit 782620f added the define only when building with the bundled
|
||||
zlib. Using a shared zlib results in build breakage:
|
||||
|
||||
../src/inspector_agent.cc:179:16: error: assigning to 'Bytef *' (aka 'unsigned char *') from incompatible type
|
||||
'const uint8_t *' (aka 'const unsigned char *')
|
||||
strm.next_in = PROTOCOL_JSON + 3;
|
||||
^ ~~~~~~~~~~~~~~~~~
|
||||
1 error generated.
|
||||
---
|
||||
node.gyp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/node.gyp b/node.gyp
|
||||
index fa98547..d799ba1 100644
|
||||
--- a/node.gyp
|
||||
+++ b/node.gyp
|
||||
@@ -480,6 +480,8 @@
|
||||
}],
|
||||
[ 'node_shared_zlib=="false"', {
|
||||
'dependencies': [ 'deps/zlib/zlib.gyp:zlib' ],
|
||||
+ }, {
|
||||
+ 'defines': [ 'ZLIB_CONST' ],
|
||||
}],
|
||||
|
||||
[ 'node_shared_http_parser=="false"', {
|
|
@ -9,7 +9,7 @@
|
|||
# Contributor: Jason Plum <jplum@archlinuxarm.org>
|
||||
|
||||
pkgname=nodejs
|
||||
pkgver=6.7.0
|
||||
pkgver=6.8.0
|
||||
pkgrel=1
|
||||
pkgdesc='Evented I/O for V8 javascript'
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -20,8 +20,10 @@ depends=('openssl' 'zlib' 'icu' 'libuv' 'http-parser') # 'v8')
|
|||
makedepends=('python2' 'procps-ng' 'git')
|
||||
optdepends=('npm: nodejs package manager')
|
||||
source=("nodejs::git+https://github.com/nodejs/node.git#tag=v$pkgver"
|
||||
6.8.0-build-fix.patch
|
||||
'0001-arm-fixes.patch')
|
||||
sha256sums=('SKIP'
|
||||
'bc9c4c1fcef55e6163daf7c4ee882d8a23973e16e28fea508ee72478cb9941fa'
|
||||
'eaeb2f55bd3390c50b8bb2bfe73131eb0fea20cccee88ed66331da93c1746fb6')
|
||||
|
||||
set_flags_for_arm() {
|
||||
|
@ -46,6 +48,9 @@ set_flags_for_arm() {
|
|||
prepare() {
|
||||
cd nodejs
|
||||
|
||||
# https://github.com/nodejs/node/issues/9076
|
||||
patch -p1 -i ../6.8.0-build-fix.patch
|
||||
|
||||
patch -p1 -i ../0001-arm-fixes.patch
|
||||
|
||||
msg 'Fixing for python2 name'
|
||||
|
@ -100,7 +105,7 @@ build() {
|
|||
|
||||
check() {
|
||||
cd nodejs
|
||||
make test || warning "Tests failed"
|
||||
make test
|
||||
}
|
||||
|
||||
package() {
|
||||
|
|
Loading…
Reference in a new issue