added community/toolame

This commit is contained in:
Kevin Mihelich 2012-02-21 23:44:06 -05:00
parent 315eea3dbf
commit e597be4fcb
2 changed files with 118 additions and 0 deletions

View file

@ -0,0 +1,32 @@
# $Id: PKGBUILD 65411 2012-02-21 03:29:11Z spupykin $
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Victor Martinez Romanos <vmromanos@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - Makefile replacements for ARM
plugrel=1
pkgname=toolame
pkgver=02l
pkgrel=9
pkgdesc="An optimized mpeg 1/2 layer 2 audio encoder"
arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/toolame"
license=('LGPL')
depends=('glibc')
source=(http://downloads.sourceforge.net/sourceforge/toolame/toolame-02l.tgz
toolame-02l.patch)
md5sums=('5946e2dd78fbb57e54386b3b5d873fee'
'7fe02630ce8f08bd279a4bce93e64128')
build() {
cd $srcdir/$pkgname-$pkgver
patch -p0 < ../toolame-02l.patch
[ "$CARCH" = "x86_64" ] && sed -i "s|-march=i686|-march=x86-64|g" Makefile
[ "$CARCH" = "arm" ] && sed -i "s|-march=i686|-march=armv5te|g" Makefile
[ "$CARCH" = "armv7h" ] && sed -i "s|-march=i686|-march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16|g" Makefile
make
install -D -m755 toolame $pkgdir/usr/bin/toolame
}

View file

@ -0,0 +1,86 @@
--- Makefile 2006-02-07 16:32:57.000000000 +0100
+++ Makefile 2006-02-07 16:39:07.000000000 +0100
@@ -1,6 +1,3 @@
-
-CC = gcc
-
c_sources = \
common.c \
encode.c \
@@ -28,16 +25,16 @@
#Uncomment this if you want to do some profiling/debugging
#PG = -g -pg
-PG = -fomit-frame-pointer
+PG = -pipe
# Optimize flag. 3 is about as high as you can sanely go with GCC3.2.
-OPTIM = -O3
+OPTIM = -O2
# These flags are pretty much mandatory
REQUIRED = -DNDEBUG -DINLINE=inline
#pick your architecture
-ARCH = -march=pentium
+ARCH = -march=i686
#Possible x86 architectures
#gcc3.2 => i386, i486, i586, i686, pentium, pentium-mmx
# pentiumpro, pentium2, pentium3, pentium4, k6, k6-2, k6-3,
@@ -56,7 +53,7 @@
NEW_02L_FIXES = -DNEWENCODE -DNEWATAN
-CC_SWITCHES = $(OPTIM) $(REQUIRED) $(ARCH) $(PG) $(TWEAKS) $(WARNINGS) $(NEW_02L_FIXES)
+CC_SWITCHES = $(OPTIM) $(REQUIRED) $(ARCH) $(PG) $(FLAGS) $(WARNINGS) $(NEW_02L_FIXES)
PGM = toolame
@@ -75,16 +72,16 @@
$(CC) $(CC_SWITCHES) -c $< -o $@
$(PGM): $(OBJ) Makefile
- $(CC) $(PG) -o $(PGM) $(OBJ) $(LIBS)
+ $(CC) -o $(PGM) $(OBJ) $(LIBS)
clean:
- -rm $(OBJ) $(DEP)
+ -rm $(OBJ) $(DEP) 2>/dev/null
megaclean:
- -rm $(OBJ) $(DEP) $(PGM) \#*\# *~
+ -rm $(OBJ) $(DEP) $(PGM) \#*\# *~ 2>/dev/null
distclean:
- -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile
+ -rm $(OBJ) $(DEP) $(PGM) \#* *~ gmon.out gprof* core *shit* *.wav *.mp2 *.c.* *.mp2.* *.da *.h.* *.d *.mp3 *.pcm *.wav logfile 2>/dev/null
tags: TAGS
--- audio_read.c 2003-03-01 17:18:30.000000000 -0800
+++ audio_read.c 2005-04-19 22:32:41.288998770 -0700
@@ -436,7 +436,7 @@
if (pcm_aiff_data->sampleSize != sizeof (short) * BITS_IN_A_BYTE) {
fprintf (stderr, "Sound data is not %d bits in \"%s\".\n",
- sizeof (short) * BITS_IN_A_BYTE, file_name);
+ (int)(sizeof (short) * BITS_IN_A_BYTE), file_name);
exit (1);
}
--- fft.c 2003-03-01 23:14:45.000000000 -0800
+++ fft.c 2005-04-19 22:47:49.019986989 -0700
@@ -1190,9 +1190,9 @@
static FLOAT atan_t[ATANSIZE];
INLINE FLOAT atan_table(FLOAT y, FLOAT x) {
- int index;
+ unsigned int index;
- index = (int)(ATANSCALE * fabs(y/x));
+ index = (unsigned int)(ATANSCALE * fabs(y/x));
if (index>=ATANSIZE)
index = ATANSIZE-1;