mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/qt5-webengine to 5.15.6-2
This commit is contained in:
parent
e242a59235
commit
ece9bb5473
3 changed files with 129 additions and 1 deletions
|
@ -12,7 +12,7 @@ highmem=1
|
||||||
pkgname=qt5-webengine
|
pkgname=qt5-webengine
|
||||||
_qtver=5.15.6
|
_qtver=5.15.6
|
||||||
pkgver=${_qtver/-/}
|
pkgver=${_qtver/-/}
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url='https://www.qt.io'
|
url='https://www.qt.io'
|
||||||
license=('LGPL3' 'LGPL2.1' 'BSD')
|
license=('LGPL3' 'LGPL2.1' 'BSD')
|
||||||
|
@ -25,6 +25,8 @@ groups=('qt' 'qt5')
|
||||||
_pkgfqn=qtwebengine
|
_pkgfqn=qtwebengine
|
||||||
source=(git+https://code.qt.io/qt/qtwebengine.git#tag=v${pkgver}-lts
|
source=(git+https://code.qt.io/qt/qtwebengine.git#tag=v${pkgver}-lts
|
||||||
git+https://code.qt.io/qt/qtwebengine-chromium.git
|
git+https://code.qt.io/qt/qtwebengine-chromium.git
|
||||||
|
chromium-harfbuzz-3.0.0.patch
|
||||||
|
skia-harfbuzz-3.0.0.patch
|
||||||
qt5-webengine-glibc-2.33.patch
|
qt5-webengine-glibc-2.33.patch
|
||||||
0001-ARM-toolchain-fixes.patch
|
0001-ARM-toolchain-fixes.patch
|
||||||
0002-Fix-ARM-skia-ICE.patch
|
0002-Fix-ARM-skia-ICE.patch
|
||||||
|
@ -33,6 +35,8 @@ source=(git+https://code.qt.io/qt/qtwebengine.git#tag=v${pkgver}-lts
|
||||||
0005-Fix-sandbox-Aw-snap-for-sycalls-403-and-407.patch)
|
0005-Fix-sandbox-Aw-snap-for-sycalls-403-and-407.patch)
|
||||||
sha256sums=('SKIP'
|
sha256sums=('SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
|
'7ce947944a139e66774dfc7249bf7c3069f07f83a0f1b2c1a1b14287a7e15928'
|
||||||
|
'dae11dec5088eb1b14045d8c9862801a342609c15701d7c371e1caccf46e1ffd'
|
||||||
'2294e5390c869963fc58f7bf1ee0a254a3f7fce3ed00c04e34a5f03e2b31b624'
|
'2294e5390c869963fc58f7bf1ee0a254a3f7fce3ed00c04e34a5f03e2b31b624'
|
||||||
'10b3fed2d67b3a1f487d2d95c9a603fcbc23f08d4528d1986a6d0010c9e466bc'
|
'10b3fed2d67b3a1f487d2d95c9a603fcbc23f08d4528d1986a6d0010c9e466bc'
|
||||||
'48f37525c7066b0119b10981ae59139189ca3423db6bd14da6e064065d5d3016'
|
'48f37525c7066b0119b10981ae59139189ca3423db6bd14da6e064065d5d3016'
|
||||||
|
@ -49,6 +53,10 @@ prepare() {
|
||||||
git submodule set-branch --branch 87-based src/3rdparty
|
git submodule set-branch --branch 87-based src/3rdparty
|
||||||
git submodule update
|
git submodule update
|
||||||
|
|
||||||
|
# Fix build with harfbuzz 3.0.0
|
||||||
|
patch -p1 -d src/3rdparty/chromium -i "$srcdir"/chromium-harfbuzz-3.0.0.patch
|
||||||
|
patch -p1 -d src/3rdparty/chromium/third_party/skia -i "$srcdir"/skia-harfbuzz-3.0.0.patch
|
||||||
|
|
||||||
patch -p1 -i "$srcdir"/qt5-webengine-glibc-2.33.patch # Fix text rendering when building with glibc 2.33
|
patch -p1 -i "$srcdir"/qt5-webengine-glibc-2.33.patch # Fix text rendering when building with glibc 2.33
|
||||||
|
|
||||||
cd "$srcdir/$_pkgfqn/src/3rdparty"
|
cd "$srcdir/$_pkgfqn/src/3rdparty"
|
||||||
|
|
20
extra/qt5-webengine/chromium-harfbuzz-3.0.0.patch
Normal file
20
extra/qt5-webengine/chromium-harfbuzz-3.0.0.patch
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
# https://github.com/chromium/chromium/commit/b289f6f3fcbc
|
||||||
|
|
||||||
|
diff --git a/components/paint_preview/common/subset_font.cc b/components/paint_preview/common/subset_font.cc
|
||||||
|
index 8ff0540d9a..20a7d37474 100644
|
||||||
|
--- a/components/paint_preview/common/subset_font.cc
|
||||||
|
+++ b/components/paint_preview/common/subset_font.cc
|
||||||
|
@@ -72,9 +72,11 @@ sk_sp<SkData> SubsetFont(SkTypeface* typeface, const GlyphUsage& usage) {
|
||||||
|
hb_set_t* glyphs =
|
||||||
|
hb_subset_input_glyph_set(input.get()); // Owned by |input|.
|
||||||
|
usage.ForEach(base::BindRepeating(&AddGlyphs, base::Unretained(glyphs)));
|
||||||
|
- hb_subset_input_set_retain_gids(input.get(), true);
|
||||||
|
+ hb_subset_input_set_flags(input.get(), HB_SUBSET_FLAGS_RETAIN_GIDS);
|
||||||
|
|
||||||
|
- HbScoped<hb_face_t> subset_face(hb_subset(face.get(), input.get()));
|
||||||
|
+ HbScoped<hb_face_t> subset_face(hb_subset_or_fail(face.get(), input.get()));
|
||||||
|
+ if (!subset_face)
|
||||||
|
+ return nullptr;
|
||||||
|
HbScoped<hb_blob_t> subset_blob(hb_face_reference_blob(subset_face.get()));
|
||||||
|
if (!subset_blob)
|
||||||
|
return nullptr;
|
100
extra/qt5-webengine/skia-harfbuzz-3.0.0.patch
Normal file
100
extra/qt5-webengine/skia-harfbuzz-3.0.0.patch
Normal file
|
@ -0,0 +1,100 @@
|
||||||
|
# Minimal diff for harfbuzz 3.0.0 support; based on:
|
||||||
|
# https://github.com/google/skia/commit/66684b17b382
|
||||||
|
# https://github.com/google/skia/commit/51d83abcd24a
|
||||||
|
|
||||||
|
diff --git a/gn/skia.gni b/gn/skia.gni
|
||||||
|
index d98fdc19ee..199335d5c4 100644
|
||||||
|
--- a/gn/skia.gni
|
||||||
|
+++ b/gn/skia.gni
|
||||||
|
@@ -34,8 +34,6 @@ declare_args() {
|
||||||
|
skia_include_multiframe_procs = false
|
||||||
|
skia_lex = false
|
||||||
|
skia_libgifcodec_path = "third_party/externals/libgifcodec"
|
||||||
|
- skia_pdf_subset_harfbuzz =
|
||||||
|
- false # TODO: set skia_pdf_subset_harfbuzz to skia_use_harfbuzz.
|
||||||
|
skia_qt_path = getenv("QT_PATH")
|
||||||
|
skia_skqp_global_error_tolerance = 0
|
||||||
|
skia_tools_require_resources = false
|
||||||
|
@@ -99,6 +97,10 @@ declare_args() {
|
||||||
|
skia_use_libfuzzer_defaults = true
|
||||||
|
}
|
||||||
|
|
||||||
|
+declare_args() {
|
||||||
|
+ skia_pdf_subset_harfbuzz = skia_use_harfbuzz
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
declare_args() {
|
||||||
|
skia_compile_sksl_tests = skia_compile_processors
|
||||||
|
skia_enable_fontmgr_android = skia_use_expat && skia_use_freetype
|
||||||
|
diff --git a/src/pdf/SkPDFSubsetFont.cpp b/src/pdf/SkPDFSubsetFont.cpp
|
||||||
|
index 81c37eef3a..2340a7937b 100644
|
||||||
|
--- a/src/pdf/SkPDFSubsetFont.cpp
|
||||||
|
+++ b/src/pdf/SkPDFSubsetFont.cpp
|
||||||
|
@@ -49,6 +49,37 @@ static sk_sp<SkData> to_data(HBBlob blob) {
|
||||||
|
blob.release());
|
||||||
|
}
|
||||||
|
|
||||||
|
+template<typename...> using void_t = void;
|
||||||
|
+template<typename T, typename = void>
|
||||||
|
+struct SkPDFHarfBuzzSubset {
|
||||||
|
+ // This is the HarfBuzz 3.0 interface.
|
||||||
|
+ // hb_subset_flags_t does not exist in 2.0. It isn't dependent on T, so inline the value of
|
||||||
|
+ // HB_SUBSET_FLAGS_RETAIN_GIDS until 2.0 is no longer supported.
|
||||||
|
+ static HBFace Make(T input, hb_face_t* face) {
|
||||||
|
+ // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
|
||||||
|
+ // If it isn't known if a font is 'tricky', retain the hints.
|
||||||
|
+ hb_subset_input_set_flags(input, 2/*HB_SUBSET_FLAGS_RETAIN_GIDS*/);
|
||||||
|
+ return HBFace(hb_subset_or_fail(face, input));
|
||||||
|
+ }
|
||||||
|
+};
|
||||||
|
+template<typename T>
|
||||||
|
+struct SkPDFHarfBuzzSubset<T, void_t<
|
||||||
|
+ decltype(hb_subset_input_set_retain_gids(std::declval<T>(), std::declval<bool>())),
|
||||||
|
+ decltype(hb_subset_input_set_drop_hints(std::declval<T>(), std::declval<bool>())),
|
||||||
|
+ decltype(hb_subset(std::declval<hb_face_t*>(), std::declval<T>()))
|
||||||
|
+ >>
|
||||||
|
+{
|
||||||
|
+ // This is the HarfBuzz 2.0 (non-public) interface, used if it exists.
|
||||||
|
+ // This code should be removed as soon as all users are migrated to the newer API.
|
||||||
|
+ static HBFace Make(T input, hb_face_t* face) {
|
||||||
|
+ hb_subset_input_set_retain_gids(input, true);
|
||||||
|
+ // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
|
||||||
|
+ // If it isn't known if a font is 'tricky', retain the hints.
|
||||||
|
+ hb_subset_input_set_drop_hints(input, false);
|
||||||
|
+ return HBFace(hb_subset(face, input));
|
||||||
|
+ }
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
static sk_sp<SkData> subset_harfbuzz(sk_sp<SkData> fontData,
|
||||||
|
const SkPDFGlyphUse& glyphUsage,
|
||||||
|
int ttcIndex) {
|
||||||
|
@@ -71,11 +102,10 @@ static sk_sp<SkData> subset_harfbuzz(sk_sp<SkData> fontData,
|
||||||
|
hb_set_t* glyphs = hb_subset_input_glyph_set(input.get());
|
||||||
|
glyphUsage.getSetValues([&glyphs](unsigned gid) { hb_set_add(glyphs, gid);});
|
||||||
|
|
||||||
|
- hb_subset_input_set_retain_gids(input.get(), true);
|
||||||
|
- // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
|
||||||
|
- // If it isn't known if a font is 'tricky', retain the hints.
|
||||||
|
- hb_subset_input_set_drop_hints(input.get(), false);
|
||||||
|
- HBFace subset(hb_subset(face.get(), input.get()));
|
||||||
|
+ HBFace subset = SkPDFHarfBuzzSubset<hb_subset_input_t*>::Make(input.get(), face.get());
|
||||||
|
+ if (!subset) {
|
||||||
|
+ return nullptr;
|
||||||
|
+ }
|
||||||
|
HBBlob result(hb_face_reference_blob(subset.get()));
|
||||||
|
return to_data(std::move(result));
|
||||||
|
}
|
||||||
|
diff --git a/third_party/harfbuzz/BUILD.gn b/third_party/harfbuzz/BUILD.gn
|
||||||
|
index 173830de62..4156607ef9 100644
|
||||||
|
--- a/third_party/harfbuzz/BUILD.gn
|
||||||
|
+++ b/third_party/harfbuzz/BUILD.gn
|
||||||
|
@@ -14,6 +14,9 @@ if (skia_use_system_harfbuzz) {
|
||||||
|
system("harfbuzz") {
|
||||||
|
include_dirs = [ "/usr/include/harfbuzz" ]
|
||||||
|
libs = [ "harfbuzz" ]
|
||||||
|
+ if (skia_pdf_subset_harfbuzz) {
|
||||||
|
+ libs += [ "harfbuzz-subset" ]
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
} else {
|
||||||
|
third_party("harfbuzz") {
|
Loading…
Reference in a new issue