added extra/qt5-doc

This commit is contained in:
Kevin Mihelich 2017-06-09 12:24:22 +00:00
parent ce06c42f37
commit eebb4448bb
2 changed files with 137 additions and 0 deletions

View file

@ -0,0 +1,72 @@
From 581e99bdd47340b9b3d41cffd51d8ac03422def6 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 8 Jun 2017 20:41:08 -0600
Subject: [PATCH] ARM toolchain fixes
---
chromium/build/toolchain/linux/BUILD.gn | 20 +++++++++++++++++++-
chromium/tools/gn/args.cc | 3 +++
2 files changed, 22 insertions(+), 1 deletion(-)
diff --git a/chromium/build/toolchain/linux/BUILD.gn b/chromium/build/toolchain/linux/BUILD.gn
index 548722d393..8a24c50f79 100644
--- a/chromium/build/toolchain/linux/BUILD.gn
+++ b/chromium/build/toolchain/linux/BUILD.gn
@@ -22,7 +22,7 @@ clang_toolchain("clang_arm64") {
}
gcc_toolchain("arm") {
- toolprefix = "arm-linux-gnueabihf-"
+ toolprefix = ""
cc = "${toolprefix}gcc"
cxx = "${toolprefix}g++"
@@ -39,6 +39,24 @@ gcc_toolchain("arm") {
}
}
+gcc_toolchain("arm64") {
+ toolprefix = ""
+
+ cc = "${toolprefix}gcc"
+ cxx = "${toolprefix}g++"
+
+ ar = "${toolprefix}ar"
+ ld = cxx
+ readelf = "${toolprefix}readelf"
+ nm = "${toolprefix}nm"
+
+ toolchain_args = {
+ current_cpu = "arm64"
+ current_os = "linux"
+ is_clang = false
+ }
+}
+
clang_toolchain("clang_x86") {
toolchain_args = {
current_cpu = "x86"
diff --git a/chromium/tools/gn/args.cc b/chromium/tools/gn/args.cc
index 7285d7a538..54703e1760 100644
--- a/chromium/tools/gn/args.cc
+++ b/chromium/tools/gn/args.cc
@@ -266,6 +266,7 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
static const char kX86[] = "x86";
static const char kX64[] = "x64";
static const char kArm[] = "arm";
+ static const char kArm64[] = "arm64";
static const char kMips[] = "mipsel";
static const char kS390X[] = "s390x";
static const char kPPC64[] = "ppc64";
@@ -280,6 +281,8 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
arch = kX64;
else if (os_arch.substr(0, 3) == "arm")
arch = kArm;
+ else if (os_arch == "aarch64")
+ arch = kArm64;
else if (os_arch == "mips")
arch = kMips;
else if (os_arch == "s390x")
--
2.12.0

65
extra/qt5-doc/PKGBUILD Normal file
View file

@ -0,0 +1,65 @@
# $Id: PKGBUILD 240297 2015-06-03 10:22:03Z fyan $
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Michael Hansen <zrax0111 gmail com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch for chromium GN
pkgname=qt5-doc
_qtver=5.9.0
pkgver=${_qtver/-/}
pkgrel=1
arch=('any')
url='http://qt-project.org/'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
pkgdesc='A cross-platform application and UI framework (Documentation)'
depends=('qt5-base')
makedepends=('qt5-tools' 'python2' 'pciutils' 'libxtst' 'libxcursor' 'libxrandr' 'libxss' 'libxcomposite' 'git')
groups=('qt' 'qt5')
_pkgfqn="qt-everywhere-opensource-src-${_qtver}"
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/single/${_pkgfqn}.tar.xz"
'0001-ARM-toolchain-fixes.patch')
sha256sums=('f70b5c66161191489fc13c7b7eb69bf9df3881596b183e7f6d94305a39837517'
'897c5960db849211f525039d386e21692cad8a5ba056f3e22440146225c20df8')
prepare() {
cd ${_pkgfqn}
ln -s /usr/bin qttools/
ln -s /usr/bin/{rcc,uic,moc} qtbase/bin/
# Hack to force using python2
cd "$srcdir"
mkdir -p bin
ln -s /usr/bin/python2 bin/python
cd ${_pkgfqn}/qtwebengine/src/3rdparty
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
}
build() {
cd ${_pkgfqn}
export PATH="$srcdir/bin:$PATH"
PYTHON=/usr/bin/python2 ./configure -confirm-license -opensource \
-prefix /usr \
-docdir /usr/share/doc/qt \
-headerdir /usr/include/qt \
-archdatadir /usr/lib/qt \
-datadir /usr/share/qt \
-sysconfdir /etc/xdg \
-examplesdir /usr/share/doc/qt/examples
make docs
}
package() {
cd ${_pkgfqn}
make -j1 INSTALL_ROOT="$pkgdir" install_docs
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
# Fix conflicts with qt5-examples
rm -r "$pkgdir"/usr/share/doc/qt/examples
}