mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/android-tools to 29.0.4-2
This commit is contained in:
parent
c97dd165ee
commit
f5742f86fb
2 changed files with 22 additions and 6 deletions
|
@ -9,7 +9,7 @@ buildarch=28
|
|||
|
||||
pkgname=android-tools
|
||||
pkgver=29.0.4
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
tag=platform-tools-$pkgver
|
||||
pkgdesc='Android platform tools'
|
||||
arch=(x86_64)
|
||||
|
@ -32,6 +32,7 @@ source=(git+https://android.googlesource.com/platform/system/core#tag=$tag
|
|||
git+https://boringssl.googlesource.com/boringssl#commit=$_boringssl_commit
|
||||
generate_build.rb
|
||||
fix_build_core.patch
|
||||
fix_sparse_img.patch
|
||||
bash_completion.fastboot)
|
||||
# Bash completion file was taken from https://github.com/mbrubeck/android-completion
|
||||
sha1sums=('SKIP'
|
||||
|
@ -43,7 +44,8 @@ sha1sums=('SKIP'
|
|||
'SKIP'
|
||||
'SKIP'
|
||||
'afca7974ad8658e52fd028ead12ad0a959d63273'
|
||||
'6f3d6ca9112b0f2b3049febb46cf311ddc883567'
|
||||
'9d35e4e9c4d1064783f3b1edaae0a2fae49493a4'
|
||||
'2b57a4cf8012473c1a4fc6adae16573756272b02'
|
||||
'7004dbd0c193668827174880de6f8434de8ceaee')
|
||||
|
||||
prepare() {
|
||||
|
@ -51,6 +53,7 @@ prepare() {
|
|||
|
||||
cd "$srcdir"/core
|
||||
patch -p1 < ../fix_build_core.patch
|
||||
patch -p1 < ../fix_sparse_img.patch # FS#63370
|
||||
|
||||
cd "$srcdir"/avb
|
||||
sed -i 's|/usr/bin/env python$|/usr/bin/env python2|g' avbtool
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
diff --git a/adb/adb.cpp b/adb/adb.cpp
|
||||
index 24d4292d02..e4ad76b7c3 100644
|
||||
index 098ed38f30..d0b2e87e7c 100644
|
||||
--- a/adb/adb.cpp
|
||||
+++ b/adb/adb.cpp
|
||||
@@ -44,8 +44,6 @@
|
||||
|
@ -40,10 +40,10 @@ index 0c5c28f1b3..b6a1281521 100644
|
|||
usb_init();
|
||||
} else {
|
||||
diff --git a/adb/client/usb_libusb.cpp b/adb/client/usb_libusb.cpp
|
||||
index 53f01a0ce5..5be0d91085 100644
|
||||
index 53f01a0ce5..b4c3aadc28 100644
|
||||
--- a/adb/client/usb_libusb.cpp
|
||||
+++ b/adb/client/usb_libusb.cpp
|
||||
@@ -30,7 +31,7 @@
|
||||
@@ -30,7 +30,7 @@
|
||||
#include <thread>
|
||||
#include <unordered_map>
|
||||
|
||||
|
@ -53,7 +53,7 @@ index 53f01a0ce5..5be0d91085 100644
|
|||
#include <android-base/file.h>
|
||||
#include <android-base/logging.h>
|
||||
diff --git a/fastboot/fastboot.cpp b/fastboot/fastboot.cpp
|
||||
index 8923f409df..d245a577ff 100644
|
||||
index 8923f409df..5cadb9649b 100644
|
||||
--- a/fastboot/fastboot.cpp
|
||||
+++ b/fastboot/fastboot.cpp
|
||||
@@ -58,9 +58,7 @@
|
||||
|
@ -88,3 +88,16 @@ index 8c0aa6bf4e..3ad5b53568 100644
|
|||
std::vector<const char*> mke2fs_args = {mke2fs_path.c_str(), "-t", "ext4", "-b"};
|
||||
|
||||
std::string block_size_str = std::to_string(block_size);
|
||||
diff --git a/libcutils/include/cutils/threads.h b/libcutils/include/cutils/threads.h
|
||||
index ba4846e33b..f3fccc4895 100644
|
||||
--- a/libcutils/include/cutils/threads.h
|
||||
+++ b/libcutils/include/cutils/threads.h
|
||||
@@ -33,8 +33,6 @@ extern "C" {
|
||||
// Deprecated: use android::base::GetThreadId instead, which doesn't truncate on Mac/Windows.
|
||||
//
|
||||
|
||||
-extern pid_t gettid();
|
||||
-
|
||||
//
|
||||
// Deprecated: use `_Thread_local` in C or `thread_local` in C++.
|
||||
//
|
||||
|
|
Loading…
Reference in a new issue