extra/libreoffice-still to 6.0.6-4

This commit is contained in:
Kevin Mihelich 2018-10-30 00:15:47 +00:00
parent 7eb3eb0b16
commit f7dba67f19
3 changed files with 53 additions and 58 deletions

View file

@ -1,4 +1,3 @@
# $Id$
# Maintainer: AndyRTR <andyrtr@archlinux.org>
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
@ -21,7 +20,7 @@ pkgbase=libreoffice-still
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
_LOver=6.0.6.2
pkgver=6.0.6
pkgrel=3
pkgrel=4
arch=('x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -31,7 +30,7 @@ makedepends=('curl>=7.20.0' 'hunspell>=1.2.8' 'python>=3.7' 'libwpd>=0.9.2' 'lib
'lcms2' 'poppler>=0.24.0' 'libvisio' 'libetonyek' 'libodfgen' 'libcdr'
'libmspub' 'harfbuzz-icu' 'nss' 'hicolor-icon-theme'
'desktop-file-utils' 'shared-mime-info' 'gtk2' 'gst-plugins-base-libs'
'sane' 'perl-archive-zip' 'zip' 'unzip' 'unixodbc' 'apache-ant'
'sane' 'perl-archive-zip' 'zip' 'unzip' 'unixodbc' 'ant'
'gperf' 'gtk3' 'cppunit' 'beanshell' 'clucene'
'junit' 'libmythes' 'libwpg' 'java-environment' 'postgresql-libs' 'libgl'
'bluez-libs' 'gdb' 'doxygen' 'libatomic_ops' 'mdds'
@ -63,6 +62,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
${_additional_source_url2}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies+ODFTOOLKIT-460+ODFTOOLKIT-475.jar # for test suite
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
make-pyuno-work-with-system-wide-module-install.diff
poppler-0.70.patch
emfio.patch
libreoffice-still.sh libreoffice-still.csh)
noextract=(boost_1_65_1.tar.bz2
@ -102,6 +102,7 @@ sha256sums=('f1666430abf616a3813e4c886b51f157366f592102ae0e874abc17f3d58c6a8e'
'702413413a5d8076c17fe79c0808dfba145a7260020f6c8627ea529a0cf83769'
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
'4cac21ffdb711803c0d5372c6b0ba04f1310afa7907081fdd01c11e68c1785bf'
'8b4815788be087940750b775690b5890c4cf9e121f11006a72ccab834f212abb'
'52e90a5a3d8d5b626caa51675b601aba508463c2b9caa98d07cfa35220fc0b22'
'531de4133cb6ff5c841e4251fdafe69521ccd195f5933eb8c113291d3eff183a')
@ -139,6 +140,9 @@ prepare() {
# fix not upstreamable pyuno paths - FS#54250
patch -Np1 -i ${srcdir}/make-pyuno-work-with-system-wide-module-install.diff
# fix build with poppler 0.70
patch -Np1 -i ../poppler-0.70.patch
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do
case "$i" in
@ -222,7 +226,7 @@ build() {
--with-system-libstaroffice \
--with-system-serf \
--with-jdk-home="/usr/lib/jvm/default" \
--with-ant-home="/usr/share/apache-ant"\
--with-ant-home="/usr/share/ant"\
--without-system-boost\
--with-system-icu \
--with-system-cairo \

View file

@ -0,0 +1,45 @@
From 557ee0a0f4e40b934c72515f41f3a605803ddb1d Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <evangelos@foutrelis.com>
Date: Wed, 24 Oct 2018 17:48:53 +0300
Subject: [PATCH] fix build with poppler 0.70
---
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 4 ++++
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
2 files changed, 8 insertions(+)
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
index 575a90acb..99219f7e6 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
@@ -578,7 +578,11 @@ void PDFOutDev::restoreState(GfxState*)
printf( "restoreState\n" );
}
+#if POPPLER_CHECK_VERSION(0, 70, 0)
+void PDFOutDev::setDefaultCTM(const double *pMat)
+#else
void PDFOutDev::setDefaultCTM(double *pMat)
+#endif
{
assert(pMat);
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
index da021a2a0..27440f2bb 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
@@ -166,7 +166,11 @@ namespace pdfi
//----- initialization and control
// Set default transform matrix.
+#if POPPLER_CHECK_VERSION(0, 70, 0)
+ virtual void setDefaultCTM(const double *ctm) override;
+#else
virtual void setDefaultCTM(double *ctm) override;
+#endif
// Start a page.
virtual void startPage(int pageNum, GfxState *state
--
2.19.1

View file

@ -1,54 +0,0 @@
From 76a29148be63cb006a7e25e312dc93acc93e071f Mon Sep 17 00:00:00 2001
From: Stephan Bergmann <sbergman@redhat.com>
Date: Tue, 3 Jul 2018 08:33:34 +0200
Subject: [PATCH] const fixes for python3-devel-3.7.0-1.fc29.x86_64
Change-Id: Ia16a8b828e11ce36e9bb77ecf9e8a1179bd9b90c
Reviewed-on: https://gerrit.libreoffice.org/56841
Tested-by: Jenkins
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
---
pyuno/source/module/pyuno_impl.hxx | 2 +-
pyuno/source/module/pyuno_type.cxx | 2 +-
pyuno/source/module/pyuno_util.cxx | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/pyuno/source/module/pyuno_impl.hxx b/pyuno/source/module/pyuno_impl.hxx
index ea0e419ffb1b..73acabdf4a16 100644
--- a/pyuno/source/module/pyuno_impl.hxx
+++ b/pyuno/source/module/pyuno_impl.hxx
@@ -80,7 +80,7 @@ inline PyObject* PyStr_FromString(const char *string)
return PyUnicode_FromString(string);
}
-inline char * PyStr_AsString(PyObject *object)
+inline char const * PyStr_AsString(PyObject *object)
{
return PyUnicode_AsUTF8(object);
}
diff --git a/pyuno/source/module/pyuno_type.cxx b/pyuno/source/module/pyuno_type.cxx
index c6fc1351436b..80505d85bbd1 100644
--- a/pyuno/source/module/pyuno_type.cxx
+++ b/pyuno/source/module/pyuno_type.cxx
@@ -157,7 +157,7 @@ Any PyEnum2Enum( PyObject *obj )
}
OUString strTypeName( OUString::createFromAscii( PyStr_AsString( typeName.get() ) ) );
- char *stringValue = PyStr_AsString( value.get() );
+ char const *stringValue = PyStr_AsString( value.get() );
TypeDescription desc( strTypeName );
if( !desc.is() )
diff --git a/pyuno/source/module/pyuno_util.cxx b/pyuno/source/module/pyuno_util.cxx
index 45ee5a38e40b..f9714fb270f0 100644
--- a/pyuno/source/module/pyuno_util.cxx
+++ b/pyuno/source/module/pyuno_util.cxx
@@ -69,7 +69,7 @@ OUString pyString2ustring( PyObject *pystr )
#else
#if PY_MAJOR_VERSION >= 3
Py_ssize_t size(0);
- char *pUtf8(PyUnicode_AsUTF8AndSize(pystr, &size));
+ char const *pUtf8(PyUnicode_AsUTF8AndSize(pystr, &size));
ret = OUString(pUtf8, size, RTL_TEXTENCODING_UTF8);
#else
PyObject* pUtf8 = PyUnicode_AsUTF8String(pystr);