linux-hikey: kernel-CVE-2016-0728.patch

This commit is contained in:
Jason Plum 2016-01-20 13:42:34 -05:00
parent 223da03f57
commit fb75e16c5c
2 changed files with 87 additions and 1 deletions

View file

@ -9,7 +9,7 @@ _srcname=linux-${_commit}
_kernelname=${pkgbase#linux}
_desc="HiKey Development Board"
pkgver=3.18.0
pkgrel=1
pkgrel=2
arch=('aarch64')
url="https://github.com/96boards/linux"
license=('GPL2')
@ -17,11 +17,13 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools')
options=('!strip')
source=("https://github.com/96boards/linux/archive/${_commit}.tar.gz"
'https://github.com/96boards/linux/commit/fedb1bdd784c3990ad916452db38f778e96cdcf9.patch'
'kernel-CVE-2016-0728.patch'
'linux.preset'
'cmdline'
'config')
md5sums=('31b83dbd3f1c38bbfe76078def29fa1f'
'de4caa8870c6e163c33c66e490d3c16b'
'6470e9783bd1c7a8feddc2d67f07afd5'
'20022bddda62a9bf97424c1127433093'
'b28f62703034bb99d8ae83724acb851d'
'8d1b4e2db2e6d877cfcda448e65eb996')
@ -32,6 +34,9 @@ prepare() {
# Revert usb: dwc2: platform: downgrade to full speed
git apply -R ../fedb1bdd784c3990ad916452db38f778e96cdcf9.patch
# Apply CVE-2016-0728
git apply ../kernel-CVE-2016-0728.patch
cat "${srcdir}/config" > ./.config
# add pkgrel to extraversion

View file

@ -0,0 +1,81 @@
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
From: Yevgeny Pats <yevgeny@perception-point.io>
Date: Tue, 19 Jan 2016 22:09:04 +0000
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
This fixes CVE-2016-0728.
If a thread is asked to join as a session keyring the keyring that's already
set as its session, we leak a keyring reference.
This can be tested with the following program:
#include <stddef.h>
#include <stdio.h>
#include <sys/types.h>
#include <keyutils.h>
int main(int argc, const char *argv[])
{
int i = 0;
key_serial_t serial;
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
if (keyctl(KEYCTL_SETPERM, serial,
KEY_POS_ALL | KEY_USR_ALL) < 0) {
perror("keyctl");
return -1;
}
for (i = 0; i < 100; i++) {
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
}
return 0;
}
If, after the program has run, there something like the following line in
/proc/keys:
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
with a usage count of 100 * the number of times the program has been run,
then the kernel is malfunctioning. If leaked-keyring has zero usages or
has been garbage collected, then the problem is fixed.
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
Signed-off-by: David Howells <dhowells@redhat.com>
Acked-by: Don Zickus <dzickus@redhat.com>
Acked-by: Prarit Bhargava <prarit@redhat.com>
Acked-by: Jarod Wilson <jarod@redhat.com>
Signed-off-by: James Morris <james.l.morris@oracle.com>
---
security/keys/process_keys.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
index a3f85d2..e6d50172 100644
--- a/security/keys/process_keys.c
+++ b/security/keys/process_keys.c
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
ret = PTR_ERR(keyring);
goto error2;
} else if (keyring == new->session_keyring) {
+ key_put(keyring);
ret = 0;
goto error2;
}
--
cgit v0.12