extra/kwin: fix patch

This commit is contained in:
Kevin Mihelich 2015-05-04 00:03:21 +00:00
parent e62131890a
commit fca70b9184
2 changed files with 19 additions and 25 deletions

View file

@ -26,7 +26,7 @@ source=("http://download.kde.org/stable/plasma/${pkgver}/${pkgname}-${pkgver}.ta
"kwin_remove_eglonxbackend.patch")
md5sums=('4cce33510b72d1f4321e529fd00bf7d4'
'65af20bd49436056c93932ad7f80f7dd'
'176fedf90b0056de0934ea926095de89')
'7bfedcb642b0d6b517cc9e639c9b9c16')
prepare() {
mkdir build

View file

@ -1,38 +1,32 @@
diff -urN a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2015-02-21 13:23:27.000000000 -0700
+++ b/CMakeLists.txt 2015-03-01 16:00:41.823988772 -0700
@@ -393,10 +393,6 @@
)
--- a/CMakeLists.txt 2015-04-23 04:08:00.000000000 -0600
+++ b/CMakeLists.txt 2015-05-03 17:59:09.416829142 -0600
@@ -414,7 +414,7 @@
endif()
if(KWIN_HAVE_EGL)
- set(kwin_KDEINIT_SRCS ${kwin_KDEINIT_SRCS} abstract_egl_backend.cpp eglonxbackend.cpp)
+ set(kwin_KDEINIT_SRCS ${kwin_KDEINIT_SRCS} abstract_egl_backend.cpp)
endif()
-if(KWIN_HAVE_EGL)
- set(kwin_KDEINIT_SRCS ${kwin_KDEINIT_SRCS} eglonxbackend.cpp)
-endif()
-
if(HAVE_WAYLAND)
set(kwin_KDEINIT_SRCS
${kwin_KDEINIT_SRCS}
diff -urN a/scene_opengl.cpp b/scene_opengl.cpp
--- a/scene_opengl.cpp 2015-02-21 13:21:17.000000000 -0700
+++ b/scene_opengl.cpp 2015-03-01 16:00:41.838988770 -0700
--- a/scene_opengl.cpp 2015-04-23 04:06:05.000000000 -0600
+++ b/scene_opengl.cpp 2015-05-03 17:59:40.756785872 -0600
@@ -28,7 +28,6 @@
*********************************************************************/
#include "scene_opengl.h"
#ifdef KWIN_HAVE_EGL
-#include "eglonxbackend.h"
// for Wayland
#if HAVE_WAYLAND_EGL
#include "egl_wayland_backend.h"
@@ -488,10 +487,10 @@
if (kwinApp()->shouldUseWaylandForCompositing()) {
backend = new EglWaylandBackend();
} else {
#endif // KWIN_HAVE_EGL
#ifndef KWIN_HAVE_OPENGLES
#include "glxbackend.h"
@@ -501,7 +500,7 @@
} else
#endif // HAVE_WAYLAND
{
- backend = new EglOnXBackend();
+ backend = NULL;
}
#else
- backend = new EglOnXBackend();
+ backend = NULL;
#endif
#endif
#endif // KWIN_HAVE_EGL
break;