mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
158 lines
3.5 KiB
Diff
158 lines
3.5 KiB
Diff
diff -urN a/arch/arm/boot/dts/armada-370-smileplug.dts b/arch/arm/boot/dts/armada-370-smileplug.dts
|
|
--- a/arch/arm/boot/dts/armada-370-smileplug.dts 1969-12-31 17:00:00.000000000 -0700
|
|
+++ b/arch/arm/boot/dts/armada-370-smileplug.dts 2013-08-01 09:41:26.157246690 -0600
|
|
@@ -0,0 +1,143 @@
|
|
+/*
|
|
+ * Device Tree file for Marvell SMILE Plug
|
|
+ *
|
|
+ * Kevin Mihelich <kevin@archlinuxarm.org>
|
|
+ * Gregory CLEMENT <gregory.clement@free-electrons.com>
|
|
+ *
|
|
+ * This file is licensed under the terms of the GNU General Public
|
|
+ * License version 2. This program is licensed "as is" without any
|
|
+ * warranty of any kind, whether express or implied.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+/include/ "armada-370.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Marvell SMILE Plug";
|
|
+ compatible = "marvell,smileplug", "marvell,armada370", "marvell,armada-370-xp";
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ device_type = "memory";
|
|
+ reg = <0x00000000 0x20000000>; /* 512 MB */
|
|
+ };
|
|
+
|
|
+ soc {
|
|
+ internal-regs {
|
|
+ serial@12000 {
|
|
+ clock-frequency = <200000000>;
|
|
+ status = "okay";
|
|
+ };
|
|
+ timer@20300 {
|
|
+ clock-frequency = <600000000>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ pinctrl {
|
|
+ smile_led_pins: smile-led-pins {
|
|
+ marvell,pins = "mpp63", "mpp64", "mpp47", "mpp59";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ gpio_leds {
|
|
+ compatible = "gpio-leds";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&smile_led_pins>;
|
|
+
|
|
+ red_eyes_led {
|
|
+ label = "smileplug:red:eyes";
|
|
+ gpios = <&gpio1 31 0>;
|
|
+ default-state = "off";
|
|
+ };
|
|
+
|
|
+ green_eyes_led {
|
|
+ label = "smileplug:green:eyes";
|
|
+ gpios = <&gpio2 0 0>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ red_smile_led {
|
|
+ label = "smileplug:red:smile";
|
|
+ gpios = <&gpio1 15 0>;
|
|
+ default-state = "off";
|
|
+ };
|
|
+
|
|
+ green_smile_led {
|
|
+ label = "smileplug:green:smile";
|
|
+ gpios = <&gpio1 27 0>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ mdio {
|
|
+ phy0: ethernet-phy@0 {
|
|
+ reg = <0>;
|
|
+ };
|
|
+
|
|
+ phy1: ethernet-phy@1 {
|
|
+ reg = <1>;
|
|
+ };
|
|
+ };
|
|
+ ethernet@70000 {
|
|
+ status = "okay";
|
|
+ phy = <&phy0>;
|
|
+ phy-mode = "rgmii-id";
|
|
+ };
|
|
+ ethernet@74000 {
|
|
+ status = "okay";
|
|
+ phy = <&phy1>;
|
|
+ phy-mode = "rgmii-id";
|
|
+ };
|
|
+
|
|
+ mvsdio@d4000 {
|
|
+ pinctrl-0 = <&sdio_pins3>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+ /*
|
|
+ * No CD or WP GPIOs: SDIO interface used for
|
|
+ * Wifi/Bluetooth chip
|
|
+ */
|
|
+ broken-cd;
|
|
+ };
|
|
+
|
|
+ usb@50000 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ usb@51000 {
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ i2c@11000 {
|
|
+ status = "okay";
|
|
+ clock-frequency = <100000>;
|
|
+ pca9505: pca9505@25 {
|
|
+ compatible = "nxp,pca9505";
|
|
+ gpio-controller;
|
|
+ #gpio-cells = <2>;
|
|
+ reg = <0x25>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ pcie-controller {
|
|
+ status = "okay";
|
|
+
|
|
+ /* Internal mini-PCIe connector */
|
|
+ pcie@1,0 {
|
|
+ /* Port 0, Lane 0 */
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ /* Connected on the PCB to a USB 3.0 XHCI controller */
|
|
+ pcie@2,0 {
|
|
+ /* Port 1, Lane 0 */
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
diff -urN a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
--- a/arch/arm/boot/dts/Makefile 2013-07-28 21:53:33.000000000 -0600
|
|
+++ b/arch/arm/boot/dts/Makefile 2013-08-01 09:42:47.346872657 -0600
|
|
@@ -100,6 +100,7 @@
|
|
msm8960-cdp.dtb
|
|
dtb-$(CONFIG_ARCH_MVEBU) += armada-370-db.dtb \
|
|
armada-370-mirabox.dtb \
|
|
+ armada-370-smileplug.dtb \
|
|
armada-370-rd.dtb \
|
|
armada-xp-db.dtb \
|
|
armada-xp-gp.dtb \
|