mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
42 lines
1.5 KiB
Diff
42 lines
1.5 KiB
Diff
From: Serge Hallyn <serge.hallyn@ubuntu.com>
|
|
Date: Tue, 11 Mar 2014 04:17:07 +0000 (-0500)
|
|
Subject: misc/sys/xattr.h: guard against linux uapi header inclusion
|
|
X-Git-Url: https://sourceware.org/git/?p=glibc.git;a=commitdiff_plain;h=fdbe8eae;hp=fede7a5ffa188c22c3789135bd5cf82e487dd3d0
|
|
|
|
misc/sys/xattr.h: guard against linux uapi header inclusion
|
|
|
|
If the glibc xattr.h header is included after the uapi header,
|
|
compilation fails due to an enum re-using a #define from the
|
|
uapi header. Protect against this by guarding the define and
|
|
enum inclusions against each other.
|
|
|
|
(A corresponding kernel patch has been sent here:
|
|
http://lkml.org/lkml/2014/3/7/331 )
|
|
|
|
(See https://lists.debian.org/debian-glibc/2014/03/msg00029.html
|
|
and https://sourceware.org/glibc/wiki/Synchronizing_Headers
|
|
for more information.)
|
|
|
|
Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
|
|
---
|
|
|
|
diff --git a/misc/sys/xattr.h b/misc/sys/xattr.h
|
|
index 929cd87..796df90 100644
|
|
--- a/misc/sys/xattr.h
|
|
+++ b/misc/sys/xattr.h
|
|
@@ -26,6 +26,7 @@ __BEGIN_DECLS
|
|
|
|
/* The following constants should be used for the fifth parameter of
|
|
`*setxattr'. */
|
|
+#ifndef __USE_KERNEL_XATTR_DEFS
|
|
enum
|
|
{
|
|
XATTR_CREATE = 1, /* set value, fail if attr already exists. */
|
|
@@ -33,6 +34,7 @@ enum
|
|
XATTR_REPLACE = 2 /* set value, fail if attr does not exist. */
|
|
#define XATTR_REPLACE XATTR_REPLACE
|
|
};
|
|
+#endif
|
|
|
|
/* Set the attribute NAME of the file pointed to by PATH to VALUE (which
|
|
is SIZE bytes long). Return 0 on success, -1 for errors. */
|