mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
11 lines
634 B
Diff
11 lines
634 B
Diff
--- qtbase-everywhere-src-5.10.0-beta4/src/corelib/io/qfilesystemengine_unix.cpp.orig 2017-11-14 12:10:28.156094557 +0000
|
|
+++ qtbase-everywhere-src-5.10.0-beta4/src/corelib/io/qfilesystemengine_unix.cpp 2017-11-14 12:10:46.156136206 +0000
|
|
@@ -95,7 +95,7 @@
|
|
{ return syscall(SYS_renameat2, oldfd, oldpath, newfd, newpath, flags); }
|
|
# endif
|
|
|
|
-# if !QT_CONFIG(statx) && defined(SYS_statx) && QT_HAS_INCLUDE(<linux/stat.h>)
|
|
+# if 0
|
|
# include <linux/stat.h>
|
|
static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
|
|
{ return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
|