mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
39 lines
1.5 KiB
Diff
39 lines
1.5 KiB
Diff
From e1387e57b57b39a22d626d6f6f8ae5e6fa1a4567 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Fri, 8 Sep 2017 11:53:48 +0200
|
|
Subject: [PATCH 12/12] PCI: aardvark: define IRQ related hooks in
|
|
pci_host_bridge
|
|
|
|
Commit 769b461fc0c0 ("arm64: PCI: Drop DT IRQ allocation from
|
|
pcibios_alloc_irq()") was assuming all PCI host controller drivers had
|
|
been converted to use ->map_irq(), but that wasn't the case:
|
|
pci-aardvark had not been converted. Due to this, it broke the support
|
|
for legacy PCI interrupts when using the pci-aardvark driver (used on
|
|
Marvell Armada 3720 platforms).
|
|
|
|
In order to fix this, we make sure the ->map_irq and ->swizzle_irq
|
|
fields of pci_host_bridge are properly filled in.
|
|
|
|
Fixes: 769b461fc0c0 ("arm64: PCI: Drop DT IRQ allocation from pcibios_alloc_irq()")
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Cc: <stable@vger.kernel.org> # v4.13+
|
|
---
|
|
drivers/pci/host/pci-aardvark.c | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/drivers/pci/host/pci-aardvark.c b/drivers/pci/host/pci-aardvark.c
|
|
index 6d6a2ae35481..f682650bf037 100644
|
|
--- a/drivers/pci/host/pci-aardvark.c
|
|
+++ b/drivers/pci/host/pci-aardvark.c
|
|
@@ -999,6 +999,8 @@ static int advk_pcie_probe(struct platform_device *pdev)
|
|
bridge->sysdata = pcie;
|
|
bridge->busnr = 0;
|
|
bridge->ops = &advk_pcie_ops;
|
|
+ bridge->map_irq = of_irq_parse_and_map_pci;
|
|
+ bridge->swizzle_irq = pci_common_swizzle;
|
|
|
|
ret = pci_scan_root_bus_bridge(bridge);
|
|
if (ret < 0) {
|
|
--
|
|
2.14.1
|
|
|