mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
From 7c075bae56e45f268e62efcd82589111bce92ae3 Mon Sep 17 00:00:00 2001
|
|
From: Dave Airlie <airlied@redhat.com>
|
|
Date: Mon, 7 Dec 2020 09:47:35 +1000
|
|
Subject: [PATCH] radeonsi: fix regression on gpus using the radeon winsys.
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
For GPUs using the radeon kernel driver, num_se was never
|
|
getting initialised.
|
|
|
|
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/3939
|
|
Fixes: f2977a162af4 ("ac: fix min/max_good_num_cu_per_sa on gfx10.3 with disabled SEs")
|
|
Reviewed-by: Marek Olšák <marek.olsak@amd.com>
|
|
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/7954>
|
|
---
|
|
src/gallium/winsys/radeon/drm/radeon_drm_winsys.c | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/src/gallium/winsys/radeon/drm/radeon_drm_winsys.c b/src/gallium/winsys/radeon/drm/radeon_drm_winsys.c
|
|
index 0aab59cd236..ef7434d7589 100644
|
|
--- a/src/gallium/winsys/radeon/drm/radeon_drm_winsys.c
|
|
+++ b/src/gallium/winsys/radeon/drm/radeon_drm_winsys.c
|
|
@@ -530,6 +530,8 @@ static bool do_winsys_init(struct radeon_drm_winsys *ws)
|
|
}
|
|
}
|
|
|
|
+ ws->info.num_se = ws->info.max_se;
|
|
+
|
|
radeon_get_drm_value(ws->fd, RADEON_INFO_MAX_SH_PER_SE, NULL,
|
|
&ws->info.max_sa_per_se);
|
|
if (ws->gen == DRV_SI) {
|
|
--
|
|
GitLab
|
|
|