mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
45 lines
1.3 KiB
Diff
45 lines
1.3 KiB
Diff
From 2c1bea4109c351862aa1ebb425adababd630454c Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Fri, 19 Feb 2016 21:40:56 -0700
|
|
Subject: [PATCH] arch linux arm modifications
|
|
|
|
---
|
|
configs/rpi_2_defconfig | 1 +
|
|
configs/rpi_3_defconfig | 1 +
|
|
include/configs/rpi.h | 2 +-
|
|
3 files changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configs/rpi_2_defconfig b/configs/rpi_2_defconfig
|
|
index bddee43..1f6fb91 100644
|
|
--- a/configs/rpi_2_defconfig
|
|
+++ b/configs/rpi_2_defconfig
|
|
@@ -27,3 +27,4 @@ CONFIG_USB_KEYBOARD=y
|
|
CONFIG_LCD=y
|
|
CONFIG_PHYS_TO_BUS=y
|
|
CONFIG_OF_LIBFDT=y
|
|
+CONFIG_IDENT_STRING=" Arch Linux ARM"
|
|
diff --git a/configs/rpi_3_defconfig b/configs/rpi_3_defconfig
|
|
index 9b6a72f..a0118f7 100644
|
|
--- a/configs/rpi_3_defconfig
|
|
+++ b/configs/rpi_3_defconfig
|
|
@@ -28,3 +28,4 @@ CONFIG_USB_KEYBOARD=y
|
|
CONFIG_LCD=y
|
|
CONFIG_PHYS_TO_BUS=y
|
|
CONFIG_OF_LIBFDT=y
|
|
+CONFIG_IDENT_STRING=" Arch Linux ARM"
|
|
diff --git a/include/configs/rpi.h b/include/configs/rpi.h
|
|
index 45c8234..12d6473 100644
|
|
--- a/include/configs/rpi.h
|
|
+++ b/include/configs/rpi.h
|
|
@@ -187,7 +187,7 @@
|
|
"pxefile_addr_r=0x00100000\0" \
|
|
"kernel_addr_r=0x01000000\0" \
|
|
"scriptaddr=0x02000000\0" \
|
|
- "ramdisk_addr_r=0x02100000\0" \
|
|
+ "ramdisk_addr_r=0x03000000\0" \
|
|
|
|
#define BOOT_TARGET_DEVICES(func) \
|
|
func(MMC, mmc, 0) \
|
|
--
|
|
2.10.2
|
|
|