mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-29 00:25:25 +00:00
13 lines
411 B
Diff
13 lines
411 B
Diff
--- a/Source/ThirdParty/ANGLE/src/compiler/SymbolTable.cpp
|
|
+++ b/Source/ThirdParty/ANGLE/src/compiler/SymbolTable.cpp
|
|
@@ -171,7 +171,8 @@ TFunction::~TFunction()
|
|
TSymbolTableLevel::~TSymbolTableLevel()
|
|
{
|
|
for (tLevel::iterator it = level.begin(); it != level.end(); ++it)
|
|
- delete (*it).second;
|
|
+ if ((*it).first == (*it).second->getMangledName())
|
|
+ delete (*it).second;
|
|
}
|
|
|
|
//
|
|
|