mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
48 lines
2 KiB
Diff
48 lines
2 KiB
Diff
From 592837abc8b07f9b28898fa91c31658e2beecfc4 Mon Sep 17 00:00:00 2001
|
|
From: Ronny Berndt <ronny@apache.org>
|
|
Date: Sat, 11 Jun 2022 14:18:54 +0200
|
|
Subject: [PATCH] Add Erlang 25 support
|
|
|
|
Before merging this PR, PR #16 in couchdb-snappy needs to get merged and tagged with CouchDB-1.0.8
|
|
---
|
|
rebar.config.script | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/rebar.config.script b/rebar.config.script
|
|
index 31855098b3..44c4d61b1a 100644
|
|
--- a/rebar.config.script
|
|
+++ b/rebar.config.script
|
|
@@ -192,7 +192,7 @@ MakeDep = fun
|
|
end.
|
|
|
|
AddConfig = [
|
|
- {require_otp_vsn, "20|21|22|23|24"},
|
|
+ {require_otp_vsn, "20|21|22|23|24|25|26"},
|
|
{deps_dir, "src"},
|
|
{deps, lists:map(MakeDep, DepDescs ++ OptionalDeps)},
|
|
{sub_dirs, SubDirs},
|
|
|
|
From 6da9405ff97acae745ae85f3f9ce92484a7722df Mon Sep 17 00:00:00 2001
|
|
From: Nick Vatamaniuc <vatamane@gmail.com>
|
|
Date: Fri, 17 Jun 2022 16:47:12 -0400
|
|
Subject: [PATCH] Erlang 25 compatibility - http_uri:parse -> uri_string:parse
|
|
|
|
This fixes the replicator eunit failure:
|
|
https://github.com/apache/couchdb/pull/4060#issuecomment-1154391783
|
|
---
|
|
.../test/eunit/couch_replicator_error_reporting_tests.erl | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/couch_replicator/test/eunit/couch_replicator_error_reporting_tests.erl b/src/couch_replicator/test/eunit/couch_replicator_error_reporting_tests.erl
|
|
index 7778bd77de..b0863614c3 100644
|
|
--- a/src/couch_replicator/test/eunit/couch_replicator_error_reporting_tests.erl
|
|
+++ b/src/couch_replicator/test/eunit/couch_replicator_error_reporting_tests.erl
|
|
@@ -165,7 +165,7 @@ mock_fail_req(Path, Return) ->
|
|
send_req_direct,
|
|
fun(W, Url, Headers, Meth, Body, Opts, TOut) ->
|
|
Args = [W, Url, Headers, Meth, Body, Opts, TOut],
|
|
- {ok, {_, _, _, _, UPath, _}} = http_uri:parse(Url),
|
|
+ #{path := UPath} = uri_string:parse(Url),
|
|
case lists:suffix(Path, UPath) of
|
|
true -> Return;
|
|
false -> meck:passthrough(Args)
|