mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
diff --git a/gcc/d/d-incpath.cc b/gcc/d/d-incpath.cc
|
|
index 995ff792..3e06bc0a 100644
|
|
--- a/gcc/d/d-incpath.cc
|
|
+++ b/gcc/d/d-incpath.cc
|
|
@@ -206,7 +206,7 @@ add_import_paths(const char *iprefix, const char *imultilib, bool stdinc)
|
|
import_path = xstrdup(p->fname);
|
|
|
|
// Add D-specific suffix.
|
|
- import_path = concat(import_path, "/d", NULL);
|
|
+ import_path = concat(import_path, "/dlang/gdc", NULL);
|
|
|
|
// Ignore duplicate entries.
|
|
bool found = false;
|
|
diff --git a/libphobos/configure b/libphobos/configure
|
|
index 7325fcbf..a75286c8 100755
|
|
--- a/libphobos/configure
|
|
+++ b/libphobos/configure
|
|
@@ -14658,7 +14658,7 @@ fi
|
|
|
|
|
|
# Default case for install directory for D sources files.
|
|
- gdc_include_dir='${libdir}/gcc/${target_alias}'/${d_gcc_ver}/include/d
|
|
+ gdc_include_dir='/usr/include/dlang/gdc/'
|
|
|
|
|
|
|
|
diff --git a/libphobos/m4/druntime.m4 b/libphobos/m4/druntime.m4
|
|
index fac44aac..6ff6b2c7 100644
|
|
--- a/libphobos/m4/druntime.m4
|
|
+++ b/libphobos/m4/druntime.m4
|
|
@@ -78,7 +78,7 @@ AC_DEFUN([DRUNTIME_INSTALL_DIRECTORIES],
|
|
AC_SUBST(toolexeclibdir)
|
|
|
|
# Default case for install directory for D sources files.
|
|
- gdc_include_dir='${libdir}/gcc/${target_alias}'/${d_gcc_ver}/include/d
|
|
+ gdc_include_dir='/usr/include/dlang/gdc/'
|
|
AC_SUBST(gdc_include_dir)
|
|
])
|
|
|