mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
36 lines
1,016 B
Diff
36 lines
1,016 B
Diff
From dc0ed09cc89a281605aaf22b714cc5d780160dbb Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Thu, 14 Jun 2018 11:59:02 -0600
|
|
Subject: [PATCH] Initialize XRandR before EnterVT
|
|
|
|
---
|
|
src/armsoc_driver.c | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/src/armsoc_driver.c b/src/armsoc_driver.c
|
|
index 83e74a7..a52646c 100644
|
|
--- a/src/armsoc_driver.c
|
|
+++ b/src/armsoc_driver.c
|
|
@@ -1130,6 +1130,9 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
|
|
*/
|
|
pScrn->vtSema = TRUE;
|
|
|
|
+ /* Do some XRandR initialization. Return value is not useful */
|
|
+ (void)xf86CrtcScreenInit(pScreen);
|
|
+
|
|
/* Take over the virtual terminal from the console, set the
|
|
* desired mode, etc.:
|
|
*/
|
|
@@ -1138,9 +1141,6 @@ ARMSOCScreenInit(SCREEN_INIT_ARGS_DECL)
|
|
goto fail6;
|
|
}
|
|
|
|
- /* Do some XRandR initialization. Return value is not useful */
|
|
- (void)xf86CrtcScreenInit(pScreen);
|
|
-
|
|
if (!miCreateDefColormap(pScreen)) {
|
|
ERROR_MSG("Cannot create colormap!");
|
|
goto fail7;
|
|
--
|
|
2.17.1
|
|
|