PKGBUILDs/community/docker/docker-arm.patch
2014-01-03 19:20:06 -05:00

14 lines
592 B
Diff

diff --git a/engine/engine.go b/engine/engine.go
index 5da0a97..f468a59 100644
--- a/engine/engine.go
+++ b/engine/engine.go
@@ -60,7 +60,7 @@ func (eng *Engine) Register(name string, handler Handler) error {
// behavior.
func New(root string) (*Engine, error) {
// Check for unsupported architectures
- if runtime.GOARCH != "amd64" {
+ if runtime.GOARCH != "amd64" && runtime.GOARCH != "arm" {
return nil, fmt.Errorf("The docker runtime currently only supports amd64 (not %s). This will change in the future. Aborting.", runtime.GOARCH)
}
// Check for unsupported kernel versions