PKGBUILDs/core/linux-odroid-c1/0003-AUFS-fix-for-3.10.76.patch
2015-05-31 16:36:59 +00:00

40 lines
1.2 KiB
Diff

From 76c66bc752ac11dd7058c4c1d45902e094ad0545 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 30 Apr 2015 20:15:13 -0600
Subject: [PATCH 3/3] AUFS fix for 3.10.76
---
fs/aufs/debug.c | 2 +-
fs/aufs/hnotify.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/fs/aufs/debug.c b/fs/aufs/debug.c
index a26b5bd..7cedc88 100644
--- a/fs/aufs/debug.c
+++ b/fs/aufs/debug.c
@@ -156,7 +156,7 @@ void au_dpri_dalias(struct inode *inode)
struct dentry *d;
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias)
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias)
au_dpri_dentry(d);
spin_unlock(&inode->i_lock);
}
diff --git a/fs/aufs/hnotify.c b/fs/aufs/hnotify.c
index 1bd7a9a..927beb6 100644
--- a/fs/aufs/hnotify.c
+++ b/fs/aufs/hnotify.c
@@ -198,7 +198,7 @@ static int hn_gen_by_inode(char *name, unsigned int nlen, struct inode *inode,
AuDebugOn(!name);
au_iigen_dec(inode);
spin_lock(&inode->i_lock);
- hlist_for_each_entry(d, &inode->i_dentry, d_alias) {
+ hlist_for_each_entry(d, &inode->i_dentry, d_u.d_alias) {
spin_lock(&d->d_lock);
dname = &d->d_name;
if (dname->len != nlen
--
2.4.1