mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
30 lines
1.2 KiB
Diff
30 lines
1.2 KiB
Diff
From c5f42fa1207dc6df476b55a9cdda439d8cfcba05 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Johannes=20L=C3=B6thberg?= <johannes@kyriasis.com>
|
|
Date: Thu, 14 Mar 2019 20:35:52 +0100
|
|
Subject: [PATCH] Revert 1c95f5a34c14f08d65cdd198827e3a2fcb63cf39 +
|
|
9452a8dfa3ba3575d5cf090a4e2305ee106d259e
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
|
|
---
|
|
src/librustc_codegen_llvm/debuginfo/metadata.rs | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/librustc_codegen_llvm/debuginfo/metadata.rs b/src/librustc_codegen_llvm/debuginfo/metadata.rs
|
|
index 9f63038c36..553b952b56 100644
|
|
--- a/src/librustc_codegen_llvm/debuginfo/metadata.rs
|
|
+++ b/src/librustc_codegen_llvm/debuginfo/metadata.rs
|
|
@@ -1167,7 +1167,7 @@ fn use_enum_fallback(cx: &CodegenCx) -> bool {
|
|
// LLVM version 7 did not release with an important bug fix;
|
|
// but the required patch is in the LLVM 8. Rust LLVM reports
|
|
// 8 as well.
|
|
- || llvm_util::get_major_version() < 8;
|
|
+ || llvm_util::get_major_version() < 7;
|
|
}
|
|
|
|
// Describes the members of an enum value: An enum is described as a union of
|
|
--
|
|
2.20.1
|
|
|