mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
44 lines
1.2 KiB
Diff
44 lines
1.2 KiB
Diff
From 79e1cf43cb41de41944272ea46e077b6315ce8c0 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Wed, 3 Feb 2016 21:23:59 -0700
|
|
Subject: [PATCH 2/2] arch linux arm modifications
|
|
|
|
---
|
|
common/cmd_cfgload.c | 2 +-
|
|
include/configs/odroidc2.h | 7 +++++++
|
|
2 files changed, 8 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/common/cmd_cfgload.c b/common/cmd_cfgload.c
|
|
index 90e2541..7166d26 100644
|
|
--- a/common/cmd_cfgload.c
|
|
+++ b/common/cmd_cfgload.c
|
|
@@ -52,7 +52,7 @@ static char* read_cfgload(void)
|
|
|
|
setenv("filesize", "0");
|
|
|
|
- sprintf(cmd, "fatload mmc 0:1 0x%p boot.ini", (void *)p);
|
|
+ sprintf(cmd, "load mmc 0:1 0x%p /boot/boot.ini", (void *)p);
|
|
run_command(cmd, 0);
|
|
|
|
filesize = getenv_ulong("filesize", 16, 0);
|
|
diff --git a/include/configs/odroidc2.h b/include/configs/odroidc2.h
|
|
index 307d643..6c1564b 100755
|
|
--- a/include/configs/odroidc2.h
|
|
+++ b/include/configs/odroidc2.h
|
|
@@ -75,6 +75,13 @@
|
|
#define CONFIG_BOOTDELAY 1 // Seconds
|
|
#define CONFIG_ABORTBOOT_WITH_ENTERKEY
|
|
|
|
+/* Arch Linux ARM */
|
|
+#define CONFIG_CMD_FS_GENERIC
|
|
+#define CONFIG_SUPPORT_RAW_INITRD
|
|
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
|
+#define CONFIG_CMD_PART
|
|
+#define CONFIG_PARTITION_UUIDS
|
|
+
|
|
/* args/envs */
|
|
#define CONFIG_SYS_MAXARGS 64
|
|
|
|
--
|
|
2.8.0
|
|
|