mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
31 lines
1.4 KiB
Diff
31 lines
1.4 KiB
Diff
|
|
# HG changeset patch
|
|
# User Daniel Stenberg <daniel@haxx.se>
|
|
# Date 1484000700 -3600
|
|
# Node ID ebcbf47a83e7d3b89460cf1c991b6be5a79a967b
|
|
# Parent 0759511f24e1b8d42acf5e9612f3ab91715842c2
|
|
Bug 1329272 - add bracket for sed 4.3 compliance, r=glandium
|
|
|
|
diff --git a/build/autoconf/icu.m4 b/build/autoconf/icu.m4
|
|
--- a/build/autoconf/icu.m4
|
|
+++ b/build/autoconf/icu.m4
|
|
@@ -64,17 +64,17 @@ if test -n "$USE_ICU"; then
|
|
icudir="$_topsrcdir/intl/icu/source"
|
|
if test ! -d "$icudir"; then
|
|
icudir="$_topsrcdir/../../intl/icu/source"
|
|
if test ! -d "$icudir"; then
|
|
AC_MSG_ERROR([Cannot find the ICU directory])
|
|
fi
|
|
fi
|
|
|
|
- version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
|
+ version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
|
if test x"$version" = x; then
|
|
AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
|
|
fi
|
|
MOZ_ICU_VERSION="$version"
|
|
|
|
# TODO: the l is actually endian-dependent
|
|
# We could make this set as 'l' or 'b' for little or big, respectively,
|
|
# but we'd need to check in a big-endian version of the file.
|
|
|