mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
71 lines
2.4 KiB
Diff
71 lines
2.4 KiB
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 0ac65fe..71378aa 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -62,7 +62,7 @@ ENDIF()
|
|
# set(CMAKE_CXX_STANDARD 98)
|
|
|
|
IF(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
|
|
- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
|
|
+# SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
|
|
ELSEIF(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
|
|
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98")
|
|
ELSEIF(CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
|
|
@@ -72,7 +72,7 @@ ELSE()
|
|
ENDIF()
|
|
|
|
IF(CMAKE_C_COMPILER_ID STREQUAL "GNU")
|
|
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
|
|
+# SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
|
|
ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "Clang")
|
|
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
|
|
ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "MSVC")
|
|
diff --git a/gnuradio-runtime/lib/math/qa_fxpt.h b/gnuradio-runtime/lib/math/qa_fxpt.h
|
|
index 58a6f02..6020e47 100644
|
|
--- a/gnuradio-runtime/lib/math/qa_fxpt.h
|
|
+++ b/gnuradio-runtime/lib/math/qa_fxpt.h
|
|
@@ -25,6 +25,7 @@
|
|
|
|
#include <cppunit/extensions/HelperMacros.h>
|
|
#include <cppunit/TestCase.h>
|
|
+#include <memory>
|
|
|
|
class qa_fxpt : public CppUnit::TestCase
|
|
{
|
|
diff --git a/gnuradio-runtime/lib/math/qa_fxpt_nco.h b/gnuradio-runtime/lib/math/qa_fxpt_nco.h
|
|
index 1b2cdae..1755904 100644
|
|
--- a/gnuradio-runtime/lib/math/qa_fxpt_nco.h
|
|
+++ b/gnuradio-runtime/lib/math/qa_fxpt_nco.h
|
|
@@ -25,6 +25,7 @@
|
|
|
|
#include <cppunit/extensions/HelperMacros.h>
|
|
#include <cppunit/TestCase.h>
|
|
+#include <memory>
|
|
|
|
class qa_fxpt_nco : public CppUnit::TestCase
|
|
{
|
|
diff --git a/gnuradio-runtime/lib/math/qa_fxpt_vco.h b/gnuradio-runtime/lib/math/qa_fxpt_vco.h
|
|
index 72693f3..76e0b6d 100644
|
|
--- a/gnuradio-runtime/lib/math/qa_fxpt_vco.h
|
|
+++ b/gnuradio-runtime/lib/math/qa_fxpt_vco.h
|
|
@@ -25,6 +25,7 @@
|
|
|
|
#include <cppunit/extensions/HelperMacros.h>
|
|
#include <cppunit/TestCase.h>
|
|
+#include <memory>
|
|
|
|
class qa_fxpt_vco : public CppUnit::TestCase
|
|
{
|
|
diff --git a/gr-fec/include/gnuradio/fec/polar_decoder_common.h b/gr-fec/include/gnuradio/fec/polar_decoder_common.h
|
|
index 13b25ea..8a3d65d 100644
|
|
--- a/gr-fec/include/gnuradio/fec/polar_decoder_common.h
|
|
+++ b/gr-fec/include/gnuradio/fec/polar_decoder_common.h
|
|
@@ -68,7 +68,7 @@ namespace gr {
|
|
bool set_frame_size(unsigned int frame_size){return false;};
|
|
|
|
private:
|
|
- static BOOST_CONSTEXPR_OR_CONST float D_LLR_FACTOR;
|
|
+ static const float D_LLR_FACTOR;
|
|
unsigned int d_frozen_bit_counter;
|
|
|
|
protected:
|