PKGBUILDs/alarm/uboot-odroid/0002-odroid-x-support.patch
2016-07-19 00:43:40 +00:00

40 lines
1.1 KiB
Diff

From fb927d726489ef96f4af524870e74d32ee846140 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 6 Feb 2015 05:40:56 -0700
Subject: [PATCH 2/2] odroid-x support
---
board/samsung/odroid/odroid.c | 2 +-
include/configs/odroid.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/board/samsung/odroid/odroid.c b/board/samsung/odroid/odroid.c
index b4cb332..d025d06 100644
--- a/board/samsung/odroid/odroid.c
+++ b/board/samsung/odroid/odroid.c
@@ -57,7 +57,7 @@ void set_board_type(void)
const char *get_board_type(void)
{
- const char *board_type[] = {"u3", "x2"};
+ const char *board_type[] = {"u3", "x"};
return board_type[gd->board_type];
}
diff --git a/include/configs/odroid.h b/include/configs/odroid.h
index 306ff07..460c796 100644
--- a/include/configs/odroid.h
+++ b/include/configs/odroid.h
@@ -23,7 +23,7 @@
#define CONFIG_MACH_TYPE 4289
-#define CONFIG_NR_DRAM_BANKS 8
+#define CONFIG_NR_DRAM_BANKS 4
#define CONFIG_SYS_SDRAM_BASE 0x40000000
#define SDRAM_BANK_SIZE (256 << 20) /* 256 MB */
#define PHYS_SDRAM_1 CONFIG_SYS_SDRAM_BASE
--
2.8.3