mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
101 lines
3.5 KiB
Diff
101 lines
3.5 KiB
Diff
diff --git c/gcc/doc/cppopts.texi i/gcc/doc/cppopts.texi
|
|
index 5212478..52d5997 100644
|
|
--- c/gcc/doc/cppopts.texi
|
|
+++ i/gcc/doc/cppopts.texi
|
|
@@ -769,7 +769,7 @@ Replacement: [ ] @{ @} # \ ^ | ~
|
|
Enable special code to work around file systems which only permit very
|
|
short file names, such as MS-DOS@.
|
|
|
|
-@itemx --help
|
|
+@item --help
|
|
@itemx --target-help
|
|
@opindex help
|
|
@opindex target-help
|
|
diff --git c/gcc/doc/generic.texi i/gcc/doc/generic.texi
|
|
index 5874c55..79af22f 100644
|
|
--- c/gcc/doc/generic.texi
|
|
+++ i/gcc/doc/generic.texi
|
|
@@ -1415,13 +1415,13 @@ generate these expressions anyhow, if it can tell that strictness does
|
|
not matter. The type of the operands and that of the result are
|
|
always of @code{BOOLEAN_TYPE} or @code{INTEGER_TYPE}.
|
|
|
|
-@itemx POINTER_PLUS_EXPR
|
|
+@item POINTER_PLUS_EXPR
|
|
This node represents pointer arithmetic. The first operand is always
|
|
a pointer/reference type. The second operand is always an unsigned
|
|
integer type compatible with sizetype. This is the only binary
|
|
arithmetic operand that can operate on pointer types.
|
|
|
|
-@itemx PLUS_EXPR
|
|
+@item PLUS_EXPR
|
|
@itemx MINUS_EXPR
|
|
@itemx MULT_EXPR
|
|
These nodes represent various binary arithmetic operations.
|
|
diff --git c/gcc/doc/invoke.texi i/gcc/doc/invoke.texi
|
|
index 4ed31b6..c071595 100644
|
|
--- c/gcc/doc/invoke.texi
|
|
+++ i/gcc/doc/invoke.texi
|
|
@@ -165,7 +165,7 @@ in the following sections.
|
|
-pipe -pass-exit-codes @gol
|
|
-x @var{language} -v -### --help@r{[}=@var{class}@r{[},@dots{}@r{]]} --target-help @gol
|
|
--version -wrapper @@@var{file} -fplugin=@var{file} -fplugin-arg-@var{name}=@var{arg} @gol
|
|
--fdump-ada-spec@r{[}-slim@r{]}} -fdump-go-spec=@var{file}
|
|
+-fdump-ada-spec@r{[}-slim@r{]} -fdump-go-spec=@var{file}}
|
|
|
|
@item C Language Options
|
|
@xref{C Dialect Options,,Options Controlling C Dialect}.
|
|
@@ -5085,11 +5085,11 @@ Dump after duplicating the computed gotos.
|
|
@option{-fdump-rtl-ce3} enable dumping after the three
|
|
if conversion passes.
|
|
|
|
-@itemx -fdump-rtl-cprop_hardreg
|
|
+@item -fdump-rtl-cprop_hardreg
|
|
@opindex fdump-rtl-cprop_hardreg
|
|
Dump after hard register copy propagation.
|
|
|
|
-@itemx -fdump-rtl-csa
|
|
+@item -fdump-rtl-csa
|
|
@opindex fdump-rtl-csa
|
|
Dump after combining stack adjustments.
|
|
|
|
@@ -5100,11 +5100,11 @@ Dump after combining stack adjustments.
|
|
@option{-fdump-rtl-cse1} and @option{-fdump-rtl-cse2} enable dumping after
|
|
the two common sub-expression elimination passes.
|
|
|
|
-@itemx -fdump-rtl-dce
|
|
+@item -fdump-rtl-dce
|
|
@opindex fdump-rtl-dce
|
|
Dump after the standalone dead code elimination passes.
|
|
|
|
-@itemx -fdump-rtl-dbr
|
|
+@item -fdump-rtl-dbr
|
|
@opindex fdump-rtl-dbr
|
|
Dump after delayed branch scheduling.
|
|
|
|
@@ -5149,7 +5149,7 @@ Dump after the initialization of the registers.
|
|
@opindex fdump-rtl-initvals
|
|
Dump after the computation of the initial value sets.
|
|
|
|
-@itemx -fdump-rtl-into_cfglayout
|
|
+@item -fdump-rtl-into_cfglayout
|
|
@opindex fdump-rtl-into_cfglayout
|
|
Dump after converting to cfglayout mode.
|
|
|
|
@@ -5179,7 +5179,7 @@ Dump after removing redundant mode switches.
|
|
@opindex fdump-rtl-rnreg
|
|
Dump after register renumbering.
|
|
|
|
-@itemx -fdump-rtl-outof_cfglayout
|
|
+@item -fdump-rtl-outof_cfglayout
|
|
@opindex fdump-rtl-outof_cfglayout
|
|
Dump after converting from cfglayout mode.
|
|
|
|
@@ -5191,7 +5191,7 @@ Dump after the peephole pass.
|
|
@opindex fdump-rtl-postreload
|
|
Dump after post-reload optimizations.
|
|
|
|
-@itemx -fdump-rtl-pro_and_epilogue
|
|
+@item -fdump-rtl-pro_and_epilogue
|
|
@opindex fdump-rtl-pro_and_epilogue
|
|
Dump after generating the function pro and epilogues.
|
|
|