mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
17 lines
748 B
Diff
17 lines
748 B
Diff
diff --git a/coregrind/m_initimg/initimg-linux.c b/coregrind/m_initimg/initimg-linux.c
|
|
index 30e1f85..387beae 100644
|
|
--- a/coregrind/m_initimg/initimg-linux.c
|
|
+++ b/coregrind/m_initimg/initimg-linux.c
|
|
@@ -703,6 +703,12 @@ Addr setup_client_stack( void* init_sp,
|
|
(and anything above) are not supported by Valgrind. */
|
|
auxv->u.a_val &= VKI_HWCAP_S390_TE - 1;
|
|
}
|
|
+# elif defined(VGP_arm64_linux)
|
|
+ {
|
|
+ /* Linux 4.11 started pupulating this for arm64, but we
|
|
+ currently don't support any. */
|
|
+ auxv->u.a_val = 0;
|
|
+ }
|
|
# endif
|
|
break;
|
|
# if defined(VGP_ppc64be_linux) || defined(VGP_ppc64le_linux)
|