mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-10-29 22:43:48 +00:00
71 lines
1.9 KiB
Diff
71 lines
1.9 KiB
Diff
From 737f6a0e38813727892484840406ad51c48e0687 Mon Sep 17 00:00:00 2001
|
|
From: Marcin Wojtas <mw@semihalf.com>
|
|
Date: Fri, 21 Jul 2017 01:50:36 +0200
|
|
Subject: [PATCH 05/13] ARM64: dts: marvell: armada-37xx: Enable uSD on
|
|
ESPRESSObin
|
|
|
|
The ESPRESSObin board exposes one of the SDHCI interfaces
|
|
via J1 uSD slot. This patch enables it.
|
|
|
|
Tested-by: Miquel Raynal <miquel.raynal@free-electrons.com>
|
|
Signed-off-by: Marcin Wojtas <mw@semihalf.com>
|
|
Signed-off-by: Zbigniew Bodek <zbodek@gmail.com>
|
|
[gregory.clement@free-electrons.com: removed "no-1-8-v"]
|
|
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
|
|
---
|
|
.../boot/dts/marvell/armada-3720-espressobin.dts | 25 ++++++++++++++++++++++
|
|
1 file changed, 25 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
|
|
index b1af3f988b29..2ce52ba74f73 100644
|
|
--- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
|
|
+++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
|
|
@@ -45,6 +45,7 @@
|
|
|
|
/dts-v1/;
|
|
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
#include "armada-372x.dtsi"
|
|
|
|
/ {
|
|
@@ -59,6 +60,20 @@
|
|
device_type = "memory";
|
|
reg = <0x00000000 0x00000000 0x00000000 0x20000000>;
|
|
};
|
|
+
|
|
+ vcc_sd_reg1: regulator {
|
|
+ compatible = "regulator-gpio";
|
|
+ regulator-name = "vcc_sd1";
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ regulator-boot-on;
|
|
+
|
|
+ gpios = <&gpionb 4 GPIO_ACTIVE_HIGH>;
|
|
+ gpios-states = <0>;
|
|
+ states = <1800000 0x1
|
|
+ 3300000 0x0>;
|
|
+ enable-active-high;
|
|
+ };
|
|
};
|
|
|
|
/* J9 */
|
|
@@ -71,6 +86,16 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+/* J1 */
|
|
+&sdhci1 {
|
|
+ wp-inverted;
|
|
+ bus-width = <4>;
|
|
+ cd-gpios = <&gpionb 3 GPIO_ACTIVE_LOW>;
|
|
+ marvell,pad-type = "sd";
|
|
+ vqmmc-supply = <&vcc_sd_reg1>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
/* Exported on the micro USB connector J5 through an FTDI */
|
|
&uart0 {
|
|
status = "okay";
|
|
--
|
|
2.14.1
|
|
|