mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
25 lines
1.2 KiB
Diff
25 lines
1.2 KiB
Diff
From 11071b94eff58eeaf69f2b81afe317b72cd22b54 Mon Sep 17 00:00:00 2001
|
|
From: graysky <therealgraysky@proton.me>
|
|
Date: Sat, 7 May 2022 06:10:06 -0400
|
|
Subject: [PATCH 1/2] mcpu=cortex-xxx application to ffmpeg
|
|
|
|
Get build system to patch ffmpeg source removing the -march= flag
|
|
---
|
|
cmake/modules/FindFFMPEG.cmake | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
|
|
index 9ce807c..a18b21c 100644
|
|
--- a/cmake/modules/FindFFMPEG.cmake
|
|
+++ b/cmake/modules/FindFFMPEG.cmake
|
|
@@ -279,6 +279,7 @@ if(NOT FFMPEG_FOUND)
|
|
${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/FindGnuTls.cmake
|
|
<SOURCE_DIR> &&
|
|
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
|
|
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
|
|
echo "########################################## patched ffmpeg ##############################"
|
|
)
|
|
|
|
--
|
|
2.36.0
|
|
|