PKGBUILDs/core/kernel26/LEDs.patch

69 lines
2.4 KiB
Diff

diff -urN a//arch/arm/mach-kirkwood/guruplug-setup.c b//arch/arm/mach-kirkwood/guruplug-setup.c
--- a//arch/arm/mach-kirkwood/guruplug-setup.c 2010-12-09 15:17:27.000000000 -0700
+++ b//arch/arm/mach-kirkwood/guruplug-setup.c 2010-12-18 00:50:13.409176002 -0700
@@ -19,7 +19,6 @@
#include <asm/mach-types.h>
#include <asm/mach/arch.h>
#include <mach/kirkwood.h>
-#include <plat/mvsdio.h>
#include "common.h"
#include "mpp.h"
@@ -57,12 +56,14 @@
static struct gpio_led guruplug_led_pins[] = {
{
- .name = "guruplug:red:health",
+ .name = "status:red:fault",
+ .default_trigger = "none",
.gpio = 46,
.active_low = 1,
},
{
- .name = "guruplug:green:health",
+ .name = "status:green:health",
+ .default_trigger = "default-on",
.gpio = 47,
.active_low = 1,
},
diff -urN a//arch/arm/mach-kirkwood/Kconfig b//arch/arm/mach-kirkwood/Kconfig
--- a//arch/arm/mach-kirkwood/Kconfig 2010-12-09 15:17:27.000000000 -0700
+++ b//arch/arm/mach-kirkwood/Kconfig 2010-12-18 00:50:13.369176001 -0700
@@ -64,6 +64,12 @@
QNAP TS-410, TS-410U, TS-419P and TS-419U Turbo NAS
devices.
+config MACH_GOFLEXNET
+ bool "Seagate GoFlex Net"
+ help
+ Say 'Y' here if you want your kernel to support the
+ Seagate GoFlex Net.
+
config MACH_OPENRD
bool
diff -urN a//arch/arm/mach-kirkwood/Makefile b//arch/arm/mach-kirkwood/Makefile
--- a//arch/arm/mach-kirkwood/Makefile 2010-12-09 15:17:27.000000000 -0700
+++ b//arch/arm/mach-kirkwood/Makefile 2010-12-18 00:50:13.369176001 -0700
@@ -9,6 +9,7 @@
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
obj-$(CONFIG_MACH_TS219) += ts219-setup.o tsx1x-common.o
+obj-$(CONFIG_MACH_GOFLEXNET) += goflexnet-setup.o
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
obj-$(CONFIG_MACH_NETSPACE_V2) += netspace_v2-setup.o
diff -urN a//arch/arm/mach-kirkwood/sheevaplug-setup.c b//arch/arm/mach-kirkwood/sheevaplug-setup.c
--- a//arch/arm/mach-kirkwood/sheevaplug-setup.c 2010-12-09 15:17:27.000000000 -0700
+++ b//arch/arm/mach-kirkwood/sheevaplug-setup.c 2010-12-18 00:50:13.409176002 -0700
@@ -58,7 +58,7 @@
static struct gpio_led sheevaplug_led_pins[] = {
{
- .name = "plug:green:health",
+ .name = "status:green:health",
.default_trigger = "default-on",
.gpio = 49,
.active_low = 1,